Subject: [Ietf-and-github] Simple WG policy for document management

From: Paul Hoffman <[email-masked]>
Date: Mon, 21 Oct 2019 17:50:28 +0000

Greetings again. First, a big thank-you to Martin and Barbara for adding Section 5 to https://datatracker.ietf.org/doc/draft-ietf-git-using-github/ . I hope everyone in the WG looks at the revisions in document, particularly this new sections.

The new 5.1 seems limited to me, or maybe I would want an additional level between 5.1 and 5.2. In many WGs, I find that people want to do document management using GitHub but not issue tracking, but they want WG participants to be able to contribute text in the repo instead of just on the list. This is particularly useful for "please add a few sentences about $x" and "that paragraph was unclear, I think this would be better". Thus, I'd like to either see 5.1 be expanded to allow PRs from the WG, or a new section 5.2 inserted that is 5.1 plus WG PRs.

Does this match with what others have found in WGs that are just using GitHub for document management and pre-draft-revision change tracking?

--Paul Hoffman

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 22 Oct 2019 14:33:33 +1100

On Tue, Oct 22, 2019, at 04:50, Paul Hoffman wrote:
> [...] I'd like to either see 5.1 be expanded to allow PRs 
> from the WG, or a new section 5.2 inserted that is 5.1 plus WG PRs.

https://github.com/ietf-gitwg/using-github/pull/new/light-pr does the former, which I think makes the most sense here.  That is, it allows editors to manage the document as they see fit, using the tools available, but doesn't confer any special status to those tools.

As Paul observes, the text could have been read to imply that editors can't use pull requests at all.  That was never the intention.

> Does this match with what others have found in WGs that are just using 
> GitHub for document management and pre-draft-revision change tracking?

Yeah, this matches what I've seen in practice.