Subject: [Ietf-and-github] Redirection

From: Rob Sayre <[email-masked]>
Date: Mon, 4 Nov 2019 21:52:14 -0800

Hi,

I noticed another interesting case to consider.

When is it appropriate to tell a GitHub commenter to write the mailing
list? Or, on the mailing list, to open a GitHub issue?

thanks,
Rob

---

From: Mike Bishop <[email-masked]>
Date: Tue, 5 Nov 2019 16:39:16 +0000

Personal opinion from HTTP and QUIC:  When an issue proposes a dramatic change to the protocol rather than a flaw in the document/design, editors and chairs will often suggest taking it to the mailing list to generate broader discussion.  Or if discussion on the issue is mostly between two participants who aren’t reaching agreement, taking it to the mailing list is encouraged to gather further input and break the deadlock.

The issues list is the list of things we think still need work in the document.  If the mailing list discussion dies down and it’s not on the issues list, it’s easy to forget.  Either the editor needs to be responsible for opening issues to reflect things raised on the mailing list, or they need to direct the commenter to do so.  But regardless, such discussions need to make it to GitHub somehow if that’s how the editors are tracking issues.  Note that this sometimes becomes an effective “pocket veto” for the group, where suggestions that don’t gain much traction on the list just don’t get issues created.

From: Ietf-and-github <[email-masked]> On Behalf Of Rob Sayre
Sent: Tuesday, November 5, 2019 12:52 AM
To: [email-masked]
Subject: [Ietf-and-github] Redirection

Hi,

When is it appropriate to tell a GitHub commenter to write the mailing list? Or, on the mailing list, to open a GitHub issue?

thanks,
Rob