Subject: [Ietf-and-github] WGLC: draft-ietf-git-using-github-02

From: Mike Bishop <[email-masked]>
Date: Tue, 3 Dec 2019 22:05:16 +0000

In section 3.2/3.3, it might be worth mentioning that GitHub has a feature<https://help.github.com/en/github/creating-cloning-and-archiving-repositories/about-code-owners> for the owners/administrators to give certain user(s) control of individual files, despite the global write access that contributors have.  This means it's possible to configure the SHOULD NOT on GitHub, rather than relying on everyone's good behavior.  I think this configuration should be RECOMMENDED for multi-document repos.

In section 4.0, we should probably include a reminder that, regardless of the from of contribution, all contributions are covered by the Note Well.  (I know that's implied by the term, but it's worth being explicit.)

In section 4.3, is it truly the WG that provides these facilities at the chair's request?  This seems like something that either a) chairs MAY configure independently at the WG's request, or b) something that the IETF would provide at the chair's request.  The latter seems the most sensible, but does represent a requirement for new functionality.

In Section 7, I'm not certain about the "greater time commitment" reasoning.  There is an identical level of traffic coming into your inbox regardless of whether the incoming deluge is e-mail or GitHub notifications.  And in fact, exactly the same discussions that take place on GitHub could take place on the mailing list.  The fact that GitHub facilitates a greater pace of interaction and therefore generates a greater volume of traffic is really what we're alluding to here.  GitHub helps working groups work more quickly, and quicker work risks leaving some people behind.

I second the comment that Section 10 is a bit over-the-top for a document we intend to publish as having IETF consensus.  GitHub doesn't speak IPv6.  This makes us sad.  It's still useful.  Hyperbole serves no useful purpose here.

Appendix A.2 states that the quicwg has only two repos, but it in fact has three.  Another example of the ops drafts being ignored.

-----Original Message-----

From: Ietf-and-github <[email-masked]> On Behalf Of [email-masked]

Sent: Tuesday, November 19, 2019 3:02 AM

To: [email-masked]

Cc: [email-masked]

Subject: [Ietf-and-github] I-D Action: draft-ietf-git-using-github-02.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

This draft is a work item of the GitHub Integration and Tooling WG of the IETF.

        Title           : Using GitHub at the IETF

        Authors         : Martin Thomson

                          Barbara Stark

               Filename        : draft-ietf-git-using-github-02.txt

               Pages           : 27

               Date            : 2019-11-18

Abstract:

   This document describes best practices for Working Groups that use

   GitHub for their work.

The IETF datatracker status page for this draft is:

https://datatracker.ietf.org/doc/draft-ietf-git-using-github/

There are also htmlized versions available at:

https://tools.ietf.org/html/draft-ietf-git-using-github-02

https://datatracker.ietf.org/doc/html/draft-ietf-git-using-github-02

A diff from the previous version is available at:

https://www.ietf.org/rfcdiff?url2=draft-ietf-git-using-github-02

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:

ftp://ftp.ietf.org/internet-drafts/

_______________________________________________

Ietf-and-github mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/ietf-and-github

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 04 Dec 2019 16:33:35 +1100

Thanks for reviewing Mike,

Your PR is: https://github.com/ietf-gitwg/using-github/pull/36

On Wed, Dec 4, 2019, at 09:05, Mike Bishop wrote:
> In section 3.2/3.3, it might be worth mentioning that GitHub  has a 
> feature 
> <https://help.github.com/en/github/creating-cloning-and-archiving-repositories/about-code-owners> for the owners/administrators to give certain user(s) control of individual files, despite the global write access that contributors have. This means it's possible to configure the SHOULD NOT on GitHub, rather than relying on everyone's good behavior. I think this configuration should be RECOMMENDED for multi-document repos.

That's a relatively new feature.  One that I note we aren't using in the two multi-document repositories I'm involved in.  I don't know enough about the limitations of that to say whether a recommendation there is a good idea or not.  At some level, I'm concerned that it will encourage more WGs to create single repositories, which I think are terrible.  That's probably not a great reason not to include it, but lack of experience with it should be.

> In section 4.0, we should probably include a reminder that, regardless 
> of the from of contribution, all contributions are covered by the Note 
> Well. (I know that’s implied by the term, but it’s worth being 
> explicit.)

In https://github.com/ietf-gitwg/using-github/pull/33 in response to Rich's review I moved that around a little.  The emphasis being on the notices and not the contributions.  Is that the wrong angle?  Both of you picked Section 4.
 
> In section 4.3, is it truly the WG that provides these facilities at 
> the chair’s request? This seems like something that either a) chairs 
> MAY configure independently at the WG’s request, or b) something that 
> the IETF would provide at the chair’s request. The latter seems the 
> most sensible, but does represent a requirement for new functionality.

I struck the paragraph.  I don't think that we can say (yet) who needs to run that infrastructure.  That's a question we can resolve outside of a published document.

> In Section 7, I’m not certain about the “greater time commitment” 
> reasoning. There is an identical level of traffic coming into your 
> inbox regardless of whether the incoming deluge is e-mail or GitHub 
> notifications. And in fact, exactly the same discussions that take 
> place on GitHub *could* take place on the mailing list. The fact that 
> GitHub facilitates a greater pace of interaction and therefore 
> generates a greater volume of traffic is really what we’re alluding to 
> here. GitHub helps working groups work more quickly, and quicker work 
> risks leaving some people behind.

I'll reword.

> Appendix A.2 states that the quicwg has only two repos, but it in fact 
> has three. Another example of the ops drafts being ignored.

\o/  There are also other repositories now.

See my other email.  I don't know how much editorial control I can exercise over this text.  I think that I'd rather remove these sections now that they have done their jobs.

---

From: Mike Bishop <[email-masked]>
Date: Wed, 4 Dec 2019 15:40:50 +0000

True, lack of experience with CODEOWNERS might keep us from recommending it.  Noting its presence and potential usefulness, however, seems reasonable.  It might be worth turning it on in QUIC so that we can get some experience with it and have a more informed opinion.

-----Original Message-----
From: Ietf-and-github <[email-masked]> On Behalf Of Martin Thomson
Sent: Wednesday, December 4, 2019 12:34 AM
To: [email-masked]
Subject: Re: [Ietf-and-github] WGLC: draft-ietf-git-using-github-02

 

I'll reword.

---

From: Mike Bishop <[email-masked]>
Date: Wed, 4 Dec 2019 19:37:56 +0000

Separately, I note that you didn't respond to the feedback on Section 10 and haven't in any previous WGLC feedback e-mail either.  Do you and the chairs believe that we have working group consensus for such a hyperbolic statement?  I don't believe this text in this form should be sent out for IETF Last Call or IESG review.

In the spirit of the working group, I've submitted a PR with less dramatic language as https://github.com/ietf-gitwg/using-github/pull/37.

-----Original Message-----
From: Ietf-and-github <[email-masked]> On Behalf Of Martin Thomson
Sent: Wednesday, December 4, 2019 12:34 AM
To: [email-masked]
Subject: Re: [Ietf-and-github] WGLC: draft-ietf-git-using-github-02

 

I'll reword.

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 05 Dec 2019 08:17:56 +1100

On Thu, Dec 5, 2019, at 06:37, Mike Bishop wrote:
> Separately, I note that you didn't respond to the feedback on Section 
> 10 and haven't in any previous WGLC feedback e-mail either.  Do you and 
> the chairs believe that we have working group consensus for such a 
> hyperbolic statement?  I don't believe this text in this form should be 
> sent out for IETF Last Call or IESG review.

I just removed the section as part of my response to Rich's review.

---

From: Mike Bishop <[email-masked]>
Date: Wed, 4 Dec 2019 22:00:55 +0000

All good, then.  Thanks!  😊

-----Original Message-----
From: Ietf-and-github <[email-masked]> On Behalf Of Martin Thomson
Sent: Wednesday, December 4, 2019 4:18 PM
To: [email-masked]
Subject: Re: [Ietf-and-github] WGLC: draft-ietf-git-using-github-02

> 10 and haven't in any previous WGLC feedback e-mail either.  Do you

> and the chairs believe that we have working group consensus for such a

> hyperbolic statement?  I don't believe this text in this form should

> be sent out for IETF Last Call or IESG review.

[email-masked]<mailto:[email-masked]>