Subject: [Ietf-and-github] Anecdotal appendices in draft-ietf-git-using-github

From: "Martin Thomson" <[email-masked]>
Date: Wed, 04 Dec 2019 16:12:10 +1100

I've never really known what to do with these sections.  As input to the process of this working group, they are useful, but I'm not sure how much value we get out of creating a publication with this content.

What do people think about removing these?

Proposal: https://github.com/ietf-gitwg/using-github/pull/35

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 4 Dec 2019 15:57:23 +0000

>    I've never really known what to do with these sections.  As input to the process of this working group, they are useful, but I'm not sure how much value we get out of creating a publication with…

Other groups have done 'use cases' drafts that are never intended for publication; that seems to make sense here.

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 4 Dec 2019 17:57:00 +0000

> What do people think about removing these?

<not wearing a chair hat> Removing them seems fine, given how quickly they will become out-of-date.

--Paul Hoffman

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 4 Dec 2019 20:24:52 +0000

> From: Paul Hoffman
> > I've never really known what to do with these sections.  As input to the
> process of this working group, they are useful, but I'm not sure how much
> value we get out of creating a publication with this content.
> >

As written, I agree they aren't content I'd like to keep. However, I think it would be really useful to have some non-WG-specific "sample GitHub usages" based on these, to help WG chairs more concretely understand some of their options. I'd be happy to take a stab at writing up one or two such samples to see what people think.

Alternately, we could put such samples in the GitHub tutorial (which, now that I think of that, would probably be the better place). Which reminds me I got distracted and forgot to provide input to that.
Barbara

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 05 Dec 2019 08:44:59 +1100

On Thu, Dec 5, 2019, at 07:24, STARK, BARBARA H wrote:
> Alternately, we could put such samples in the GitHub tutorial (which, 
> now that I think of that, would probably be the better place). Which 
> reminds me I got distracted and forgot to provide input to that.

That seems like a great way to approach this.  Would it make sense to just copy the anecdotes directly for the moment?

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 4 Dec 2019 22:12:30 +0000

> From: Martin Thomson <[email-masked]>
> That seems like a great way to approach this.  Would it make sense to just
> copy the anecdotes directly for the moment?

I think that would be quite reasonable.
Barbara

---

From: Fred Baker <[email-masked]>
Date: Wed, 4 Dec 2019 14:23:46 -0800

> On Dec 4, 2019, at 1:44 PM, Martin Thomson <[email-masked]> wrote:
> 

Well, in a form that a working group chair can ask his/her working group to ratify and use.

> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github