Subject: Re: [Ietf-and-github] WGLC: draft-ietf-git-using-github-02

From: "Salz, Rich" <[email-masked]>
Date: Wed, 4 Dec 2019 02:27:06 +0000

*   In section 4.0, we should probably include a reminder that, regardless of the from of contribution, all contributions are covered by the Note Well.  (I know that’s implied by the term, but it’s worth being explicit.)

And perhaps instruct the repo managers to make this clear and explicit.

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 04 Dec 2019 14:36:11 +1100

Hi Rich,

I realize now that a lot of the associated text moved to the other document, which isn't ideal.  We should at least mandate the inclusion of the IPR and copyright notices.  I've done that, along with consolidating some of the text into the "Communicating Policies" section (2.2).

https://github.com/ietf-gitwg/using-github/pull/33

The relevant text being:

> In addition to Working Group policies, notices on repositories MUST include citations for BCPs 78 and 79 ([ref], [ref]) and other IETF contribution policies.  A copy or reference to the [IETF Note Well](link) is appropriate. 

I can add a reminder and back-reference to Section 4 in addition to that section if you think that would help.

Cheers,
Martin

On Wed, Dec 4, 2019, at 13:27, Salz, Rich wrote:
>  
>  * In section 4.0, we should probably include a reminder that, 
> regardless of the from of contribution, all contributions are covered 
> by the Note Well. (I know that’s implied by the term, but it’s worth 
> being explicit.)
> 
> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github
>

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 4 Dec 2019 03:59:52 +0000

>    https://github.com/ietf-gitwg/using-github/pull/33
 
Looks good; I put a clarifying question in the PR.