Subject: Re: [Ietf-and-github] WGLC for draft-ietf-git-github-wg-configuration

From: Tim Wicinski <[email-masked]>
Date: Wed, 4 Dec 2019 17:30:06 -0500

One comment I have on this document - it discusses the files that need to
be included with any working group.
Should we not have a default Organization with all correct files (Note
Well., Contributing, etc) created that
can be used as a default for new working groups?

Tim

On Tue, Nov 19, 2019 at 4:25 AM Christopher Wood <[email-masked]>
wrote:

> This is the working group last call for
> draft-ietf-git-github-wg-configuration [1]. Due to upcoming holidays, it
> will run until December 13. Please review the document and send your
> comments to the list by then.
>
> Thanks,
> Chris
>
> [1]
> https://datatracker.ietf.org/doc/draft-ietf-git-github-wg-configuration/
>
> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github
>

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 05 Dec 2019 15:18:31 +1100

Unlike repositories, organisations can't be created from a template. There might be cause to have templates for common repository shapes, but we have to rely on things like Rich Salz's setup tool for this. 

On Thu, Dec 5, 2019, at 09:30, Tim Wicinski wrote:
> 
> One comment I have on this document - it discusses the files that need 
> to be included with any working group.
> On Tue, Nov 19, 2019 at 4:25 AM Christopher Wood <[email-masked]> wrote:
> > This is the working group last call for draft-ietf-git-github-wg-configuration [1]. Due to upcoming holidays, it will run until December 13. Please review the document and send your comments to the list by then.
> > 
> >  Thanks,
> >  Chris
> > 
> >  [1] https://datatracker.ietf..org/doc/draft-ietf-git-github-wg-configuration/ <https://datatracker.ietf.org/doc/draft-ietf-git-github-wg-configuration/>
> >

---

From: Tim Wicinski <[email-masked]>
Date: Wed, 4 Dec 2019 23:58:22 -0500

Oh true.  As I was reading these I was feeling a new WG chair may be
looking for a reference
to Rich's fine work.

On Wed, Dec 4, 2019 at 11:19 PM Martin Thomson <[email-masked]> wrote:

> Unlike repositories, organisations can't be created from a template. There
> might be cause to have templates for common repository shapes, but we have
> to rely on things like Rich Salz's setup tool for this.
>
> > >  [1] https://datatracker.ietf..org/doc/draft-ietf-git-github-wg-configuration/
> <https://datatracker.ietf.org/doc/draft-ietf-git-github-wg-configuration/>
> > >

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 5 Dec 2019 05:04:24 +0000

>    [1] https://datatracker.ietf.org/doc/draft-ietf-git-github-wg-configuration/
 
I read this document.  I dislike ietf-<wgname>-wg as the naming convention, preferring a pure top-down approach of ietf-wg-<wgname>.

I am also confused by statements like the IETF should regularly backup all repositories.  Who is signing up to do that?

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 5 Dec 2019 00:08:42 -0500

if we do ietf-wg-<wgname> then we can do ietf-bof-<name> ietf-iab-<foo>. etc

that does have some advantages.

On Thu, Dec 5, 2019 at 12:04 AM Salz, Rich <[email-masked]> wrote:

> I read this document.  I dislike ietf-<wgname>-wg as the naming
> convention, preferring a pure top-down approach of ietf-wg-<wgname>.
>
> I am also confused by statements like the IETF should regularly backup all
> repositories.  Who is signing up to do that?
>
>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 5 Dec 2019 15:11:38 +0000

*   if we do ietf-wg-<wgname> then we can do ietf-bof-<name> ietf-iab-<foo>. Etc

Yes, exactly.  I was thinking ietf-area-{sec,ops,etc} also.

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 5 Dec 2019 10:30:34 -0500

Hi Rich,

> On Dec 5, 2019, at 12:04 AM, Salz, Rich <[email-masked]> wrote:
> 

The IETF Secretariat.

Alissa

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 5 Dec 2019 15:38:39 +0000

> The IETF Secretariat.

Cool.

Next question, which I should have asked in the same note to avoid a round-trip :)  How are they notified when a new repo gets created?  That should probably be in the doc.

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 11 Dec 2019 00:02:20 +0000

Sorry for the vacation-delayed reply. Please see
   https://github.com/ietf-gitwg/draft-ietf-git-github-wg-configuration/pull/10
for a proposed change that deals with both of Rich's issues: default repo naming and having the IETF Secretariat know which repos to back up.

--Paul Hoffman

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 11 Dec 2019 11:51:42 +1100

> https://github.com/ietf-gitwg/draft-ietf-git-github-wg-configuration/pull/10

Thanks Paul.  This looks good.

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 11 Dec 2019 02:26:54 +0000

On 12/10/19, 7:52 PM, "Martin Thomson" <[email-masked]> wrote:

Ditto.

---

From: "Christopher Wood" <[email-masked]>
Date: Mon, 16 Dec 2019 09:32:42 -0800

Thanks for all who read the document and provided feedback! The last call is now finished.  We'll merge the PRs that came up during the call, spin a new version, and then move the document onwards to the IESG. 

Best,
Chris

On Tue, Nov 19, 2019, at 1:24 AM, Christopher Wood wrote:
> draft-ietf-git-github-wg-configuration [1]. Due to upcoming holidays, 
> it will run until December 13. Please review the document and send your