Subject: [Ietf-and-github] Using GitHub Actions

From: "Martin Thomson" <[email-masked]>
Date: Fri, 10 Jul 2020 17:16:38 +1000

Anyone using the latest version of https://github.com/martinthomson/i-d-template will get support for GitHub Actions.

The main advantage of this change is that you don't need to setup CI to get an Editor's Copy that updates with every commit, or draft submission using a tag.  No more messing around with tokens and setting up separate systems.

Results look like this: https://github.com/martinthomson/rfced-model/actions
and this: https://martinthomson.github.io/rfced-model/draft-thomson-rfced-model.html

Anyone looking to convert can copy the necessary files into place:

# Get the latest
git -C lib fetch origin main
git -C lib checkout -f main
make update

# Copy the files
cp -R lib/template/.github .
git add .github
git commit
git push

Of course, now isn't necessarily the time to experiment, but I thought that I would share.  Also, there are a few open issues with archiving issues and pull requests, but I hope to fix those shortly and they don't affect normal operation.

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 13 Jul 2020 04:06:56 +0100

This is great, thank you.

I've just tested on a fresh repo and this worked first time with no
hitches, much better than fiddling with CircleCI.

Cheers
Lucas

On Fri, Jul 10, 2020 at 8:17 AM Martin Thomson <[email-masked]> wrote:

> Anyone using the latest version of
> https://github.com/martinthomson/i-d-template will get support for GitHub
> Actions.
>
> The main advantage of this change is that you don't need to setup CI to
> get an Editor's Copy that updates with every commit, or draft submission
> using a tag.  No more messing around with tokens and setting up separate
> systems.
>
> Results look like this:
> https://github.com/martinthomson/rfced-model/actions
> and this:
> https://martinthomson.github.io/rfced-model/draft-thomson-rfced-model.html
>
> Of course, now isn't necessarily the time to experiment, but I thought
> that I would share.  Also, there are a few open issues with archiving
> issues and pull requests, but I hope to fix those shortly and they don't
> affect normal operation.
>
>