Subject: [Ietf-hub-bangalore] IP hop by hop routing with TE

From: sujay gupta <[email-masked]>
Date: Wed, 4 May 2016 17:07:30 -0700

Hi Group

I am trying to do a hop by hop IP routing with guaranteed/reserved
bandwidth for a certain traffic class.

The decision should be dynamic, so i will need some IGP or EGP TE extension.

So how can I do this with a central controller? (PCE??)
And can I do this without a central controller ( equivalent to MPLS;RSVP
-TE but without MPLS)

Any thoughts?

Regards,
-Sujay

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 5 May 2016 17:44:12 +0530

Hi Sujay,

PCE *currently* works well with MPLS (RSVP-TE signaling or Segement Routing
without signalling).

If no MPLS, checkout https://datatracker.ietf.org/doc/rfc3272/ which might
give you some ideas.

Regards,
Dhruv

On Thu, May 5, 2016 at 5:37 AM, sujay gupta <[email-masked]> wrote:

> _______________________________________________
> Ietf-hub-bangalore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-hub-bangalore
>
>

---

From: sujay gupta <[email-masked]>
Date: Fri, 6 May 2016 06:26:09 -0700

HI Dhruv

Thanks for the link it is a good introduction and relevant details on the
TE.

So when you say PCE works currently with MPLS, I would typically need a
controller (PCEP controller) with a TE database and BGP-LS
for feeding the information, right?

Which comes to the next question after PCEP controller has the TED, is
running a CSPF path a part of the PCEP role, or an application has to be
build over it?

My use case is a single IGP domain requiring light-weight TE.

Hence my choice would be a constraint based source routing mechanism. The
intelligence for which can be calculated using OSPF-TE or ISIS-TE, but the
question
remains is how do set up the transport path without MPLS.

Regards,
-Sujay

On Thu, May 5, 2016 at 5:14 AM, Dhruv Dhody <[email-masked]> wrote:

> Hi Sujay,
>
> PCE *currently* works well with MPLS (RSVP-TE signaling or Segement
> Routing without signalling).
>
> If no MPLS, checkout https://datatracker.ietf.org/doc/rfc3272/ which
> might give you some ideas.
>
> Regards,
> Dhruv
>

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 6 May 2016 19:38:51 +0530

Hi Sujay,

> for feeding the information, right?

​Yes!
​

> running a CSPF path a part of the PCEP role, or an application has to be

​Both option exist. For in case of ODL, the application decides the path,
in some controller the path computation algorithm is built in. ​

> remains is how do set up the transport path without MPLS.

The protocol "PCEP" might not help you, but what if after computing the
path you use openflow to set the "flow" (in MPLS we would call that LSP) on
each node.

Another option would be SR with IPv6 in data plane.

​and then there is this - https://tools.ietf.org/html/draft-ietf-isis-pcr-05
and http://www.ieee802.org/1/pages/802.1ca.html

Hope this helps!

Regards,
Dhruv​

---

From: sujay gupta <[email-masked]>
Date: Fri, 6 May 2016 15:46:11 -0700

Hi Dhruv,

Good idea on using SR, but which PCE controller has inbuilt application for
constraint based routing?

Regards.
-Sujay

On Fri, May 6, 2016 at 7:08 AM, Dhruv Dhody <[email-masked]> wrote:

> ​and then there is this -
> https://tools.ietf.org/html/draft-ietf-isis-pcr-05 and
> http://www.ieee802.org/1/pages/802.1ca.html
>
> Hope this helps!
>
> Regards,
> Dhruv​
>
>
>
>> Regards,
>> -Sujay
>>
>>
>>
>>
>>
>>>> And can I do this without a central controller ( equivalent to
>>>> MPLS;RSVP -TE but without MPLS)
>>>>
>>>> Any thoughts?
>>>>
>>>> Regards,
>>>> -Sujay
>>>>

---

From: Dhruv Dhody <[email-masked]>
Date: Sat, 7 May 2016 10:24:14 +0530

Hi Sujay,

Currently we are working on ONOS G release to have CSPF and PCE built in.
But you do need to figure out which southbound to use? Can OF carry Ipv6-SR
header?

Regards,
Dhruv

On Sat, May 7, 2016 at 4:16 AM, sujay gupta <[email-masked]> wrote:

> Hi Dhruv,
>
> Good idea on using SR, but which PCE controller has inbuilt application
> for constraint based routing?
>
> Regards.
> -Sujay
>
>
>
>>> Thanks for the link it is a good introduction and relevant details on
>>> the TE.
>>>
>>> Hence my choice would be a constraint based source routing mechanism.
>>> The intelligence for which can be calculated using OSPF-TE or ISIS-TE, but
>>> the question

---

From: sujay gupta <[email-masked]>
Date: Sat, 7 May 2016 00:04:05 -0700

Hi Dhruv

That's good. I believe if I have a constrained route map, i can program a
openflow directed path all across like how routeflow does.
The challenge will remain if the switches are running both OF and legacy
routing, where a label concept to distinguish constrained traffic needs to
come.
(& hence back to MPLS etc.)

But yes all the discussion we had is useful.

Regards,
-Sujay

On Fri, May 6, 2016 at 9:54 PM, Dhruv Dhody <[email-masked]> wrote:

>>> ​Both option exist. For in case of ODL, the application decides the
>>> path, in some controller the path computation algorithm is built in. ​
>>>
>>>
>>>
>>>>