Subject: [EAI] Determine for EAI to meet at IETF83 or not

From: Joseph Yee <[email-masked]>
Date: Tue, 31 Jan 2012 05:11:36 -0500

All,

I made a session request for EAI at upcoming IETF (see attached).  However, it's likely that John and I would not be in Paris.  I would like to ask who will go to Paris, and what issues are the WG facing that we need a face to face meeting to resolve.  Having a meeting or not will be determined by attendance and issues at hand.  If there will be meeting in Paris, then I will ask for volunteers to help hosting the session.

Regards,
Joseph, co-chair EAI

Subject: eai - New Meeting Session Request for IETF 83
From: IETF Meeting Session Request Tool <[email-masked]>
To: [email-masked]
Cc: [email-masked],[email-masked],[email-masked],[email-masked]
Date: Mon, 30 Jan 2012 13:52:45 -0800 (PST)

A new meeting session request has just been submitted
by Joseph Yee, a working group chair of eai.

---------------------------------------------------------
Working Group Name: eai
Area Name: Applications Area
Session Requester: Joseph Yee

Number of Sessions: 1
Length of Session(s):  2 hours

Number of Attendees: 50
Conflicts to Avoid:
  First Priority: apparea iri sieve marf dnsext hybi httpbis precis ftpext2 urnbis kitten abfab appsawg repute
  Second Priority: dnsop vcarddav decade 
  BOF or IRTF Session: WEIRD (if became BOF), and all other BOFs in app-area

Special Requests:
  additional 2nd priority conflict to avoid: all other APP area WGs and BOFs<br><br>thanks
---------------------------------------------------------

---

From: John C Klensin <[email-masked]>
Date: Tue, 31 Jan 2012 05:39:01 -0500

--On Tuesday, January 31, 2012 05:11 -0500 Joseph Yee
<[email-masked]> wrote:

> All,
> 
> I made a session request for EAI at upcoming IETF (see
> attached).  However, it's likely that John and I would not be
> in Paris.  I would like to ask who will go to Paris, and what
> issues are the WG facing that we need a face to face meeting
> to resolve.  Having a meeting or not will be determined by
> attendance and issues at hand.  If there will be meeting in
> Paris, then I will ask for volunteers to help hosting the
> session.

Writing as participant more than as co-chair...

The four core documents are in AUTH48 now and nearing
publication (for most of them, I think we are finished as soon
as some additional folks sign off).  One of the causes of delay
is that the editing process and AUTH48 review made it clear that
WG participants didn't read these drafts nearly carefully
enough.  Some of the problems were just silly and easily
corrected, but those problems should not have remained in the
documents going into Last Call, much less being caught at AUTH48
(example: several of the references to 5335bis from the other
documents had the wrong title and author list).  Others were
more substantive (e.g., some confusion about our actual order of
preferences in part of 5336bis).   We are getting them fixed up
(or deciding to let them go), but the fact that they weren't
caught earlier says very bad things about the quality of the
WG's reviews.

We have claimed that the POP, IMAP, and POP-IMAP-downgrade
documents are just about ready to go.  There are no outstanding
consensus call issues on any of them.  If people can read them
now, identify any issues and have enough discussion start
getting any issues resolved, we can issue a WG Last Call and
have those documents in IETF Last Call before Paris.  On the
other hand, the experience with the core documents is going to
make me, and I presume Joseph and Pete, very wary of forwarding
documents into IETF Last Call unless there is evidence of
significantly more careful review than we saw the last time
around.

If we cannot get a more appropriate level of review and
discussion for the next three documents, my recommendation to
Joseph and Pete will be that we shut down the WG (or put it on a
long vacation) rather than trying to move forward with the other
documents.

If we can get the next three documents into or past IETF Last
Call (good news) and we conclude that the WG should not start
other work (opinions may differ on whether that would be good or
bad news), then there will certainly be no reason to meet in
Paris.

best,
    john

---

From: [email-masked]
Date: Tue, 31 Jan 2012 13:08:19 -0800 (PST)

> long vacation) rather than trying to move forward with the other

I have to agree with John about this. I will also observe that when you get
right down to it, the present set of documents are in fact technically fairly
simple and straightforward in their approach. (And this is a good thing.)

But the same most certainly cannot be said for any of these last three
documents, most especially the downgrade specification. If these documents do
not receive extensive and careful technical review I have to agree that the
best thing to do is to abandon then for now. Breakage in any of these things is
a sure recipe for a near-endless set of long term issues.

				Ned

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Wed, 1 Feb 2012 00:02:06 +0100

Which documents, exactly, should I review? I ask because when I googled for eai imap I found one which expired in June 2010. I can review it, fine, but I have a nasty feeling that I am again looking at an obsolete document.

Arnt

---

From: Joseph Yee <[email-masked]>
Date: Tue, 31 Jan 2012 18:26:37 -0500

Hi Arnt,

All EAI documents are available at IETF WG page:
http://datatracker.ietf.org/wg/eai/

The most recent IMAP draft published at 2011-12-26 (day after Christmas).

Best
Joseph

On Tue, Jan 31, 2012 at 6:02 PM, Arnt Gulbrandsen
<[email-masked]>wrote:

> Which documents, exactly, should I review? I ask because when I googled
> for eai imap I found one which expired in June 2010. I can review it, fine,
> but I have a nasty feeling that I am again looking at an obsolete document.
>
> Arnt
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima
>
>

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Wed, 1 Feb 2012 00:50:46 +0100

I chased some links.

5738bis does not say what happens if a server advertises utf8=only and a client uses mutf7. I suggest a mandatory NO (rendering that part if the namespace inaccessible forever). I like 5738bis otherwise.

I am not capable of judging the pop document tonight. I found the irrelevant LANG feature too aggravating.

Downgrade is, IMHO, rather too complex. It seems to be very god work, but so complex. Does downgrade really need to be that good? I like the address treatment, and subject needs to be downgraded, but the rest? It's a lot of work, a great many test cases, and I fear that the only people who care are the ones who implement EAI and never need the downgraded version.

Arnt

---

From: "Jiankang YAO" <[email-masked]>
Date: Wed, 1 Feb 2012 11:01:07 +0800

If there are some important issue to be discussed, I think that it should be pop-imap-downgrade issue.

Anyway, I will be in Paris.

Jiankang Yao

----- Original Message ----- 
From: "Joseph Yee" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, January 31, 2012 6:11 PM
Subject: [EAI] Determine for EAI to meet at IETF83 or not

All,

Regards,
Joseph, co-chair EAI

--------------------------------------------------------------------------------