Subject: Re: [EAI] FW: Draft on IDN Tables in XML

From: John C Klensin <[email-masked]>
Date: Fri, 02 Mar 2012 10:02:28 -0500

--On Thursday, March 01, 2012 22:22 +0000 Shawn Steele
<[email-masked]> wrote:

> Hmm, sort of an FYI:  if it's interesting for IDN Zone admins
> to declare the rules they use, maybe something similar is
> interesting for email admins to declare how they assign EAI
> addresses?

Maybe, although we have never tried to standardize that in 40
years or so.  Some people would undoubtedly consider disclosing
their assignment system as an invitation to attacks.  And,
perhaps worse, the assignment rule in many places has been
approximately FCFS with a few restrictions.  For example, how
would you describe the current assignment model for Hotmail?

    john

---

From: Shawn Steele <[email-masked]>
Date: Fri, 2 Mar 2012 15:51:05 +0000

One could say the same about zones :)  I'm not for the idea, I just saw a possible correlation.  (I actually don't see much need for it for IDN either, there's already a way to ask if someone else's name's valid: DNS, so this seems limited to specialized apps).

-Shawn

-----Original Message-----
From: John C Klensin [mailto:[email-masked]] 
Sent: Friday, March 02, 2012 7:02 AM
To: Shawn Steele; [email-masked]
Subject: Re: [EAI] FW: Draft on IDN Tables in XML

--On Thursday, March 01, 2012 22:22 +0000 Shawn Steele <[email-masked]> wrote:

> Hmm, sort of an FYI:  if it's interesting for IDN Zone admins to 
> declare the rules they use, maybe something similar is interesting for 
> email admins to declare how they assign EAI addresses?

Maybe, although we have never tried to standardize that in 40 years or so.  Some people would undoubtedly consider disclosing their assignment system as an invitation to attacks.  And, perhaps worse, the assignment rule in many places has been approximately FCFS with a few restrictions.  For example, how would you describe the current assignment model for Hotmail?

    john