Subject: [EAI] a couple of 5738bis comments

From: Arnt Gulbrandsen <[email-masked]>
Date: Mon, 30 Apr 2012 10:25:53 +0200

Hi,

it's somewhat unclear to me why this is permitted, supported,
meaningful, etc:

  a login arnt foo
  b enable utf8=accept
  c select inbox
  d uid fetch 1:* body.peek[header.fields (subject from to cc date)]

Note that EAI syntax is enabled by command b, but EAI use not enabled by c.

Arnt

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 30 Apr 2012 13:10:24 +0100

> Note that EAI syntax is enabled by command b, but EAI use not enabled by c.
Hi Arnt,

I am entirely lacking coffee today, so can you please spell out:
1). what is the problem
2). what change you are proposing to fix it.

Thanks,
Alexey

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Mon, 30 Apr 2012 16:38:30 +0200

> I am entirely lacking coffee today, so can you please spell out:

I see two obviously useful cases.

1. Client wants EAI.
2. Client doesn't.

But 5738bis provides three settings.

1. Client wants EAI syntax and messages.
2. Client wants EAI syntax but not EAI messages
3. Client knows nothing about EAI.

(The command sequence above provides the middle case.)

> 2). what change you are proposing to fix it.

I'm not proposing. I'm wondering why the document offers three cases.

I'm not saying "b enable utf8=accept" followed by "c select inbox" is
pointless, I'm asking what its point is.

Arnt