Subject: Re: [EAI] a couple of 5738bis comments

From: Alexey Melnikov <[email-masked]>
Date: Tue, 01 May 2012 20:01:20 +0100

Hi Arnt,

On 30/04/2012 15:38, Arnt Gulbrandsen wrote:
> Alexey answers me:
>>>     b enable utf8=accept
>>>     c select inbox
>>>
>> I am entirely lacking coffee today, so can you please spell out:
>> 1). what is the problem
> I see two obviously useful cases.
>
> 1. Client wants EAI.
> 2. Client doesn't.
>
> But 5738bis provides three settings.
>
> 1. Client wants EAI syntax and messages.
> 2. Client wants EAI syntax but not EAI messages
> 3. Client knows nothing about EAI.
>
> (The command sequence above provides the middle case.)
I don't think we really care about 2. Maybe we used to care when there 
were more IMAP extensions in the same document.

Remind me how is 1 different from 2?
>> 2). what change you are proposing to fix it.
> I'm not proposing. I'm wondering why the document offers three cases.
>
> I'm not saying "b enable utf8=accept" followed by "c select inbox" is
> pointless, I'm asking what its point is.
>

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Tue, 1 May 2012 21:54:14 +0200

>> 3. Client knows nothing about EAI.
...
> Remind me how is 1 different from 2?

  a login alexey features
  b enable utf8=accept
  c select inbox ...
  d uid fetch 1:* bodystructure

If command c uses the UTF8 option, command d returns data from the real
messages. This is option 1 above.

If command c doesn't use the UTF8 option, the responses for command d
can use *"..." strings, but have to contain downgraded information. This
is option 2 above.

If option 2 isn't valuable, then I think the UTF8 option to SELECT, LIST
etc can perhaps be dropped, and the single command ENABLE UTF8=ACCEPT
turns on EAI support completely.

Arnt