Subject: [EAI] What some MUAs did with a message with an empty From group

From: "John Levine" <[email-masked]>
Date: 2 Aug 2012 17:21:16 -0000

Executive summary: nothing broke.

* Alpine (my normal client)

Displayed OK.  Invented a matching Reply-To: line.  If I reply, the To: line is empty.

* Thunderbird

Displayed OK. Reply put the same empty From: group on the To: line, rejects attempts to
send it with a message saying to fix the To: line.

* Evolution

Displayed OK. Reply has a blank To: line.

* Android mail

Displayed OK. Reply has a blank To: line.

* Squirrelmail (popular webmail IMAP client)

Displayed OK, reply put the null group on the To: line and let you try
to send mail to it.

* Yahoo Mail

Filed as spam but displayed reasonably.  Reply had an empty To: line.

* Gmail

Filed as spam but displayed reasonably.  Reply had an empty To: line.

* Hotmail aka outlook.com

Displayed OK. Reply put the same empty From: group on the To: line, rejects attempts to
send it with a message saying to fix the To: line.

-----------------------------------

Here's the messge.

Date: Thu, 2 Aug 2012 09:24:15
From: A foreign person:  ;
To: [email-masked]
Cc: [email-masked]
Subject: let's have lunch

at the sushi place at 1230

Regards,

---

From: Barry Leiba <[email-masked]>
Date: Thu, 2 Aug 2012 13:35:18 -0400

Will you please re-post this to the thread on <[email-masked]> ?

Barry

On Thursday, August 2, 2012, John Levine wrote:

> To: [email-masked] <javascript:;>
> Cc: [email-masked] <javascript:;>
> _______________________________________________
> IMA mailing list
> [email-masked] <javascript:;>
> https://www.ietf.org/mailman/listinfo/ima
>