Subject: Re: [Int-dir] INT DIR review of draft-ietf-6tisch-minimal-12.txt

From: Thomas Watteyne <[email-masked]>
Date: Tue, 3 Nov 2015 12:54:03 +0900

Suresh,
A quick note to thank you for the detailed review!
We have been discussing your comments with the editors of the draft, and
will come back with a response.
I assume you have no problem with us discussing your comments on the 6TiSCH
ML and/or during the 6TiSCH WG meeting in Yokohama. Please let me konw if
you do.
Thomas

On Thu, Oct 22, 2015 at 1:01 PM, Suresh Krishnan <
[email-masked]> wrote:

> I am an assigned INT directorate reviewer for
> <draft-ietf-6tisch-minimal-12.txt>. These comments were written primarily
> for
> the benefit of the Internet Area Directors. Document editors and
> shepherd(s)
> should treat these comments just like they would treat comments from any
> other IETF contributors and resolve them along with any other Last Call
> comments that have been received. For more details on the INT Directorate,
> see http://www.ietf.org/iesg/directorate.html.
>
> Summary: The draft is almost ready for publication but I have two comments
> that you may want to address.
>
> Major
> =====
>
> * Intended Status:
>
> This looks more like a recommended set of network configuration parameters
> than a new protocol definition. Has the wg considered whether the Proposed
> Standard status is appropriate (as opposed to Info or BCP)?
>
> * Section 10.1.1
>
> I have a question about the Sp computation. Looks like the Sp value needs
> to
> be between 1 and 9. In my view, the recommended method (3*ETX)-2 yields
> values between 1 and 10. This needs to be fixed.
>
> This is how I see it.
>
> On a very high quality link, if there are no retransmissions required ETX
> will be 1/1 => 1. Sp will be (3*1)-2 => 1
>
> On a very poor quality link where the packet only gets through after the
> full
> 3 retries ETX will be 4/1 => 4. Sp will be (3*4)-2 => 10.
>
> Is my calculation correct?
>
> Editorial
> =========
>
> Section 3.2
>
> s/maintin/maintain/
>
> Section 3.3
>
> s/if none is/if none are/
>
> Thanks
> Suresh
>

---

From: Suresh Krishnan <[email-masked]>
Date: Tue, 3 Nov 2015 09:11:07 +0000

Hi Thomas,
   Thanks for your response. I have no issue with you sharing the comments on 
the 6tisch mailing list. I will look forward to your response.

Regards
Suresh

On 11/03/2015 12:54 PM, Thomas Watteyne wrote:
> We have been discussing your comments with the editors of the draft, and will
> come back with a response.
> ML and/or during the 6TiSCH WG meeting in Yokohama. Please let me konw if you do.
> Thomas
>
> On Thu, Oct 22, 2015 at 1:01 PM, Suresh Krishnan
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     <draft-ietf-6tisch-minimal-12.txt>. These comments were written primarily for
>     the benefit of the Internet Area Directors. Document editors and shepherd(s)
>     I have a question about the Sp computation. Looks like the Sp value needs to
>     On a very poor quality link where the packet only gets through after the full