Subject: [Int-dir] INT area directorate review for draft-ietf-hip-multihoming-09

From: Sheng Jiang <[email-masked]>
Date: Tue, 5 Jul 2016 08:44:37 +0000

I am an assigned INT directorate reviewer for draft-ietf-hip-multihoming-09. These comments were written primarily for the benefit of the Internet Area Directors. Document editors and shepherd(s) should treat these comments just like they would treat comments from any other IETF contributors and resolve them along with any other Last Call comments that have been received. For more details on the INT Directorate, see http://www.ietf.org/iesg/directorate.html.

This Standards Track document provides defines host multihoming extensions to HIP. As an update document from RFC 5206, this document is well written. It is almost read for publication. I have one major and one minor comments as blow.

The security analysis of this document is weak. It states that “No additional security considerations beyond those outlined in [I-D.ietf-hip-rfc5206-bis] have been identified.” [I-D.ietf-hip-rfc5206-bis] is dedicated for mobility. However, there are many multi-homing specific security issues. I would like to see more security analysis against security threats that are mentioned by RFC 4218, Threats Relating to IPv6 Multihoming Solutions.

Minor comment (bridged from Brian Carpenter):

In the Introducation Section:

> Solutions for site multihoming in IPv6 networks

> have been specified by the IETF shim6 working group.

Shim6 is a host-based solution, so although can be used inside multihomed sites,

it is not correct to call it "site multihoming". Better to write

Solutions for host multihoming in multihomed IPv6 networks

have been specified by the IETF shim6 working group.

Best regards,

Sheng

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Wed, 06 Jul 2016 08:14:24 +0200

Thanks for the review Sheng!

Carlos

On Tue, 2016-07-05 at 08:44 +0000, Sheng Jiang wrote:
> I am an assigned INT directorate reviewer for draft-ietf-hip-
> multihoming-09. These comments were written primarily for the benefit
> of the Internet Area Directors. Document editors and shepherd(s)
> should treat these comments just like they would treat comments from
> any other IETF contributors and resolve them along with any other
> Last Call comments that have been received. For more details on the
> INT Directorate, see http://www.ietf.org/iesg/directorate.html.
>  
> This Standards Track document provides defines host multihoming
> extensions to HIP. As an update document from RFC 5206, this document
> is well written. It is almost read for publication. I have one major
> and one minor comments as blow.
>  
> The security analysis of this document is weak. It states that “No
> additional security considerations beyond those outlined in [I-
> D.ietf-hip-rfc5206-bis] have been identified.” [I-D.ietf-hip-rfc5206-
> bis] is dedicated for mobility. However, there are many multi-homing
> specific security issues. I would like to see more security analysis
> against security threats that are mentioned by RFC 4218, Threats
> Relating to IPv6 Multihoming Solutions.
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 26 Jul 2016 14:28:26 +1200

Tom,

No further comments from my side.

Regards
   Brian

On 25/07/2016 03:10, Tom Henderson wrote:
> Dear Sheng and Brian,
> 
> I believe that draft version 10 of the HIP multihoming document
> addresses your comments on the previous draft.
> 
> 
> 
> https://tools.ietf.org/html/draft-ietf-hip-multihoming-10
> 
> 
> 
> Thank you for the review and please let me know if you have additional
> concerns with the new security considerations section.
> 
> 
> 
> - Tom
> 
> 
> 
> On 07/05/2016 11:14 PM, Carlos Jesús Bernardos Cano wrote:
> 
>>> Shim6 is a host-based solution, so although can be used inside
> 
>>> multihomed sites,
>

---

From: Sheng Jiang <[email-masked]>
Date: Tue, 26 Jul 2016 05:56:36 +0000

Thanks, Tom. No further comments from my side.

Sheng
________________________________________
From: Tom Henderson [[email-masked]]
Sent: 24 July 2016 23:10
To: [email-masked]; Sheng Jiang; [email-masked]; [email-masked]; [email-masked]
Cc: Bernie Volz (volz); Brian E Carpenter; Gonzalo Camarillo
Subject: Re: INT area directorate review for draft-ietf-hip-multihoming-09

Dear Sheng and Brian,

- Tom