Subject: Re: [Int-dir] INT-DIR review of draft-ietf-6lo-privacy-considerations-03

From: Dave Thaler <[email-masked]>
Date: Mon, 31 Oct 2016 19:35:40 +0000

It is true that the 6lo-specific parts are mainly in section 3.  The audience is people doing new foo-over-IPv6 protocols,
which today is primarily the 6lo WG, hence it was homed there and was tailored towards that audience.

I have no preference either way on whether the title should change, other than in my view the document is already 
quite short and it would not make sense to split the document or anything.   

If the title were to change (and abstract) then it could be something like:

	Privacy Considerations for IPv6 Adaptation Layer Mechanisms

With possible abstract

OLD:
   This document discusses how a number of privacy threats apply to
   technologies designed for IPv6 over networks of resource-constrained
   nodes, and provides advice to protocol designers on how to address
   such threats in adaptation layer specifications for IPv6 over such
   links.
NEW:
   This document discusses how a number of privacy threats apply to
   technologies designed for IPv6 over various link layer protocols,
   and provides advice to protocol designers on how to address
   such threats in adaptation layer specifications for IPv6 over such
   links.

I'll wait a couple hours in case the chairs or ADs have a preference.

Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ????
Sent: Monday, September 26, 2016 9:34 AM
To: <[email-masked]> <[email-masked]>; [email-masked]; [email-masked]
Subject: INT-DIR review of draft-ietf-6lo-privacy-considerations-03

I am an assigned INT directorate reviewer for <https://tools.ietf.org/html/draft-ietf-6lo-privacy-considerations-03>.
These comments were written primarily for the benefit of the Internet Area Directors. Document editors and shepherd(s) should treat these comments just like they would treat comments from any other IETF contributors and resolve them along with any other Last Call comments that have been received. For more details on the INT Directorate, see http://www.ietf.org/iesg/directorate.html.

This document is very well written and looks useful.  I didn't find any obvious technical issues that may block publication.

One possible point that my warrant a discussion is that this document doesn't seem to be very specific to resource constrained nodes (as the title and abstract suggests).  I don't see anything tightly specific to such nodes except for some parts of Section 3.  Even in Section 3 most of the discussions seem generic.  I wonder whether such general privacy issues regarding IPv6 addresses are already covered by some existing documents.  If so, this document could be much shorter by just referring to such documents and focusing on a few points specific to 6lo nodes.  If not, we might rather consider publishing it as such a generic document.

--
JINMEI, Tatuya

---

From: Dave Thaler <[email-masked]>
Date: Mon, 31 Oct 2016 19:42:32 +0000

Just chatted with the 6lo WG chair (Gabriel) who said looks good, go ahead and make this change.

So I will post a note to the WG list shortly, and submit the update before the deadline today.

-----Original Message-----
From: Dave Thaler [mailto:[email-masked]] 
Sent: Monday, October 31, 2016 12:36 PM
To: 神明達哉 <[email-masked]>; <[email-masked]> <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: INT-DIR review of draft-ietf-6lo-privacy-considerations-03

It is true that the 6lo-specific parts are mainly in section 3.  The audience is people doing new foo-over-IPv6 protocols, which today is primarily the 6lo WG, hence it was homed there and was tailored towards that audience.

With possible abstract

OLD:

Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ????
Sent: Monday, September 26, 2016 9:34 AM
To: <[email-masked]> <[email-masked]>; [email-masked]; [email-masked]
Subject: INT-DIR review of draft-ietf-6lo-privacy-considerations-03

--
JINMEI, Tatuya