Subject: Hepl required regarding the PAT table

From: "Vinay S." <[email-masked]>
Date: Thu, 18 Mar 2004 14:35:19 +0530

hi

 I m a newbie to DVB-RCS.While trying to get the Program map PIDs, for the
different programs,from the PAT table,
a variable N is presented in the standard, saying that so many program
channels are present.But, I have not found any place/hint
indicating what this variable n might be? The exact context is given
below.(marked by the Arrow)

program_association_table
program_association_section()
{
	table_id 8 uimsbf
	section_syntax_indicator 1 bslbf
	'0' 1 bslbf
	reserved 2 bslbf
	section_length 12 uimsbf
	transport_stream_id 16 uimsbf
	reserved 2 bslbf
	version_number 5 uimsbf
	current_next_indicator 1 bslbf
	section_number 8 uimsbf
	last_section_number 8 uimsbf

	for (i = 0; i < N; i++)  -------------------->what is the value of N?
	{
		program_number 16 uimsbf
		reserved 3 bslbf
		if (program_number = = '0')
		{
			network_PID 13 uimsbf
		}
		else
		{
		program_map_PID 13 uimsbf
		}
	}
CRC_32 32 rpchof
}

with warm regards,
Vinay.S

---

From: "Bernhard Collini-Nocker" <[email-masked]>
Date: Thu, 18 Mar 2004 11:02:33 +0100

Hi,
> below.(marked by the Arrow)

N is simply the number of programs, i.e. collections of correlated PIDs for
audio/video/data, to be found as PMTs.

> 	for (i = 0; i < N; i++)  -------------------->what is the

Number of programs. So on a transponder with 8 digital tv programs
N equals 8 (or more, if other kind of programs are present).

> 		program_map_PID 13 uimsbf

Regards,
Bernhard