Subject: How to compute the checksum and crc-32 for MPE and ULE

From: "Simon Teh" <[email-masked]>
Date: Wed, 18 Aug 2004 14:51:08 +0800

Dear all experts,

        Currently I'm studying the encapsulation method on MPE and ULE. But
I'm confusing on how the crc32 and the checksum been calculate. Are they
compute from the datagram section or the hold packet? I hope somebody can
help me or send me some paper or website related with these topics.. Thanks
in advance!!

Best Regards,

Simon Teh

Universiti Sains Malaysia

---

From: Moritz Vieth <[email-masked]>
Date: Wed, 18 Aug 2004 10:32:17 +0200

Hi simon,

Simon Teh wrote:
> Dear all experts,
> 
>  
> 
>         Currently I’m studying the encapsulation method on MPE and ULE. 
> But I’m confusing on how the crc32 and the checksum been calculate. Are 
> they compute from the datagram section or the hold packet? I hope 
> somebody can help me or send me some paper or website related with these 
> topics.. Thanks in advance!!
> 
>  

The current ULE draft (draft-fair-ipdvb-ule-02) says on page 14 (4.6): 
"It then accumulates a transmit value for the CRC32 that includes all 
bytes from the start of the SNDU header to the end of the SNDU 
(excluding the 32-bit trailer),...".
This means the CRC32 vlaues are computed from the whole packet 
(including the header) exept the CRC itself.

Hope this helps.

Regards,
Moritz Vieth

FhG FOKUS

---

From: "Simon Teh" <[email-masked]>
Date: Wed, 18 Aug 2004 16:36:20 +0800

Hi Moritz Vieth,
Thanks for your help...Yeap it helps a lot!

Best Regards,
Simon Teh

---

From: "Bernhard Collini-Nocker" <[email-masked]>
Date: Wed, 18 Aug 2004 11:26:30 +0200

Dear Simon,
 
probably the easiest way to find out how to correctly implement ULE, although
not yet the final version :-(, and particularly the CRC32 is looking into the
linuxtv.org source code where we have contributed and what is meanwhile even
part of the latest linux 2.6 kernel.
 
Regards,
Bernhard
 
Dr. Bernhard Collini-Nocker
Paris Lodron University Salzburg
Department of Scientific Computing
Multimedia Communication Group
Jakob Haringer Str. 2
A-5020 Salzburg
AUSTRIA
Tel: +43-662-8044 6316
Fax: +43-662-8044 172
www.scicomp.sbg.ac.at
www.network-research.org 

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag
von Simon Teh
Gesendet: Wednesday, August 18, 2004 08:51
An: Ip-DVB
Betreff: How to compute the checksum and crc-32 for MPE and ULE

Dear all experts,

        Currently I’m studying the encapsulation method on MPE and ULE. But I’m
confusing on how the crc32 and the checksum been calculate. Are they compute
from the datagram section or the hold packet? I hope somebody can help me or
send me some paper or website related with these topics.. Thanks in advance!!

Best Regards,

Simon Teh