Subject: Question about Internet Draft of Encapsulation for Ip over Mpeg2/DVB

From: "Simon Teh" <[email-masked]>
Date: Fri, 20 Aug 2004 16:27:21 +0800

Dear all members,

           Currently I'm reading an internet draft Ultra Lightweight
Encapsulation (ULE) Extension Header. From this document, I'm quite
confusing of this line:

                    Internet Engineering Task Force
Bernhard Collini-Nocker 

                    Internet Draft
Hilmar Linder 

                    Document: draft-collini-ipdvb-xule-00.txt
University of Salzburg 

Gorry Fairhurst 

University of Aberdeen 

 

                    Category: Internet Draft
May 2004 

                            Ultra Lightweight Encapsulation (ULE) Extension
Header        

-

-

-

-

-

-

-

 2.2 Optional Extension Headers 

                       A next-layer-header value greater than or equal to
512 decimal 

                       (0x0100, hexadecimal) and less than 1536 decimal
(0x600, 

                       hexadecimal), indicates an Optional Extension Header.
When a 

                       Receiver encounters a next-layer-header indicating an
Optional 

                       Extension Headers, it MAY be configured to either:

            Is there any mistake or..? I hope somebody could help me. Thanks
for reading my mail!

Best Regards,

Simon Teh

Universiti Sains Malaysia

---

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 20 Aug 2004 14:46:39 +0100

Thanks for the question,

0x0100 is correct, and should  indeed be 256 decimal.

Please note that this draft was an individual submission based on many 
mail threads and discussions - the intention was to write one case that 
could be used a strawman for discussion. Feedback and questions are most 
welcome.

The draft was discussed at the IETF-60 meeting, and the conclusion 
seemed to be that the ipdvb WG should look at further simplification (if 
possible) and then propose adding a revised text to the ULE spec itself. 
Some of this is captured in the meeting slides:

http://www.erg.abdn.ac.uk/ip-dvb/meetings/IETF-60-SanDiego/

Best wishes,

Gorry Fairhurst

Simon Teh wrote:

> Dear all members,
> 
>  
> 
>            Currently I’m reading an internet draft Ultra Lightweight 
> Encapsulation (ULE) Extension Header. From this document, I’m quite 
> confusing of this line:
> 
>  
> 
>                
> 
>                     Internet 
> Draft                                                                   
>                     Category: Internet 
> Draft                                       May 2004
>                             Ultra Lightweight Encapsulation (ULE) 
> Extension Header        
> 
>  
> 
>                                                                                 
> -
> 
>                                                                                 
> -
> 
>                                                                                 
> -
> 
>                                                                                 
> -
> 
>                                                                                 
> -
> 
>                                                                                 
> -
> 
>                                                                                 
> -
> 
>  
> 
>  
> 
>  
> 
>                        A next-layer-header value greater than or equal 
> to 512 decimal
> 
>                        hexadecimal), indicates an Optional Extension 
> Header. When a
> 
>                        Receiver encounters a next-layer-header 
> indicating an Optional
> 
>             Is there any mistake or….? I hope somebody could help me. 
> Thanks for reading my mail!
> 
>  
> 
> Best Regards,
> 
> Simon Teh
>