Subject: DVB-H MPE/timeslice question

From: Siva Veerepalli <[email-masked]>
Date: Mon, 29 Nov 2004 20:24:44 -0800 (PST)

I have been reading the DVB-H standard, and have a
question regarding MPE bursts and time slicing. The
standard says each ES i.e., MPE stream is transmitted
as a burst within a time slice. It also says that
there can be more than one elementary stream within a
single time slice.

I am assuming this means, there can be other ES's such
as PSI/SI in addition to the MPE stream of interest in
the time slot. However, I have not found anything
explicitly stated that indicates that there can be
multiple MPE streams within a single time slice, i.e.,
two bursts of elementary streams within the same time
slice.

Can some one please clarify this? If this is possible,
it would have an impact on the implementation of the
receiver since n*x memory (where n is the number of
MPE-FEC bursts and x is a max of 2Mb)would be required
in the receiver.

I guess a more basic question is, would a receiver
need more than one MPE burst to present a program of
interest?

thanks,
Siva

__________________________________ 
Do you Yahoo!? 
Read only the mail you want - Yahoo! Mail SpamGuard. 
http://promotions.yahoo.com/new_mail

---

From: "Karsten Siebert @ dpi AG" <[email-masked]>
Date: Tue, 30 Nov 2004 09:38:51 +0100

Pls. see below:

Rgds,

Karsten

-----Ursprüngliche Nachricht-----
Von: "Siva Veerepalli" <[email-masked]>
An: <[email-masked]>
Gesendet: Dienstag, 30. November 2004 05:24
Betreff: DVB-H MPE/timeslice question

> there can be more than one elementary stream within a

This is correct.

> the time slot.

PSI/SI do not run in slices, they are send continuousely.

   However, I have not found anything
> two bursts of elementary streams within the same time

In general one burst refers to one time slice, but you can pass more than
one IP stream in one burst (buffer both streams in the same burst buffer and
send this burst in one time slice. To differenciate the MACs, you still have
bytes 5 and 6 (other are used for real time data and buffer address
location).

With our IPE this can be even IPv4 and IPv6 mixed in one burst / time slice.

> MPE-FEC bursts and x is a max of 2Mb)would be required

n * 2 mb would be required, if you want to receive more than one independent
burst. Have a look into the DVB-H implementation guidelines.

> need more than one MPE burst to present a program of

No. In general programs will not be splitted.