Subject: MPE and ULE padding

From: "Simon Teh" <[email-masked]>
Date: Wed, 15 Dec 2004 11:33:01 +0800

Dear all IP-DVB members,

Good morning, I have several questions about ULE and MPE padding. As we know
that the size of ULE and MPE are variable size (MTU 1500 bytes), so if the
actual data is really small (maybe 2 bytes):

My Questions:

1.       Will it be padded until the PDU reach an expected length by MPE and
ULE? 

2.       Do the MPE and ULE have a minimum size? If yes what is the minimum
size for MPE and ULE?

Thank you!

Best Regards,

Simon Teh

Universiti Sains Malaysia

---

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 17 Dec 2004 09:58:52 +0000

See in-line.

Simon Teh wrote:
> Dear all IP-DVB members,
> 
>  
> 
> Good morning, I have several questions about ULE and MPE padding. As we 
> know that the size of ULE and MPE are variable size (MTU 1500 bytes),

The Maximum MTU of MPE is defined as a little less than 4KB.
The Maximum MTU of ULE is defined as a little less than 32KB.
Although, as you say 1500 is a common MTU for *classical* Ethernet.

> so 
> if the actual data is really small (maybe 2 bytes):
> 
I don't know of any packet which is this small in the IP world, but sure we 
can and do expect packets much less than the MTU.

>  
> 
> My Questions:
> 
> 1.       Will it be padded until the PDU reach an expected length by MPE 
> and ULE?
> 

It **CAN** be padded to fit exactly into an under-lying Transport Stream 
Packet (183B payload). **OR** if Packing is supported - i.e. the MPE driver 
supports (many do, and *ALL* ULE ones do), then you do not need normally to 
add any padding.

The ULE spec explains this process.

> 2.       Do the MPE and ULE have a minimum size? If yes what is the 
> minimum size for MPE and ULE?
> 
No (unless you refer to the TS Packet size).

> Universiti Sains Malaysia

Gory Fairhurst.

---

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 17 Dec 2004 09:58:52 +0000

See in-line.

Gory Fairhurst.