Subject: MPE Question

From: Siva Veerepalli <[email-masked]>
Date: Wed, 27 Apr 2005 17:35:35 -0700 (PDT)

A couple of questions about MPE-FEC framing.

1. The interim IP datacast standard A079 (meant to
facilitate DVB-H trials) specifies that only one
datagram should be used per MPE section i.e., no
fragmentation of IP datagram over multiple MPE
sections. However, the DVB Databroadcast specification
allows fragmentation of the IP datagram over multiple
sections. Does anyone know what the usual practice is?
Do the final DVB/IP datacast standards specify this
for DVB-H?

2. The MPE section has optional stuffing bytes at the
end of the section. Are these used? If yes, for what?

thanks,
Siva

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: Bernhard Collini-Nocker <[email-masked]>
Date: Thu, 28 Apr 2005 07:22:43 +0200

> sections. Does anyone know what the usual practice is?

In order to reduce encapsulation overhead, section packing is used, i.e. 
if the (remainder of an) IP packet does not fit exactly in a TS packet a 
subsequent IP packet may start in that TS packet as well.
In order to reduce jitter and latency, section packing is not used.

You can find both on existing services.

> Do the final DVB/IP datacast standards specify this

The difficulty with section peckaing on the transmit side is that the 
encapsulator needs to wait for subsequent IP packets to fill an 
partially filled TS packet and therefor has typically a time-out 
associated to that waiting, ie before flushing the buffer and 
transmitting the final TS packet.

> end of the section. Are these used? If yes, for what?

Whenver an IP packets leaves "enough" space in the last TS packet 
another IP packet could be inserted. If not wanted or needed, stuffing 
takes care that the empty space is filled up with pattern 0xFF.

---

From: nurul <[email-masked]>
Date: 28 Apr 2005 13:42:33 +0800

Hi,

Do MPE allows packing? cause as far as i concern it's only allow padding
while ULE allows both. Correct me if i'm wrong.

regards,
nurul

---

From: "Simon Teh" <[email-masked]>
Date: Thu, 28 Apr 2005 14:19:30 +0800

Dear members,

For packing and padding, it depends on the TS packet. If a payload unit
finishes before the end of a TS packet payload, and where there is
sufficient space, the TS packet will carry one more new payload unit. 

So, TS packet padding and packing can be used for MPE and ULE.

I hope it will help.

Best Regards,
Simon Teh
Universiti Sains Malaysia

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of nurul
Sent: 28 April 2005 13:43
To: [email-masked]
Subject: Re: MPE Question

Hi,

regards,
nurul

---

From: nurul <[email-masked]>
Date: 28 Apr 2005 16:09:05 +0800

i see. thank you Sir.

regards,
nurul

On Thu, 2005-04-28 at 15:49, Gorry Fairhurst wrote:
> Indeed the MPE specification *DOES* allow section packing as an option. Not
> all drivers/implementations permit this.
> 
> Conversely, in ULE *ALL* compliant drivers MUST support it.
> 
> Gorry Fairhurst
> 
> On 28/4/05 6:42 am, "nurul" <[email-masked]> wrote:
> 
> > Hi,
> >

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 28 Apr 2005 08:49:40 +0100

Gorry Fairhurst

---

From: Bernhard Collini-Nocker <[email-masked]>
Date: Thu, 28 Apr 2005 10:04:32 +0200

Well, section packing is allowed, and MPE uses sections, so it can "ride 
that horse". And, of course, MPE with section packing meanwhile is 
supported by nearly all IRD cards and drivers. However, it is badly 
described compared to ULE.

Regards,
Bernhard

---

From: nurul <[email-masked]>
Date: 28 Apr 2005 16:16:40 +0800

ahhh.. i see...

thank you to you too, sir.

regards, 
nurul