Subject: Mapping of OSI-3 datagrams in the application data table of the MPE-FEC frame

From: "Eduardo Alonso de la Fuente" <[email-masked]>
Date: Mon, 4 Apr 2005 11:44:29 +0300

Hi,
 
In the ETSI 301 192 final draft (point 9.3) it is written that IP
datagrams that form the application data table of the MPE-FEC frame are
carried in MPE sections. It says that the address of each datagram
within the table is signalled in the header of the section that carries
it. It also states that there is a table_boundary flag that indicates
the end of layer 3 datagrams within the application data table.
 
The same document (point 7) describes the syntax and semantics of the
MPE section but of course there is no bits assigned to carry the address
of the datagram in the application data table and no table_boundary
flag. I am a student doing a bachelor thesis on the matter, modelling an
MPE encapsulator with Matlab, and maybe I am a little bit lost in this
matter, but I guess this information is introduced in any of the
optional fields (i.e. stuffing byte) though I do not really know if it
is done like that or if there is any 'standard' way of doing it.
 
Any help you can provide will be very useful.
 
Thank you in advance,

Eduardo Alonso de la Fuente
 <mailto:[email-masked]> [email-masked]
+358417759640

---

From: "Karsten Siebert @ dpi AG" <[email-masked]>
Date: Mon, 4 Apr 2005 11:47:05 +0200

Have a look in the section (9) describing real time parameters (address, boundaries and real time values), which are the same for MPE and FEC sections. Four MAC address bytes (1-4) are replaced by these parameters.

Karsten

  ----- Original Message ----- 
  From: Eduardo Alonso de la Fuente 
  To: IP/DVB mailing list 
  Sent: Monday, April 04, 2005 10:44 AM
  Subject: Mapping of OSI-3 datagrams in the application data table of the MPE-FEC frame

  Hi,

  In the ETSI 301 192 final draft (point 9.3) it is written that IP datagrams that form the application data table of the MPE-FEC frame are carried in MPE sections. It says that the address of each datagram within the table is signalled in the header of the section that carries it. It also states that there is a table_boundary flag that indicates the end of layer 3 datagrams within the application data table.

  The same document (point 7) describes the syntax and semantics of the MPE section but of course there is no bits assigned to carry the address of the datagram in the application data table and no table_boundary flag. I am a student doing a bachelor thesis on the matter, modelling an MPE encapsulator with Matlab, and maybe I am a little bit lost in this matter, but I guess this information is introduced in any of the optional fields (i.e. stuffing byte) though I do not really know if it is done like that or if there is any 'standard' way of doing it.

  Thank you in advance,

  [email-masked]

  +358417759640

---

From: "Eduardo Alonso de la Fuente" <[email-masked]>
Date: Mon, 4 Apr 2005 13:25:01 +0300

Ok, I had not realised that the real time parameters described were for
both MPE and MPE-FEC sections.
 
Thank you very much!!!
 
-----Mensaje original-----
De: [email-masked] [mailto:[email-masked]] En
nombre de Karsten Siebert @ dpi AG
Enviado el: lunes, 04 de abril de 2005 12:47
Para: [email-masked]
Asunto: Re: Mapping of OSI-3 datagrams in the application data table of
the MPE-FEC frame
 
Have a look in the section (9) describing real time parameters (address,
boundaries and real time values), which are the same for MPE and FEC
sections. Four MAC address bytes (1-4) are replaced by these parameters.
 
Karsten
 
----- Original Message ----- 
From: Eduardo Alonso de la Fuente <mailto:[email-masked]>  
To: IP/DVB mailing <mailto:[email-masked]>  list 
Sent: Monday, April 04, 2005 10:44 AM
Subject: Mapping of OSI-3 datagrams in the application data table of the
MPE-FEC frame
 
Hi,

 
 
Thank you in advance,