Subject: Question on ANNEX A: Informative Appendix - SNDU Packing Examples

From: "Simon Teh" <[email-masked]>
Date: Fri, 29 Apr 2005 00:45:12 +0800

Dear members,

I'm quite confusing with the example shown in Annex A on the examples of
SNDU packing.

Example A.1: Two 186B PDUs. 
    
     SNDU A is 200 bytes (including the ULE destination NPA address) 
     SNDU B is 200 bytes (including the ULE destination NPA address) 
    
   The sequence comprises 3 TS Packets: 
    
                      SNDU                
           PP=0      Length          
   +-----+------+------+------+-   -+------+ 
   | HDR | 0x00 | 0x00 | 0xC4 | ... | A182 | 
   +-----+----*-+-*----+------+-   -+------+ 
   PUSI=1     *   * 
              ***** 

For the SNDU Length shown in the figure above, why it is 0xC4?

The size for a MPEG-2 TS packet is 188, if minus TS header and PP, is 183
bytes.

So the maximum size that the IP packet (SNDU A) can be encapsulated should
be 183 = 0xb7,

But why it is 0xC4 instead of 0xb7? Or Do I miss something?

Hope somebody could help me on this matter. Thanks in advance!

 

Best Regards,

Simon Teh

Universiti Sains Malaysia

---

From: "William StanisLaus" <[email-masked]>
Date: Thu, 28 Apr 2005 19:26:25 +0100

Hi Simon,

The Length specified in the example is SNDU length and NOT MPEG2-TS header
length,  as the ULE draft specifies one SNDU can prolong/extend more than
one MPEG2-TS packet (that's what this example trying to explain). In this
example complete MPEG2-TS header information are not discussed, only PUSI
and if PUSI is ONE payload pointer are discussed.

-William.

  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Simon Teh
Sent: Thursday, April 28, 2005 5:45 PM
To: Ip-DVB
Subject: Question on ANNEX A: Informative Appendix - SNDU Packing Examples

Dear members,

    

                      SNDU                
           PP=0      Length          

 

Best Regards,

Simon Teh

---

From: "Simon Teh" <[email-masked]>
Date: Fri, 29 Apr 2005 11:19:25 +0800

Thanks for the answer Mr. William StanisLaus.

Best Regards,

Simon Teh

  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of William StanisLaus
Sent: 29 April 2005 02:26
To: 'Ip-DVB'
Subject: RE: Question on ANNEX A: Informative Appendix - SNDU Packing
Examples

Hi Simon,

-William.

  _____  

Dear members,

    

                      SNDU                
           PP=0      Length          

 

Best Regards,

Simon Teh