Subject: Re: MPE Question

From: Siva Veerepalli <[email-masked]>
Date: Thu, 28 Apr 2005 14:52:37 -0700 (PDT)

--- Bernhard Collini-Nocker <[email-masked]>
wrote:
> Siva Veerepalli wrote:
> > A couple of questions about MPE-FEC framing.
> > 
<snip>
> > 2. The MPE section has optional stuffing bytes at
> the
> > end of the section. Are these used? If yes, for
> what?
> 
> Whenver an IP packets leaves "enough" space in the
> last TS packet 
> another IP packet could be inserted. If not wanted
> or needed, stuffing 
> takes care that the empty space is filled up with
> pattern 0xFF.

I was actually referring to the stuffing bytes in the
MPE section, not the TS packet. I understand the use
of stuffing bytes in TS packets, but am not clear why
stuffing bytes are used in MPE sections.

thanks,
Siva
> 
> > thanks,
> > Siva
> > 
> > 
> > __________________________________________________
> > Do You Yahoo!?
> > Tired of spam?  Yahoo! Mail has the best spam
> protection around 
> > http://mail.yahoo.com 
> > 
> 
> 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: Bernhard Collini-Nocker <[email-masked]>
Date: Fri, 29 Apr 2005 08:06:27 +0200

Hello again,

the famous words stuffing and padding are

> stuffing bytes are used in MPE sections.

According to EN301192 "stuffing_byte: this is an optional 8-bit field 
whose value is not specified. If the payload of the section is scrambled
(see payload_scrambling_mode), these bytes are scrambled. They are to 
assist with block encryption and data processing in wide bus 
environments. The number of stuffing_bytes used should meet the data 
alignment requirements defined in the data_broadcast_descriptor."

So, for block encryption one typically has some arbitariy number of bits 
to encrypt and needs to ensure that the MPE payload is on auch a 
multiple bit boundary for what MPE internal stuffing might be needed...