Subject: Re: MPE Question

From: Siva Veerepalli <[email-masked]>
Date: Thu, 28 Apr 2005 14:48:06 -0700 (PDT)

Thanks for the response Bernhard, but I am a bit
confused about the answer. Please see my question
below:

--- Bernhard Collini-Nocker <[email-masked]>
wrote:
> Siva Veerepalli wrote:
> > A couple of questions about MPE-FEC framing.
> > 
> > 1. The interim IP datacast standard A079 (meant to
> > facilitate DVB-H trials) specifies that only one
> > datagram should be used per MPE section i.e., no
> > fragmentation of IP datagram over multiple MPE
> > sections. However, the DVB Databroadcast
> specification
> > allows fragmentation of the IP datagram over
> multiple
> > sections. Does anyone know what the usual practice
> is?
> 
> In order to reduce encapsulation overhead, section
> packing is used, i.e. 
> if the (remainder of an) IP packet does not fit
> exactly in a TS packet a 
> subsequent IP packet may start in that TS packet as
> well.
> In order to reduce jitter and latency, section
> packing is not used.

I understand that two MPE sections could probably
start in the same TS packet (I guess that is what you
mean by section packing).

My original questions was, what is the usual practice
with regards to fragmenting an IP datagram over
multiple MPE sections (irrespective of how these
sections are transported in TS packets)? The DVB-H
(data broadcast standard) allows for this, however,
the IPDC interim specification requires that one
datagram be encapsulated entirely in one mpe section
i.e., no datagram fragmentation over multiple MPE
sections.

thanks,
Siva

> 
> You can find both on existing services.
> 
> > Do the final DVB/IP datacast standards specify
> this
> > for DVB-H?
> 
> The difficulty with section peckaing on the transmit
> side is that the 
> encapsulator needs to wait for subsequent IP packets
> to fill an 
> partially filled TS packet and therefor has
> typically a time-out 
> associated to that waiting, ie before flushing the
> buffer and 
> transmitting the final TS packet.
> 
> > 2. The MPE section has optional stuffing bytes at
> the
> > end of the section. Are these used? If yes, for
> what?
> 
> Whenver an IP packets leaves "enough" space in the
> last TS packet 
> another IP packet could be inserted. If not wanted
> or needed, stuffing 
> takes care that the empty space is filled up with
> pattern 0xFF.
> 
> > thanks,
> > Siva
> > 
> > 
> > __________________________________________________
> > Do You Yahoo!?
> > Tired of spam?  Yahoo! Mail has the best spam
> protection around 
> > http://mail.yahoo.com 
> > 
> 
> 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: Bernhard Collini-Nocker <[email-masked]>
Date: Fri, 29 Apr 2005 07:54:49 +0200

Dear Siva,

you are right in that I had understood your question different.

Generally Sections do allow for numbering that is, one can put a payload 
(for example a DSM-CC object) into a number of Sections and with 
section_number and last_section_number the reassebler knows what to do. 
MPE uses this Section mechanism, so multiple Section operations should 
be possible. Actually I have never tested whether MPE decapsulators do 
support this in real, in principle they should (again the DVB 
databroadacst standard does not say too much, if anything, about it) but 
in DSM-CC Obejct carousels is a very usual mode of operation.

> --- Bernhard Collini-Nocker <[email-masked]>
[...]
> mean by section packing).

Yes.

> i.e., no datagram fragmentation over multiple MPE

Now the confusion starts when one introduces the wording of "over 
multiple MPE sections", because there is no such thing as a MPE section 
fragmentation.
I will have to read the DVB-H standard again in order to find out what 
it really says. I guess the only real issues the DVB-H wrt to IP is 
addressing is the necessity of a IP datagram encapsulated in MPE is to 
support time slicing (ie a burst transmission of the resulting TS 
packets to allow for power saving) and MPE-FEC (adding redundant code to 
allow for reconstruction). In that case I woould assume that it is very 
reasonable (especially with legacy equipment) to avoid all potential 
interpretations of MPE wrt multiple section operation and section packing.

> Siva
[...]

Yor are very welcome,
and I hope I got THE expected answer closer,
Bernhard

---

From: "William StanisLaus" <[email-masked]>
Date: Fri, 29 Apr 2005 16:56:03 +0100

Hi Siva and Bernhard,
DSM-CC which is a potential MPE of our present day DOES NOT support section
packing for normal IP data transmissions. In DSM-CC we have section length
of 12 bits, which can hold maximum of 4096 Bytes of payload data (IP in our
discussion). In Normal scenario we don't even use this big, since section
packing is not supported practically (theoretically YES), we use DVB router
one interface as Ethernet and other as DVB, on Ethernet wire we get only
1500 bytes the max, though there is a room for section
packing(theoretically) real time packet routing don't wait for another IP
packet, just push each and every ip packet received with MPE (DSM-CC) and to
MPEG2-TS (supports section packing, based on the timer - reason MPEG2-TS
MUST be 188 bytes, instead of wasting bytes with stuffing we have section
packing).

When we are talking about stuffing bytes, that was perfect by Bernhard, we
use for packet alignment, to be more specific, real time operating system
like PSOS, requires it be WORD aligned ( Multiples of Four) before
encryption algorithm to be applied for scrambling.

-William.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Bernhard Collini-Nocker
> Sent: Friday, April 29, 2005 6:55 AM
> To: [email-masked]
> Subject: Re: MPE Question
> 
> Dear Siva,
>