Subject: RE: [Technical Errata Reported] RFC5458 (1746)

From: <[email-masked]>
Date: Tue, 7 Apr 2009 16:46:56 +0100

Hi again,

I suggest to add the the TS Logical Channel definition (taken from RFC
4326). So here is the proposed text:

*********************************************

TS Logical Channel: Transport Stream Logical Channel. In this document,
this term identifies a channel at the MPEG-2 level [ISO-MPEG2]. It
exists at level 2 of the ISO/OSI reference model. All packets sent over
a TS Logical Channel carry the same PID value (this value is unique
within a specific TS Multiplex). The term "Stream" is defined in MPEG-2
[ISO-MPEG2] to describe the content carried by a specific TS Logical
Channel (see ULE Stream). Some PID values are reserved (by MPEG-2) for
specific signalling. Other standards (e.g., ATSC, DVB) also reserve
specific PID values.

**********************************************

----
Dr. Haitham S. Cruickshank 
Lecturer 
Communications Centre for Communication Systems Research (CCSR)
BA Building, Room E11 
School of Electronics, Computing and Mathematics
University of Surrey, Guildford, UK, GU2 7XH 
 
Tel: +44 1483 686007 (indirect 689844) 
Fax: +44 1483 686011 
e-mail: [email-masked] 
http://www.ee.surrey.ac.uk/Personal/H.Cruickshank/ 

-----Original Message-----
From: RFC Errata System [mailto:[email-masked]] 
Sent: 30 March 2009 08:25
To: Cruickshank HS Dr (CCSR); [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Technical Errata Reported] RFC5458 (1746)

The following errata report has been submitted for RFC5458, "Security
Requirements for the Unidirectional Lightweight Encapsulation (ULE)
Protocol".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5458&eid=1746

--------------------------------------
Type: Technical
Reported by: Alfred Hoenes <[email-masked]>

Section: 2

Original Text
-------------
[[ at the bottom of page 5 / top of page 6 ]]

   TS: Transport Stream [ISO-MPEG2].  A method of transmission at the
   MPEG-2 layer using TS Packets; it represents Layer 2 of the ISO/OSI
   reference model.  See also TS Logical Channel and TS Multiplex.
                              ^^^^^^^^^^^^^^^^^^^^^^^

<< page break >>

   TS Multiplex: In this document, ...

Corrected Text
--------------
   TS: Transport Stream [ISO-MPEG2].  A method of transmission at the
   MPEG-2 layer using TS Packets; it represents Layer 2 of the ISO/OSI
   reference model.  See also TS Logical Channel and TS Multiplex.
|
|  TS Logical Channel: ...   << to be filled in >>
|  ...

   TS Multiplex: In this document, ...

Notes
-----
The quoted keyword explanation for "TS Logical Channel" 
is missing in Section 2.

Authors/Verifiers:
  Please restore the entry and fill in the missing Corrected Text.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please use
"Reply All" to discuss whether it should be verified or rejected. When a
decision is reached, the verifying party (IESG) can log in to change the
status and edit the report, if necessary. 

--------------------------------------
RFC5458 (draft-ietf-ipdvb-sec-req-09)
--------------------------------------
Title               : Security Requirements for the Unidirectional
Lightweight Encapsulation (ULE) Protocol
Publication Date    : March 2009
Author(s)           : H. Cruickshank, P. Pillai, M. Noisternig, S.
Iyengar
Category            : INFORMATIONAL
Source              : IP over DVB
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: "Allison, Art" <[email-masked]>
Date: Tue, 7 Apr 2009 16:03:20 -0400

It is simply dead wrong to use TS logical channel in relation to
defining a Transport Stream. 
The errata should delete the term TS logical  channel, not define it as
it only misleads and propagates misunderstanding. 

The term 'TS logical channel'  is not a peer of 'TS multiplex', it is a
component of the TS multiplex. 

A MPEG-2 Transport Stream is a multiplex consisting of a collection of
elementary streams in 188-byte packets each stream having a Packet
IDentifier (PID). 

I attempted to inform authors of RFC4326 of the poor construction at the
time, but the inventors of the term had more time and used it very very
narrowly so it was no longer dead wrong use, at which point my budget to
support this work was exhausted.
 
I do have time to educate and advocate better resolution of this errata;
but for accurate usage of PID and transport stream see ISO/ITU 13818-1,
not later attempts to 'clarify' those terms by those not expert in
MPEG-2 Systems. 

Art
Art Allison

Director Advanced Engineering, Science and Technology
 
National Association of Broadcasters
1771 N Street NW
Washington, DC 20036
Phone  202 429 5418 
Fax  202 775 4981
www.nab.org

Advocacy  Education  Innovation

|-----Original Message-----
|From: [email-masked] 
|[mailto:[email-masked]] On Behalf Of 
[email-masked]
|Sent: Tuesday, April 07, 2009 11:47 AM
|To: [email-masked]; [email-masked]; 
[email-masked]; [email-masked]; 
[email-masked]; [email-masked]; [email-masked]; 
[email-masked]
|Cc: [email-masked]; [email-masked]
|Subject: RE: [Technical Errata Reported] RFC5458 (1746)
|
|
| Hi again,
|
|I suggest to add the the TS Logical Channel definition (taken 
|from RFC 4326). So here is the proposed text:
|
|*********************************************
|
|TS Logical Channel: Transport Stream Logical Channel. In this 
|document, this term identifies a channel at the MPEG-2 level 
|[ISO-MPEG2]. It exists at level 2 of the ISO/OSI reference 
|model. All packets sent over a TS Logical Channel carry the 
|same PID value (this value is unique within a specific TS 
|Multiplex). The term "Stream" is defined in MPEG-2 [ISO-MPEG2] 
|to describe the content carried by a specific TS Logical 
|Channel (see ULE Stream). Some PID values are reserved (by 
|MPEG-2) for specific signalling. Other standards (e.g., ATSC, 
|DVB) also reserve specific PID values.
|
|**********************************************
|
|
|----
|Dr. Haitham S. Cruickshank
|Lecturer
|Communications Centre for Communication Systems Research 
|(CCSR) BA Building, Room E11 School of Electronics, Computing 
|and Mathematics University of Surrey, Guildford, UK, GU2 7XH 
| 
|Tel: +44 1483 686007 (indirect 689844)
|Fax: +44 1483 686011
|e-mail: [email-masked]
|http://www.ee.surrey.ac.uk/Personal/H.Cruickshank/ 
|
|-----Original Message-----
|From: RFC Errata System [mailto:[email-masked]]
|Sent: 30 March 2009 08:25
|To: Cruickshank HS Dr (CCSR); [email-masked]; 
[email-masked]; [email-masked]; 
[email-masked]; [email-masked]; [email-masked]; 
[email-masked]
|Cc: [email-masked]; [email-masked]; [email-masked]
|Subject: [Technical Errata Reported] RFC5458 (1746)
|
|
|The following errata report has been submitted for RFC5458, "Security
|Requirements for the Unidirectional Lightweight Encapsulation (ULE)
|Protocol".
|
|--------------------------------------
|You may review the report below and at:
|http://www.rfc-editor.org/errata_search.php?rfc=5458&eid=1746
|
|--------------------------------------
|Type: Technical
|Reported by: Alfred Hoenes <[email-masked]>
|
|Section: 2
|
|Original Text
|-------------
|[[ at the bottom of page 5 / top of page 6 ]]
|
|   TS: Transport Stream [ISO-MPEG2].  A method of transmission at the
|   MPEG-2 layer using TS Packets; it represents Layer 2 of the ISO/OSI
|   reference model.  See also TS Logical Channel and TS Multiplex.
|                              ^^^^^^^^^^^^^^^^^^^^^^^
|
|<< page break >>
|
|   TS Multiplex: In this document, ...
|
|
|
|Corrected Text
|--------------
|   TS: Transport Stream [ISO-MPEG2].  A method of transmission at the
|   MPEG-2 layer using TS Packets; it represents Layer 2 of the ISO/OSI
|   reference model.  See also TS Logical Channel and TS Multiplex.
||
||  TS Logical Channel: ...   << to be filled in >>
||  ...
|
|   TS Multiplex: In this document, ...
|
|
|
|
|Notes
|-----
|The quoted keyword explanation for "TS Logical Channel" 
|is missing in Section 2.
|
|Authors/Verifiers:
|  Please restore the entry and fill in the missing Corrected Text.
|
|Instructions:
|-------------
|This errata is currently posted as "Reported". If necessary, please use
|"Reply All" to discuss whether it should be verified or 
|rejected. When a
|decision is reached, the verifying party (IESG) can log in to 
|change the
|status and edit the report, if necessary. 
|
|--------------------------------------
|RFC5458 (draft-ietf-ipdvb-sec-req-09)
|--------------------------------------
|Title               : Security Requirements for the Unidirectional
|Lightweight Encapsulation (ULE) Protocol
|Publication Date    : March 2009
|Author(s)           : H. Cruickshank, P. Pillai, M. Noisternig, S.
|Iyengar
|Category            : INFORMATIONAL
|Source              : IP over DVB
|Area                : Internet
|Stream              : IETF
|Verifying Party     : IESG
|
|

---

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 29 Apr 2009 07:45:44 +0100

After looking at this reported Errata, I suggest there does seems to be 
a valid issue to note. My thoughts are that the term 'TS logical 
channel' has been used to describe a component of the TS multiplex, 
carried as an elementary stream (ES) over a MPEG-2 TS. This term was 
used to differentiate it from the term "stream" which is widely used in 
other IETF specs to describe something different. It is not a peer of 
'TS multiplex'.

Given the term is already defined in other RFCs that are cited,
I suggest this is not likely to result in implementation errors in
future protocols.  I suggest the WG categorise this as "Hold for
Document Update" - i.e. a future update of the document should consider
this erratum when making the update.

If anyone would like to add further comments, please send them to the 
list by 5th May 2009. After this date we will inform the RFC-Ed of a 
decision.

Best wishes,

Gorry Fairhurst
IPDVB Chair

---

From: "Allison, Art" <[email-masked]>
Date: Wed, 29 Apr 2009 09:58:00 -0400

The definition using the undefined term is "TS: Transport Stream
[ISO-MPEG2]."   A method of 
transmission at the MPEG-2 layer using TS Packets; it represents Layer 2
of 
the ISO/OSI reference model.  See also TS Logical Channel and TS
Multiplex."

Fixing this error by defining the term "TS logical channel' is indeed
difficult, but as it was only introduces as one of two 'see also'
references, fixing the definition by deletion seems appropriate as the
'see also' only misleads. 
So, I suggest the last sentence be changed to read "See also TS
Multiplex."

This would remove the reference to an undefined term, and thereby
resolve the documentation issue.

Art
Art Allison

Senior Director Advanced Engineering, Science and Technology

|-----Original Message-----
|From: [email-masked] 
|[mailto:[email-masked]] On Behalf Of Gorry Fairhurst
|Sent: Wednesday, April 29, 2009 2:46 AM
|To: [email-masked]
|Cc: [email-masked]; [email-masked]; 
[email-masked]; [email-masked]; 
[email-masked]; [email-masked]; [email-masked]
|Subject: Re: [Technical Errata Reported] RFC5458 (1746)
|
|After looking at this reported Errata, I suggest there does 
|seems to be a valid issue to note. My thoughts are that the 
|term 'TS logical channel' has been used to describe a 
|component of the TS multiplex, carried as an elementary stream 
|(ES) over a MPEG-2 TS. This term was used to differentiate it 
|from the term "stream" which is widely used in other IETF 
|specs to describe something different. It is not a peer of 'TS 
|multiplex'.
|
|Given the term is already defined in other RFCs that are 
|cited, I suggest this is not likely to result in 
|implementation errors in future protocols.  I suggest the WG 
|categorise this as "Hold for Document Update" - i.e. a future 
|update of the document should consider this erratum when 
|making the update.
|
|If anyone would like to add further comments, please send them 
|to the list by 5th May 2009. After this date we will inform 
|the RFC-Ed of a decision.
|
|Best wishes,
|
|Gorry Fairhurst
|IPDVB Chair
|
|Allison, Art wrote:
|> It is simply dead wrong to use TS logical channel in relation to 
|> defining a Transport Stream.
|> The errata should delete the term TS logical  channel, not define it 
|> as it only misleads and propagates misunderstanding.
|> 
|> The term 'TS logical channel'  is not a peer of 'TS 
|multiplex', it is 
|> a component of the TS multiplex.
|> 
|> A MPEG-2 Transport Stream is a multiplex consisting of a 
|collection of 
|> elementary streams in 188-byte packets each stream having a Packet 
|> IDentifier (PID).
|> 
|> I attempted to inform authors of RFC4326 of the poor construction at 
|> the time, but the inventors of the term had more time and 
|used it very 
|> very narrowly so it was no longer dead wrong use, at which point my 
|> budget to support this work was exhausted.
|>  
|> I do have time to educate and advocate better resolution of this 
|> errata; but for accurate usage of PID and transport stream 
|see ISO/ITU 
|> 13818-1, not later attempts to 'clarify' those terms by those not 
|> expert in
|> MPEG-2 Systems. 
|> 
|> Art
|> Art Allison
|> 
|> Director Advanced Engineering, Science and Technology
|>  
|> National Association of Broadcasters
|> 1771 N Street NW
|> Washington, DC 20036
|> Phone  202 429 5418
|> Fax  202 775 4981
|> www.nab.org
|> 
|> Advocacy  Education  Innovation
|> 
|> 
|>   
|> 
|> 
|> 
|> |-----Original Message-----
|> |From: [email-masked]
|> |[mailto:[email-masked]] On Behalf Of 
|> [email-masked]
|> |Sent: Tuesday, April 07, 2009 11:47 AM
|> |To: [email-masked]; [email-masked]; 
|> [email-masked]; [email-masked]; [email-masked]; 
|> [email-masked]; [email-masked]; [email-masked]
|> |Cc: [email-masked]; [email-masked]
|> |Subject: RE: [Technical Errata Reported] RFC5458 (1746)
|> |
|> |
|> | Hi again,
|> |
|> |I suggest to add the the TS Logical Channel definition (taken from 
|> |RFC 4326). So here is the proposed text:
|> |
|> |*********************************************
|> |
|> |TS Logical Channel: Transport Stream Logical Channel. In this 
|> |document, this term identifies a channel at the MPEG-2 level 
|> |[ISO-MPEG2]. It exists at level 2 of the ISO/OSI reference 
|model. All 
|> |packets sent over a TS Logical Channel carry the same PID 
|value (this 
|> |value is unique within a specific TS Multiplex). The term 
|"Stream" is 
|> |defined in MPEG-2 [ISO-MPEG2] to describe the content carried by a 
|> |specific TS Logical Channel (see ULE Stream). Some PID values are 
|> |reserved (by
|> |MPEG-2) for specific signalling. Other standards (e.g., ATSC,
|> |DVB) also reserve specific PID values.
|> |
|> |**********************************************
|> |
|> |
|> |----
|> |Dr. Haitham S. Cruickshank
|> |Lecturer
|> |Communications Centre for Communication Systems Research
|> |(CCSR) BA Building, Room E11 School of Electronics, Computing and 
|> |Mathematics University of Surrey, Guildford, UK, GU2 7XH
|> | 
|> |Tel: +44 1483 686007 (indirect 689844)
|> |Fax: +44 1483 686011
|> |e-mail: [email-masked]
|> |http://www.ee.surrey.ac.uk/Personal/H.Cruickshank/
|> |
|> |-----Original Message-----
|> |From: RFC Errata System [mailto:[email-masked]]
|> |Sent: 30 March 2009 08:25
|> |To: Cruickshank HS Dr (CCSR); [email-masked]; 
|> [email-masked]; [email-masked]; [email-masked]; 
|> [email-masked]; [email-masked]; [email-masked]
|> |Cc: [email-masked]; [email-masked]; [email-masked]
|> |Subject: [Technical Errata Reported] RFC5458 (1746)
|> |
|> |
|> |The following errata report has been submitted for RFC5458, 
|"Security
|> |Requirements for the Unidirectional Lightweight Encapsulation (ULE)
|> |Protocol".
|> |
|> |--------------------------------------
|> |You may review the report below and at:
|> |http://www.rfc-editor.org/errata_search.php?rfc=5458&eid=1746
|> |
|> |--------------------------------------
|> |Type: Technical
|> |Reported by: Alfred Hoenes <[email-masked]>
|> |
|> |Section: 2
|> |
|> |Original Text
|> |-------------
|> |[[ at the bottom of page 5 / top of page 6 ]]
|> |
|> |   TS: Transport Stream [ISO-MPEG2].  A method of 
|transmission at the
|> |   MPEG-2 layer using TS Packets; it represents Layer 2 of 
|the ISO/OSI
|> |   reference model.  See also TS Logical Channel and TS Multiplex.
|> |                              ^^^^^^^^^^^^^^^^^^^^^^^
|> |
|> |<< page break >>
|> |
|> |   TS Multiplex: In this document, ...
|> |
|> |
|> |
|> |Corrected Text
|> |--------------
|> |   TS: Transport Stream [ISO-MPEG2].  A method of 
|transmission at the
|> |   MPEG-2 layer using TS Packets; it represents Layer 2 of 
|the ISO/OSI
|> |   reference model.  See also TS Logical Channel and TS Multiplex.
|> ||
|> ||  TS Logical Channel: ...   << to be filled in >>
|> ||  ...
|> |
|> |   TS Multiplex: In this document, ...
|> |
|> |
|> |
|> |
|> |Notes
|> |-----
|> |The quoted keyword explanation for "TS Logical Channel" 
|> |is missing in Section 2.
|> |
|> |Authors/Verifiers:
|> |  Please restore the entry and fill in the missing Corrected Text.
|> |
|> |Instructions:
|> |-------------
|> |This errata is currently posted as "Reported". If 
|necessary, please use
|> |"Reply All" to discuss whether it should be verified or 
|> |rejected. When a
|> |decision is reached, the verifying party (IESG) can log in to 
|> |change the
|> |status and edit the report, if necessary. 
|> |
|> |--------------------------------------
|> |RFC5458 (draft-ietf-ipdvb-sec-req-09)
|> |--------------------------------------
|> |Title               : Security Requirements for the Unidirectional
|> |Lightweight Encapsulation (ULE) Protocol
|> |Publication Date    : March 2009
|> |Author(s)           : H. Cruickshank, P. Pillai, M. Noisternig, S.
|> |Iyengar
|> |Category            : INFORMATIONAL
|> |Source              : IP over DVB
|> |Area                : Internet
|> |Stream              : IETF
|> |Verifying Party     : IESG
|> |
|> |
|> 
|> 
|
|
|

---

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 29 Apr 2009 15:50:25 +0100

Noted, but it is not possible to delete lines from an RFC, we can make a 
public Errata statement if the protocol has a significant error or there 
is an ambiguity that will lead to implementation error, etc. Or we can 
make a note in the document database, that will be used when a new RFC 
is issued to replace this one. I suggested the latter.

Gorry

---

From: <[email-masked]>
Date: Wed, 29 Apr 2009 17:40:24 +0100

I agree with Gorry's suggestion.
Haitham

----

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Gorry Fairhurst
Sent: 29 April 2009 15:50
To: [email-masked]
Subject: Re: [Technical Errata Reported] RFC5458 (1746)

Gorry

Allison, Art wrote:
> transmission at the MPEG-2 layer using TS Packets; it represents Layer

> 2 of the ISO/OSI reference model.  See also TS Logical Channel and TS 
> Multiplex."
> 

> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> |After looking at this reported Errata, I suggest there does seems to 
> |be a valid issue to note. My thoughts are that the term 'TS logical 
> |channel' has been used to describe a component of the TS multiplex, 
> |carried as an elementary stream
> |(ES) over a MPEG-2 TS. This term was used to differentiate it from 
> |the term "stream" which is widely used in other IETF specs to 
> |describe something different. It is not a peer of 'TS multiplex'.
> |
> |Given the term is already defined in other RFCs that are cited, I 
> |suggest this is not likely to result in implementation errors in 
> |future protocols.  I suggest the WG categorise this as "Hold for 
> |Document Update" - i.e. a future update of the document should 
> |consider this erratum when making the update.
> |
> |If anyone would like to add further comments, please send them to the

> |list by 5th May 2009. After this date we will inform the RFC-Ed of a 
> |decision.
> |
> |Best wishes,
> |
> |Gorry Fairhurst
> |IPDVB Chair
> |
> |Allison, Art wrote:
> |> The errata should delete the term TS logical  channel, not define 
> |> it as it only misleads and propagates misunderstanding.
> |> 
> |> I attempted to inform authors of RFC4326 of the poor construction 
> |> at the time, but the inventors of the term had more time and
> |used it very

> |> |Requirements for the Unidirectional Lightweight Encapsulation 
> |> |(ULE) Protocol".
> |> |
> |> |"Reply All" to discuss whether it should be verified or rejected. 
> |> |When a decision is reached, the verifying party (IESG) can log in 
> |> |to change the status and edit the report, if necessary.
> |> |

---

From: "Allison, Art" <[email-masked]>
Date: Wed, 29 Apr 2009 13:16:08 -0400

OK, if it is outside IETF process to have an errata that says " the line
...."  is not accurate and should read  " ..." in order to be accurate;
then so be it.
While I assert the line is technically in error; I agree it is
informative and therefore may only cause some confusion by an
implementation and should, not lead to an implementation error. 

Art
|-----Original Message-----
|From: [email-masked] 
|[mailto:[email-masked]] On Behalf Of 
[email-masked]
|Sent: Wednesday, April 29, 2009 12:40 PM
|To: [email-masked]
|Subject: RE: [Technical Errata Reported] RFC5458 (1746)
|
|
| I agree with Gorry's suggestion.
|Haitham
|
|
|----
|Dr. Haitham S. Cruickshank
|Lecturer
|Communications Centre for Communication Systems Research 
|(CCSR) BA Building, Room E11 School of Electronics, Computing 
|and Mathematics University of Surrey, Guildford, UK, GU2 7XH 
| 
|Tel: +44 1483 686007 (indirect 689844)
|Fax: +44 1483 686011
|e-mail: [email-masked]
|http://www.ee.surrey.ac.uk/Personal/H.Cruickshank/ 
|
|-----Original Message-----
|From: [email-masked] 
|[mailto:[email-masked]] On Behalf Of Gorry Fairhurst
|Sent: 29 April 2009 15:50
|To: [email-masked]
|Subject: Re: [Technical Errata Reported] RFC5458 (1746)
|
|Noted, but it is not possible to delete lines from an RFC, we 
|can make a public Errata statement if the protocol has a 
|significant error or there is an ambiguity that will lead to 
|implementation error, etc. Or we can make a note in the 
|document database, that will be used when a new RFC is issued 
|to replace this one. I suggested the latter.
|
|Gorry
|
|
|Allison, Art wrote:
|> The definition using the undefined term is "TS: Transport Stream
|> [ISO-MPEG2]."   A method of 
|> transmission at the MPEG-2 layer using TS Packets; it 
|represents Layer
|
|> 2 of the ISO/OSI reference model.  See also TS Logical 
|Channel and TS 
|> Multiplex."
|> 
|> Fixing this error by defining the term "TS logical channel' 
|is indeed 
|> difficult, but as it was only introduces as one of two 'see also'
|> references, fixing the definition by deletion seems 
|appropriate as the
|
|> 'see also' only misleads.
|> So, I suggest the last sentence be changed to read "See also TS 
|> Multiplex."
|> 
|> This would remove the reference to an undefined term, and thereby 
|> resolve the documentation issue.
|> 
|> Art
|> Art Allison
|> 
|> Senior Director Advanced Engineering, Science and Technology
|>  
|> National Association of Broadcasters
|> 1771 N Street NW
|> Washington, DC 20036
|> Phone  202 429 5418
|> Fax  202 775 4981
|> www.nab.org
|> 
|> Advocacy  Education  Innovation
|> 
|> 
|> 
|> 
|> |-----Original Message-----
|> |From: [email-masked]
|> |[mailto:[email-masked]] On Behalf Of Gorry Fairhurst
|> |Sent: Wednesday, April 29, 2009 2:46 AM
|> |To: [email-masked]
|> |Cc: [email-masked]; [email-masked]; 
|> [email-masked]; [email-masked]; [email-masked]; 
|> [email-masked]; [email-masked]
|> |Subject: Re: [Technical Errata Reported] RFC5458 (1746)
|> |
|> |After looking at this reported Errata, I suggest there does 
|seems to 
|> |be a valid issue to note. My thoughts are that the term 'TS logical 
|> |channel' has been used to describe a component of the TS multiplex, 
|> |carried as an elementary stream
|> |(ES) over a MPEG-2 TS. This term was used to differentiate it from 
|> |the term "stream" which is widely used in other IETF specs to 
|> |describe something different. It is not a peer of 'TS multiplex'.
|> |
|> |Given the term is already defined in other RFCs that are cited, I 
|> |suggest this is not likely to result in implementation errors in 
|> |future protocols.  I suggest the WG categorise this as "Hold for 
|> |Document Update" - i.e. a future update of the document should 
|> |consider this erratum when making the update.
|> |
|> |If anyone would like to add further comments, please send 
|them to the
|
|> |list by 5th May 2009. After this date we will inform the 
|RFC-Ed of a 
|> |decision.
|> |
|> |Best wishes,
|> |
|> |Gorry Fairhurst
|> |IPDVB Chair
|> |
|> |Allison, Art wrote:
|> |> It is simply dead wrong to use TS logical channel in relation to 
|> |> defining a Transport Stream.
|> |> The errata should delete the term TS logical  channel, not define 
|> |> it as it only misleads and propagates misunderstanding.
|> |> 
|> |> The term 'TS logical channel'  is not a peer of 'TS
|> |multiplex', it is
|> |> a component of the TS multiplex.
|> |> 
|> |> A MPEG-2 Transport Stream is a multiplex consisting of a
|> |collection of
|> |> elementary streams in 188-byte packets each stream having 
|a Packet 
|> |> IDentifier (PID).
|> |> 
|> |> I attempted to inform authors of RFC4326 of the poor construction 
|> |> at the time, but the inventors of the term had more time and
|> |used it very
|> |> very narrowly so it was no longer dead wrong use, at 
|which point my
|
|> |> budget to support this work was exhausted.
|> |>  
|> |> I do have time to educate and advocate better resolution of this 
|> |> errata; but for accurate usage of PID and transport stream
|> |see ISO/ITU
|> |> 13818-1, not later attempts to 'clarify' those terms by those not 
|> |> expert in
|> |> MPEG-2 Systems. 
|> |> 
|> |> Art
|> |> Art Allison
|> |> 
|> |> Director Advanced Engineering, Science and Technology
|> |>  
|> |> National Association of Broadcasters
|> |> 1771 N Street NW
|> |> Washington, DC 20036
|> |> Phone  202 429 5418
|> |> Fax  202 775 4981
|> |> www.nab.org
|> |> 
|> |> Advocacy  Education  Innovation
|> |> 
|> |> 
|> |>   
|> |> 
|> |> 
|> |> 
|> |> |-----Original Message-----
|> |> |From: [email-masked]
|> |> |[mailto:[email-masked]] On Behalf Of 
|> |> [email-masked]
|> |> |Sent: Tuesday, April 07, 2009 11:47 AM
|> |> |To: [email-masked]; [email-masked]; 
|> |> [email-masked]; [email-masked]; 
[email-masked];
|
|> |> [email-masked]; [email-masked]; [email-masked]
|> |> |Cc: [email-masked]; [email-masked]
|> |> |Subject: RE: [Technical Errata Reported] RFC5458 (1746)
|> |> |
|> |> |
|> |> | Hi again,
|> |> |
|> |> |I suggest to add the the TS Logical Channel definition 
|(taken from
|
|> |> |RFC 4326). So here is the proposed text:
|> |> |
|> |> |*********************************************
|> |> |
|> |> |TS Logical Channel: Transport Stream Logical Channel. In this 
|> |> |document, this term identifies a channel at the MPEG-2 level 
|> |> |[ISO-MPEG2]. It exists at level 2 of the ISO/OSI reference
|> |model. All
|> |> |packets sent over a TS Logical Channel carry the same PID
|> |value (this
|> |> |value is unique within a specific TS Multiplex). The term
|> |"Stream" is
|> |> |defined in MPEG-2 [ISO-MPEG2] to describe the content 
|carried by a
|
|> |> |specific TS Logical Channel (see ULE Stream). Some PID 
|values are 
|> |> |reserved (by
|> |> |MPEG-2) for specific signalling. Other standards (e.g., ATSC,
|> |> |DVB) also reserve specific PID values.
|> |> |
|> |> |**********************************************
|> |> |
|> |> |
|> |> |----
|> |> |Dr. Haitham S. Cruickshank
|> |> |Lecturer
|> |> |Communications Centre for Communication Systems Research
|> |> |(CCSR) BA Building, Room E11 School of Electronics, 
|Computing and 
|> |> |Mathematics University of Surrey, Guildford, UK, GU2 7XH
|> |> | 
|> |> |Tel: +44 1483 686007 (indirect 689844)
|> |> |Fax: +44 1483 686011
|> |> |e-mail: [email-masked] 
|> |> |http://www.ee.surrey.ac.uk/Personal/H.Cruickshank/
|> |> |
|> |> |-----Original Message-----
|> |> |From: RFC Errata System [mailto:[email-masked]]
|> |> |Sent: 30 March 2009 08:25
|> |> |To: Cruickshank HS Dr (CCSR); [email-masked]; 
|> |> [email-masked]; [email-masked]; 
[email-masked];
|
|> |> [email-masked]; [email-masked]; [email-masked]
|> |> |Cc: [email-masked]; [email-masked]; [email-masked]
|> |> |Subject: [Technical Errata Reported] RFC5458 (1746)
|> |> |
|> |> |
|> |> |The following errata report has been submitted for RFC5458,
|> |"Security
|> |> |Requirements for the Unidirectional Lightweight Encapsulation
|> |> |(ULE) Protocol".
|> |> |
|> |> |--------------------------------------
|> |> |You may review the report below and at:
|> |> |http://www.rfc-editor.org/errata_search.php?rfc=5458&eid=1746
|> |> |
|> |> |--------------------------------------
|> |> |Type: Technical
|> |> |Reported by: Alfred Hoenes <[email-masked]>
|> |> |
|> |> |Section: 2
|> |> |
|> |> |Original Text
|> |> |-------------
|> |> |[[ at the bottom of page 5 / top of page 6 ]]
|> |> |
|> |> |   TS: Transport Stream [ISO-MPEG2].  A method of
|> |transmission at the
|> |> |   MPEG-2 layer using TS Packets; it represents Layer 2 of
|> |the ISO/OSI
|> |> |   reference model.  See also TS Logical Channel and TS 
|Multiplex.
|> |> |                              ^^^^^^^^^^^^^^^^^^^^^^^
|> |> |
|> |> |<< page break >>
|> |> |
|> |> |   TS Multiplex: In this document, ...
|> |> |
|> |> |
|> |> |
|> |> |Corrected Text
|> |> |--------------
|> |> |   TS: Transport Stream [ISO-MPEG2].  A method of
|> |transmission at the
|> |> |   MPEG-2 layer using TS Packets; it represents Layer 2 of
|> |the ISO/OSI
|> |> |   reference model.  See also TS Logical Channel and TS 
|Multiplex.
|> |> ||
|> |> ||  TS Logical Channel: ...   << to be filled in >>
|> |> ||  ...
|> |> |
|> |> |   TS Multiplex: In this document, ...
|> |> |
|> |> |
|> |> |
|> |> |
|> |> |Notes
|> |> |-----
|> |> |The quoted keyword explanation for "TS Logical Channel" 
|> |> |is missing in Section 2.
|> |> |
|> |> |Authors/Verifiers:
|> |> |  Please restore the entry and fill in the missing 
|Corrected Text.
|> |> |
|> |> |Instructions:
|> |> |-------------
|> |> |This errata is currently posted as "Reported". If
|> |necessary, please use
|> |> |"Reply All" to discuss whether it should be verified or 
|rejected. 
|> |> |When a decision is reached, the verifying party (IESG) 
|can log in 
|> |> |to change the status and edit the report, if necessary.
|> |> |
|> |> |--------------------------------------
|> |> |RFC5458 (draft-ietf-ipdvb-sec-req-09)
|> |> |--------------------------------------
|> |> |Title               : Security Requirements for the 
|Unidirectional
|> |> |Lightweight Encapsulation (ULE) Protocol
|> |> |Publication Date    : March 2009
|> |> |Author(s)           : H. Cruickshank, P. Pillai, M. 
|Noisternig, S.
|> |> |Iyengar
|> |> |Category            : INFORMATIONAL
|> |> |Source              : IP over DVB
|> |> |Area                : Internet
|> |> |Stream              : IETF
|> |> |Verifying Party     : IESG
|> |> |
|> |> |
|> |> 
|> |> 
|> |
|> |
|> |
|> 
|> 
|
|
|

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 30 Apr 2009 12:09:52 +0100

[Sent not as WG chair]: I personally find it hard to see that this 
impacts implementation and interoperability, because this is a 
requirements spec. The term is defined already in RFC 4326.

[As WG Chair]: I would appreciate other working group feedback if other 
people have comments on this issue. Working Group members, please send 
feedback to the list, and we shall judge consensus by 5th May 2009.

Gorry

-- 
Dr Gorry Fairhurst, School of Engineering, University of Aberdeen.
The University of Aberdeen is a charity registered in Scotland,
No SC013683.

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 30 Apr 2009 07:47:37 -0400

As WG member and contributor to the original RFCs of this group I  
believe that any implementor of RFC5458 will not be lead to an  
erroneous implementation or even to confusion because of the chosen  
language. I would go further to say that at this point to redefine  
terms would be more confusing. Any implementor of RFC5458 will be  
already familiar with the multiple definitions of "streams" and  
"channels" that are used differently in the broadcast and Internet  
industries.

/mjm
Marie-Jose Montpetit, Ph.D.
Invited Scientist, MIT
[email-masked]

On Apr 30, 2009, at 7:09 AM, Gorry Fairhurst wrote:

> [As WG Chair]: I would appreciate other working group feedback if  
> other people have comments on this issue. Working Group members,  
> please send feedback to the list, and we shall judge consensus by  
> 5th May 2009.
>
> Gorry
>
> Allison, Art wrote:
>> implementation and should, not lead to an implementation error. Art
>> |From: [email-masked] |[mailto:owner- 
>> [email-masked]] On Behalf Of [email-masked]
>> |Communications Centre for Communication Systems Research |(CCSR)  
>> BA Building, Room E11 School of Electronics, Computing |and  
>> Mathematics University of Surrey, Guildford, UK, GU2 7XH | |Tel:  
>> +44 1483 686007 (indirect 689844)
>> |Fax: +44 1483 686011
>> |http://www.ee.surrey.ac.uk/Personal/H.Cruickshank/ |
>> |From: [email-masked] |[mailto:owner- 
>> [email-masked]] On Behalf Of Gorry Fairhurst
>> |Noted, but it is not possible to delete lines from an RFC, we |can  
>> make a public Errata statement if the protocol has a |significant  
>> error or there is an ambiguity that will lead to |implementation  
>> error, etc. Or we can make a note in the |document database, that  
>> will be used when a new RFC is issued |to replace this one. I  
>> suggested the latter.
>> |
>> |Gorry
>> |
>> |
>> |Allison, Art wrote:
>> |> [ISO-MPEG2]."   A method of |> transmission at the MPEG-2 layer  
>> using TS Packets; it |represents Layer
>> |
>> |> 2 of the ISO/OSI reference model.  See also TS Logical |Channel  
>> and TS |> Multiplex."
>> |> |> Fixing this error by defining the term "TS logical channel' | 
>> is indeed |> difficult, but as it was only introduces as one of two  
>> 'see also'
>> |> references, fixing the definition by deletion seems |appropriate  
>> as the
>> |
>> |> So, I suggest the last sentence be changed to read "See also TS | 
>> > Multiplex."
>> |> |> This would remove the reference to an undefined term, and  
>> thereby |> resolve the documentation issue.
>> |> |> Art
>> |> Art Allison
>> |> |> Senior Director Advanced Engineering, Science and Technology
>> |> |> |> |> |> |-----Original Message-----
>> |> |Cc: [email-masked]; [email-masked]; |> [email-masked] 
>> ; [email-masked]; [email-masked]; |> [email-masked] 
>> ; [email-masked]
>> |> |After looking at this reported Errata, I suggest there does | 
>> seems to |> |be a valid issue to note. My thoughts are that the  
>> term 'TS logical |> |channel' has been used to describe a component  
>> of the TS multiplex, |> |carried as an elementary stream
>> |> |(ES) over a MPEG-2 TS. This term was used to differentiate it  
>> from |> |the term "stream" which is widely used in other IETF specs  
>> to |> |describe something different. It is not a peer of 'TS  
>> multiplex'.
>> |> |
>> |> |Given the term is already defined in other RFCs that are cited,  
>> I |> |suggest this is not likely to result in implementation errors  
>> in |> |future protocols.  I suggest the WG categorise this as "Hold  
>> for |> |Document Update" - i.e. a future update of the document  
>> should |> |consider this erratum when making the update.
>> |> |
>> |> |If anyone would like to add further comments, please send |them  
>> to the
>> |
>> |> |list by 5th May 2009. After this date we will inform the |RFC- 
>> Ed of a |> |decision.
>> |> |
>> |> |Best wishes,
>> |> |
>> |> |Gorry Fairhurst
>> |> |IPDVB Chair
>> |> |
>> |> |Allison, Art wrote:
>> |> |> It is simply dead wrong to use TS logical channel in relation  
>> to |> |> defining a Transport Stream.
>> |> |> The errata should delete the term TS logical  channel, not  
>> define |> |> it as it only misleads and propagates misunderstanding.
>> |> |> |> |> The term 'TS logical channel'  is not a peer of 'TS
>> |> |multiplex', it is
>> |> |> |> |> A MPEG-2 Transport Stream is a multiplex consisting of a
>> |> |collection of
>> |> |> elementary streams in 188-byte packets each stream having |a  
>> Packet |> |> IDentifier (PID).
>> |> |> |> |> I attempted to inform authors of RFC4326 of the poor  
>> construction |> |> at the time, but the inventors of the term had  
>> more time and
>> |> |used it very
>> |> |> very narrowly so it was no longer dead wrong use, at |which  
>> point my
>> |
>> |> |>  |> |> I do have time to educate and advocate better  
>> resolution of this |> |> errata; but for accurate usage of PID and  
>> transport stream
>> |> |see ISO/ITU
>> |> |> 13818-1, not later attempts to 'clarify' those terms by those  
>> not |> |> expert in
>> |> |> MPEG-2 Systems. |> |> |> |> Art
>> |> |> Art Allison
>> |> |> |> |> Director Advanced Engineering, Science and Technology
>> |> |>  |> |> National Association of Broadcasters
>> |> |> 1771 N Street NW
>> |> |> |> |> Advocacy  Education  Innovation
>> |> |> |> |> |> |>   |> |> |> |> |> |> |> |> |-----Original  
>> Message-----
>> |> |> |[mailto:[email-masked]] On Behalf Of |> |> [email-masked]
>> |> |> |To: [email-masked]; [email-masked]; |> | 
>> > [email-masked]; [email-masked]; | 
>> [email-masked];
>> |
>> |> |> |I suggest to add the the TS Logical Channel definition | 
>> (taken from
>> |
>> |> |> |TS Logical Channel: Transport Stream Logical Channel. In  
>> this |> |> |document, this term identifies a channel at the MPEG-2  
>> level |> |> |[ISO-MPEG2]. It exists at level 2 of the ISO/OSI  
>> reference
>> |> |model. All
>> |> |> |defined in MPEG-2 [ISO-MPEG2] to describe the content | 
>> carried by a
>> |
>> |> |> |specific TS Logical Channel (see ULE Stream). Some PID | 
>> values are |> |> |reserved (by
>> |> |> |(CCSR) BA Building, Room E11 School of Electronics, | 
>> Computing and |> |> |Mathematics University of Surrey, Guildford,  
>> UK, GU2 7XH
>> |> |> | |> |> |Tel: +44 1483 686007 (indirect 689844)
>> |> |> |e-mail: [email-masked] |> |> |http://www.ee.surrey.ac.uk/Personal/H.Cruickshank/
>> |> |> |
>> |> |> |To: Cruickshank HS Dr (CCSR); [email-masked]; |> |> [email-masked] 
>> ; [email-masked]; [email-masked];
>> |
>> |> |> |   reference model.  See also TS Logical Channel and TS | 
>> Multiplex.
>> |> |> |   reference model.  See also TS Logical Channel and TS | 
>> Multiplex.
>> |> |> ||
>> |> |> |The quoted keyword explanation for "TS Logical Channel" |> | 
>> |> |> |  Please restore the entry and fill in the missing | 
>> Corrected Text.
>> |> |> |
>> |> |> |Instructions:
>> |> |> |-------------
>> |> |> |"Reply All" to discuss whether it should be verified or | 
>> rejected. |> |> |When a decision is reached, the verifying party  
>> (IESG) |can log in |> |> |to change the status and edit the report,  
>> if necessary.
>> |> |> |
>> |> |> |Title               : Security Requirements for the | 
>> Unidirectional
>> |> |> |Author(s)           : H. Cruickshank, P. Pillai, M. | 
>> Noisternig, S.
>> |> |> |Iyengar
>> |> |> |> |> |> |