Subject: [ipfix] Fw: I-D ACTION:draft-ietf-ipfix-architecture-01.txt

From: "K.C. Norseth" <[email-masked]>
Date: Thu, 18 Apr 2002 06:56:52 -0600

In case no one saw this.

K.C.

----- Original Message -----
From: <[email-masked]>
To: <IETF-Announce:>
Cc: <[email-masked]>
Sent: Thursday, April 18, 2002 5:59 AM
Subject: I-D ACTION:draft-ietf-ipfix-architecture-01.txt

| A New Internet-Draft is available from the on-line Internet-Drafts
directories.
| This draft is a work item of the IP Flow Information Export Working Group
of the IETF.
|
| Title : Architecture Model for IP Flow Information Export
| Author(s) : K. Norseth, G. Sadasivan
| Filename : draft-ietf-ipfix-architecture-01.txt
| Pages : 22
| Date : 17-Apr-02
|
| This memo defines the architecture, for the export of measured IP
| flow information out of an IPFIX device to a collector, per the
| requirements defined in [2].
|
| A URL for this Internet-Draft is:
| http://www.ietf.org/internet-drafts/draft-ietf-ipfix-architecture-01.txt
|
| To remove yourself from the IETF Announcement list, send a message to
| ietf-announce-request with the word unsubscribe in the body of the
message.
|
| Internet-Drafts are also available by anonymous FTP. Login with the
username
| "anonymous" and a password of your e-mail address. After logging in,
| type "cd internet-drafts" and then
| "get draft-ietf-ipfix-architecture-01.txt".
|
| A list of Internet-Drafts directories can be found in
| http://www.ietf.org/shadow.html
| or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
|
|
| Internet-Drafts can also be obtained by e-mail.
|
| Send a message to:
| [email-masked].
| In the body type:
| "FILE /internet-drafts/draft-ietf-ipfix-architecture-01.txt".
|
| NOTE: The mail server at ietf.org can return the document in
| MIME-encoded form by using the "mpack" utility.  To use this
| feature, insert the command "ENCODING mime" before the "FILE"
| command.  To decode the response(s), you will need "munpack" or
| a MIME-compliant mail reader.  Different MIME-compliant mail readers
| exhibit different behavior, especially when dealing with
| "multipart" MIME messages (i.e. documents which have been split
| up into multiple messages), so check your local documentation on
| how to manipulate these messages.
|
|
| Below is the data which will enable a MIME compliant mail reader
| implementation to automatically retrieve the ASCII version of the
| Internet-Draft.
|

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: "kevin.zhang" <[email-masked]>
Date: Mon, 22 Apr 2002 16:05:00 -0700

Hi All,

I was reading the new architecture draft, and noticed that the author's addresses section was significantly modified (beyond editorial).  I would like to know what's the decision process on this change, do we have any consensus from the contributors to the document?

Thanks,

Kevin

> -----Original Message-----
> From: majordomo listserver [mailto:[email-masked]]On Behalf
> Of K.C. Norseth
> Sent: Thursday, April 18, 2002 5:57 AM
> To: [email-masked]
> Subject: [ipfix] Fw: I-D ACTION:draft-ietf-ipfix-architecture-01.txt
> 
> 
> In case no one saw this.
> 
> K.C.
> 
> Archive     http://ipfix.doit.wisc.edu/archive/ÿñÞ–™šŠ[hþf£¢·hšçzßÝ¢+ÿÂ+ýçnjwlk/ázZÿŠyž²Æ yºÉIì¹»®&Þ™¨¥¶æj:+v‰¨þwýÚ"·ü"±ÏÞvæ§vÆ²þéì¹»®&ÞŠ—âÇø§™ë,j›¡Ü€Èb½èm¶Ÿÿþ*_‹Ý¢+ÿÂ+ýçnýªÜ†+Þ

---

From: "kevin.zhang" <[email-masked]>
Date: Mon, 29 Apr 2002 21:44:14 -0400

Hi All,

I was reading the architecture draft -01, and believed that our discussions regarding control information and flow record are not accurately captured by the current draft.  Let me try to classify this issue one more time, and see if we can all agree on this going forward.

First, I don't believe we need the terms "Control Stream" and "Data Stream" as they are redundant to the terms "Control Information" and "Flow Record".  As they don't add any value to the document, let's remove them and define Control Information and Flow Record (or Flow Data) directly.

Secondly, the "control information" is bi-directional and exchanged between the exporting process and collectors. It is possible for "control information" to be sent uni-directional from the exporting process to collectors, but this is one instance of the "control information" exchange. We can then enumerate what consists of "control information".

I thus propose the following -

* Control Information, Flow Record
- The Control Information is exchanged between IPFIX end-points to facilitate the correct  protocol operations and Flow Record encoding/decoding. It may include flow definitions and templates.  
- The Flow Record is exported from the IPFIX exporting process to IPFIX collectors. It consists of data records representing the flow definitions and properties. 

Thanks,

KevinÿñÞ–™šŠ[hþf£¢·hšçzßÝ¢+ÿÂ+ýçnjwlk/ázZÿŠyž²Æ yºÉIì¹»®&Þ™¨¥¶æj:+v‰¨þwýÚ"·ü"±ÏÞvæ§vÆ²þéì¹»®&ÞŠ—âÇø§™ë,j›¡Ü€Èb½èm¶Ÿÿþ*_‹Ý¢+ÿÂ+ýçnýªÜ†+Þ