Subject: RE: [ipfix] ipfix vs. RMON

From: "Norseth, KC" <[email-masked]>
Date: Thu, 4 Apr 2002 11:43:57 -0500

Hi,

RMON and IPFIX are 2 different things.  A lot of devices will have both
enabled at the same time, where they are providing different information.

Some of the differences:
RMON - PULL data from collector
IPFIX - PUSH data to collectors.

RMON - Device statistics and alarms
IPFIX - Flow information (IP Flow Information Export)

RMON - Health of the device
IPFIX - health of the network

RMON - L2 & L3
IPFIX - L3

Hope this helps, there is a lot more than this, but this is a start.

K.C.

|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] 
|Sent: Thursday, April 04, 2002 9:17 AM
|To: [email-masked]
|Subject: [ipfix] ipfix vs. RMON
|
|
|Hi,
|
|I was asked about what the differences between IPFIX and RMON 
|(also defined at IETF) are. In particular, what IPFIX can do 
|that RMON cannot do? 
|
|My two cents are that IPFIX runs on top of reliable TCP, hence 
|allows exporting large chunk of data. Whereas RMON runs on top 
|of UDP, not efficient for large amount of data transporting. I 
|may have missed the main points. So any comments are appreciated.
|
|Best regards
|Man Li
|
|
|--
|Help        mailto:[email-masked] and say "help" 
|in message body
|Unsubscribe mailto:[email-masked] and say 
|"unsubscribe ipfix" in message body
|Archive     http://ipfix.doit.wisc.edu/archive/
|

---

From: [email-masked]
Date: Fri, 05 Apr 2002 10:29:57 -0500

RMON covers a lot more functionality than IPFIX. But I
assume you are referring to the portion that overlaps 
with IPFIX.

From a functional level, they are similar. The main
differences are one of implementation. KC outline
several of them already.

I'd like to add another, RMON stores a lot more data on
the device and requires a lot more memory. IPFIX's goal, 
I believe is to get the data off the box quickly for 
later analysis.

Again, IPFIX is aiming at high volume data which RMON
was not designed for.

Paul

"Norseth, KC" wrote:
> 
> Hi,
> 
> RMON and IPFIX are 2 different things.  A lot of devices will have
> both enabled at the same time, where they are providing different
> information.
> 
> Some of the differences:

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/