Subject: [ipfix] architecture draft

From: Ganesh Sadasivan <[email-masked]>
Date: Wed, 05 Jun 2002 18:43:41 -0700

Hi Nevil,

[email-masked] wrote:

> Hello Ganesh:

<snip>

>
>
>
>
> I've read the list messages about the Architecture draft.  By and large
> I agree with you, at this stage extra illustrative material is helpful.
> Once we've selected a protocol, I expect that we'll want to rework the
> architecture draft to be sure it covers the chosen protocol; that will
> be the right time to think about which parts - if any - are superfluous.

Agreed.

>
>
> Wrt one of your comments, section 5.2.1 is correct when it says IPFIX
> control and data streams MUST be transported over a congestion-aware
> protocol.  That's an IETF consensus, which the IESG reminded us about by
> putting it into the IPFIX charter.

After re-reading the text, the confusion is because in section 5.1, it is
stated that "The following is the list of criteria that the candidate protocol
SHOULD meet in order to be the qualified into the IPFIX architecture"
which is true because we did not find an exact match of what we want
and are in the process of  choosing the one which matches the most.
So "SHOULD" is applicable to the total of all the selection criteria. So
I'll leave the text as it is.

>
>
> Also, I was re-reading the Minneapolis minutes; in the discussion there
> 'Control Stream' was considered to be confusing, there was consensus for
> 'Data Description' instead.
>

"Data description" does not fully convey all the control information. There
could be messages like "Keepalives" which is part of the control and
has nothing to do with "Data Description".

Thanks
Ganesh

>
> Cheers, Nevil
>
> -----------------------------------------------------------------------
>    Nevil Brownlee                   Director, Technology Development
>    Phone: +64 9 373 7599 x8941      ITSS, The University of Auckland
>    FAX: +64 9 373 7021      Private Bag 92019, Auckland, New Zealand

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: "kevin.zhang" <[email-masked]>
Date: Thu, 6 Jun 2002 02:22:22 -0400

Hi Ganesh,

Please see my comments below.

Thanks,

Kevin

> -----Original Message-----
> From: majordomo listserver [mailto:[email-masked]]On Behalf
> Of Ganesh Sadasivan
> Sent: Wednesday, June 05, 2002 9:44 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [ipfix] architecture draft
> 
> 
> Hi Nevil,
> 

If everything is optional as indicated by "SHOULD".  What are the criteria we are talking about.  The core of the architecture draft should provide a high level guidance of the design of the IPFIX system, primarily the IPFIX protocol.  I believe now is a good time to separte hard boundaries (MUST) from soft ones (SHOULD).  As lengthy debate about the transport protocol has taken place, and a decision was made in Minn., Let's make congestion-aware protocol a MUST.

> has nothing to do with "Data Description".

Can we settle for "Control Information" for now as the term is generic enough to meet our needs.  We can later enumerate what consists of control information, e.g. keepalives, data descriptions, capability indications, etc. 

> Archive     http://ipfix.doit.wisc.edu/archive/��ޖ���[h�f���h���z�ݢ+��+��njwlk/�zZ��y��Ơy��I칻�&ޙ�����j:+v���w���"��"���v�vƲ��칻�&ފ�������,j��܀��b��m����*_�ݢ+��+��n��܆+�