Subject: RE: [ipfix-eval] Question regarding Wiretapping

From: "Carter Bullard" <[email-masked]>
Date: Fri, 31 Jan 2003 13:41:57 -0500

Hey Jeff,
   Just for completeness, the US wiretapping laws cover
three types of wiretaps, Pen Register, Trap and Trace
and Content surveillance.  Flow data can easily support
all three types, but the simple flow model described
in IPFIX should be able to support Pen Register, which
generally provides calling and called party identifiers.
It could also provide some of the Trap and Trace data,
which looks alot like general PSTN billing data, but is
provided in real time.

   There are standards for the format and transport of
the data which collectively are referred to as the J-STD.
IPFIX could conceivably meet J-STD transport requirements.

Carter

> -----Original Message-----
> From: majordomo listserver 
> [mailto:[email-masked]] On Behalf Of 
> MEYER,JEFFREY D (HP-Cupertino,ex1)
> Sent: Friday, January 31, 2003 1:00 PM
> To: [email-masked]'; [email-masked]; 
> [email-masked]
> Cc: [email-masked]; [email-masked]; 
> [email-masked]
> Subject: RE: [ipfix-eval] Question regarding Wiretapping
> 
> 
> Hi,
> 
>   I view the current information model defined by IPFIX 
> as being the equivalent of "call logs".  I.e. it shows when
> and who I spoke to, but doesn't divulge any information
> about the content of the conversation.
> 
>   So, in the sense the the phone company records all this
> info and needs/uses it for billing, I view as being an
> analogous case in the IP world, using IPFix or other 
> usage recording methodologies.
> 
>   Wiretapping, actually monitoring the contents of the
> conversation is not something which IPFIX has in its 
> information model (as far I am aware).
> 
>   So my take is that the IPFIX information is equivalent
> to information which is always recorded in the PSTN
> world.  Now from a privacy perspective, who you divulge
> call logs to has broad legal repurcussions, but that is
> a separate topic.
> 
> Regards,
> 
>   Jeff Meyer
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Friday, January 31, 2003 7:42 AM
> > To: [email-masked]; [email-masked]
> > Cc: [email-masked]; [email-masked];
> > [email-masked]
> > Subject: [ipfix-eval] Question regarding Wiretapping
> > 
> > 
> > Greetings,
> > 
> > I have a  general question, Hope to get an answer you people. 
> > 
> > For network management purposes, the network element may 
> > duplicate the user traffic (packet ) and forwards towards the 
> > management application. This may be considered as wiretapping 
> > and not legal in some countries. 
> > 
> > RFC 2804 describes what is wiretapping etc. Does that mean 
> > that user needs to be informed about fields are going 
> > to collected etc.... is there any technical solution for it.
> > 
> > Regards
> > Ramg
> > 
> > --
> > Help        mailto:[email-masked] and say "help" 
> > in message body
> > Unsubscribe mailto:[email-masked] and say
> > "unsubscribe ipfix" in message body
> > Archive     http://ipfix.doit.wisc.edu/archive/
> > 
> 
> --
> Help        mailto:[email-masked] and say "help" 
> in message body
> Unsubscribe mailto:[email-masked] and say
> "unsubscribe ipfix" in message body
> Archive     http://ipfix.doit.wisc.edu/archive/
> 

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: "Tal Givoly" <[email-masked]>
Date: Fri, 31 Jan 2003 12:59:11 -0800

Hi,

Getting back to the requirements, which of the 5 classes of applications
discussed in section 3 of the requirements (Usage-based accounting, Traffic
Profiling, Traffic Engineering, Attack/intrusion detection, QoS monitoring),
would wiretapping or lawful interception in any form be classified as?

Is it the intent that IPFIX protocol support these applications?

Tal

-----Original Message-----
From: majordomo listserver [mailto:[email-masked]]On Behalf
Of Carter Bullard
Sent: Friday, January 31, 2003 10:42 AM
To: 'MEYER,JEFFREY D (HP-Cupertino,ex1)'; [email-masked];
[email-masked]; [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]
Subject: RE: [ipfix-eval] Question regarding Wiretapping

Hey Jeff,

Carter

--
Help        mailto:[email-masked] and say "help" in message
body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/