Subject: RE: [ipfix] Editors for IPFIX drafts

From: "MEYER,JEFFREY D (HP-Cupertino,ex1)" <[email-masked]>
Date: Mon, 28 Apr 2003 09:20:41 -0700

Juergen,

  Thanks for the response.

  I agree XML in and of itself is marginally human readable.

  I think that basic tools such as Xalan (http://xml.apache.org/), can
be used to "transform" a base XML document into a variety of formats,
including formatting consistent with RFC's.  Note that all the IPDR
RFC's were written in XML using Marshall Rose's xml2rfc tools
(http://xml.resource.org/).

  So the model I would picture is having the Normative XML data model
as an appendix, and having generated information from this data model
populate some of the body sections to aid human readers.

Regards,

  Jeff Meyer

> -----Original Message-----
> From: Juergen Quittek [mailto:[email-masked]]
> Sent: Monday, April 28, 2003 8:24 AM
> To: MEYER,JEFFREY D (HP-Cupertino,ex1); 'Nevil Brownlee';
> [email-masked]
> Subject: RE: [ipfix] Editors for IPFIX drafts
> 
> 
> Jeff,
> 
> I do see a value in such a formal description. But there is a 
> trafe-off.
> 
> I also see a degradation of human readability. You loose means of
> structuring your document text when using XML, for example grouping
> attributes that are related. (Of course you could do so in 
> XML, but it is
> much harder to find the heading "Port-related Attributes" in 
> an XML document,
> because headings cannot be well highlighted and numbering of 
> headings is
> not well supported.
> 
> Anyway, I like the idea of an XML encoding of the model, but 
> I we should
> not go this way if we cannot find a good way of getting it 
> hunam readable
> (maybe by applying formatting rules).
> 
> An option would also be adding the XML code to the document 
> as an appendix.
> 
>     Juergen
> 
> 
> -- MEYER,JEFFREY D (HP-Cupertino,ex1) wrote on 28 April 2003 
> 10:57 -0400:
> 
> > Hi,
> >
> >    My particular interest on working on the information model would
> > be on developing a more formal and standard way of describing the
> > information elements which are used in IPFIX communication.
> >
> >    The modelling of information elements should ideally be done
> > using a formal description language, so that tools can be 
> constructed
> > which do not require humans to transcribe this information.
> >
> >    I would propose the use of XML-Schema to provide this formal
> > description.  Through the use of XSL processors, prose 
> based descriptions
> > and tables can be produced if these are considered desireable.
> >
> >    NOTE: describing the information model formally does NOT mean
> > that encoding and transport for IPFIX need to change in any way.  It
> > simply means that rather than having as the base 
> description of information
> > items some prose in a document, you instead have a machine readable
> > representation.
> >
> >
> >   As an example of a formal (but currently incomplete) information
> > model for IPFIX, see:
> > http://www.ipdr.org/documents/ipfix/ipfixService-20020902.xml
> >
> >   I would recommend making such a representation the normative form
> > of the IPFIX information model, much like SNMP MIBs.
> >
> >
> >   Please let me know if people see value in this exercise.
> >
> > Regards,
> >
> >   Jeff Meyer
> >
> >> -----Original Message-----
> >> From: Nevil Brownlee [mailto:[email-masked]]
> >> Sent: Sunday, April 27, 2003 8:44 PM
> >> To: [email-masked]
> >> Subject: [ipfix] Editors for IPFIX drafts
> >>
> >>
> >>
> >> Hello all:
> >>
> >> Following the IPFIX meeting at the San Francisco IETF we asked for
> >> volunteers to edit the IPFIX drafts.  The current list is:
> >>
> >>  Applicability:  Tanja Zseby, Reinaldo Penno
> >>
> >>  Architecture:  Ganesh Sadasivan, Nevil Brownlee
> >>
> >>  Information Model: Paul Calato, Jeff Meyer, Juergen Quittek
> >>
> >>  Protocol:  Mark Fulmer, Paul Calato, Reinaldo Penno
> >>
> >> At this stage we already have old (expired) versions of the
> >> Architecture (-02.txt) and Data Model (-01.txt) drafts on the IPFIX
> >> web page; would the editors of all four drafts please email
> >> me an initial
> >> version of their new drafts to published as placeholders
> >> within the next
> >> few weeks.
> >>
> >> After that, the editors will work on developing better 
> versions of the
> >> drafts which can be discussed on the IPFIX list and submitted
> >> by mid-June,
> >> i.e. in plenty of time for the Vienna IETF meeting in July.
> >>
> >> Cheers, Nevil
> >>
> >> PS: Good to see some real discussion on the list.  Lets 
> concentrate on
> >>     producing text the draft editors can use!
> >>
> >> --------------------------------------------------------------
> >> ---------
> >>    Nevil Brownlee                   Director, Technology 
> Development
> >>    Phone: +64 9 373 7599 x88941     ITSS, The University 
> of Auckland
> >>    FAX: +64 9 373 7021      Private Bag 92019, Auckland, 
> New Zealand
> >>
> >>
> >> -------------------------------------------------
> >> This mail sent through University of Auckland
> >> http://www.auckland.ac.nz/
> >>
> >> --
> >> Help        mailto:[email-masked] and say "help"
> >> in message body
> >> Unsubscribe mailto:[email-masked] and say
> >> "unsubscribe ipfix" in message body
> >> Archive     http://ipfix.doit.wisc.edu/archive/
> >>
> >
> > --
> > Help        mailto:[email-masked] and say 
> "help" in message body
> > Unsubscribe mailto:[email-masked] and say
> > "unsubscribe ipfix" in message body
> > Archive     http://ipfix.doit.wisc.edu/archive/
> 
> 

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Juergen Quittek <[email-masked]>
Date: Mon, 28 Apr 2003 22:53:19 +0200

Jeff,

> (http://xml.resource.org/).

I also like Marshall's tools.
If Paul agrees, we should use them for the data model document.

> populate some of the body sections to aid human readers.

This looks like a reasonable way to go.

    Juergen