Subject: RE: [ipfix] Exporting Control Information

From: "Reinaldo Penno" <[email-masked]>
Date: Tue, 17 Jun 2003 12:57:03 -0700

How about we simplify even more? IMO we could do away with the "reaches". We
just say that it has to be reliable and one of the methods is using a
reliable transport. If someone has a different method but it is also
reliable then it is okay.

   For the reasons 1. and 2., the export of the control information
   SHOULD be done reliably.
   One way to achieve this would be  to send the control
   information over a reliable transport.

> -----Original Message-----
> From: Ganesh Sadasivan [mailto:[email-masked]] 
> Sent: Tuesday, June 17, 2003 3:45 PM
> To: Penno, Reinaldo [BL60:SB20:EXCH]
> Cc: [email-masked]
> Subject: Re: [ipfix] Exporting Control Information
> 
> 
> Hi Reinaldo,
> 
>    I agree that the statements are fuzzy. How about this one?
> 
>   For the reasons 1. and 2., the export of the control information
>   SHOULD be done such that the it reaches the collector reliably.
>   One way to achieve this would be  to send the control
>   information over a reliable transport.
> 
> Thanks
> Ganesh
> 
> Reinaldo Penno wrote:
> 
> > Hello Ganesh,
> >
> > I guess everything looks okay except number 3...Some comments
> >
> > You say that is it preferred that the export de done over a 
> reliable 
> > connection. Do you mean IPfix connection? If it the 
> "preferred" method 
> > I guess a SHOULD would be more appropriated.
> >
> > Using terms like "partially reliable" could be opening a can of 
> > worms...What is a partially reliable transport? And what 
> you mean that 
> > the network is reliable?
> >
> > Anyway, my overall suggestion is to rewrite number 3 to 
> make it less 
> > ambiguous and open to interpretation.
> >
> > regards,
> >
> > Reinaldo
> >
> > >      3. For the reasons 1. and 2. it is preferred that 
> the export of
> > >         Control Information be done over a reliable 
> connection. This 
> > > MAY
> > >
> > >         be done through a reliable transport or a 
> partially reliable
> > >         transport when the underlying network is reliable.
> >
> > ----- Original Message -----
> > From: "Ganesh Sadasivan" <[email-masked]>
> > To: <[email-masked]>
> > Sent: Monday, June 16, 2003 3:35 PM
> > Subject: [ipfix] Exporting Control Information
> >
> > > Hi,
> > >
> > >    The following text describes the architecture for 
> exporting control
> > >    information. The protocol should have it own section 
> on this topic.
> > >    Please let me know your thoughts on the paragraphs below.
> > >
> > > Exporting Control Information
> > >
> > >    The Control Information is used by the collector to :
> > >    - decode and interpret flow records.
> > >    - understand the exporter state.
> > >
> > >    As such sending control information from exporter in a 
> timely and
> > >    reliable manner is critical to the proper 
> functionality of the IPFIX
> > >    collector. The following approaches MAY be taken for 
> the export of
> > >    control information.
> > >
> > >      1. Send all the control information pertaining to 
> flow records
> > >         prior to sending the flow records themselves. 
> This includes any
> > >         incremental changes that happens to the 
> definition of the flow
> > >         records.
> > >
> > >      2. Notify on a near real time basis the state of the 
> exporter to
> > >         the collector. This includes all the changes like a
> > >         configuration change that affects the flow 
> behavior, changes to
> > >         exporter resources that affects export rates, etc 
> that which 
> > > the
> > >
> > >         collector needs to be aware of.
> > >
> > >      3. For the reasons 1. and 2. it is preferred that 
> the export of
> > >         Control Information be done over a reliable 
> connection. This 
> > > MAY
> > >
> > >         be done through a reliable transport or a 
> partially reliable
> > >         transport when the underlying network is reliable.
> > >
> > > Thanks
> > > Ganesh
> > >
> > >
> > >
> > > --
> > > Help        mailto:[email-masked] and say 
> "help" in message
> > body
> > > Unsubscribe mailto:[email-masked] and say 
> "unsubscribe 
> > > ipfix" in message body
> > > Archive     http://ipfix.doit.wisc.edu/archive/
> >
> > --
> > Help        mailto:[email-masked] and say 
> "help" in message body
> > Unsubscribe mailto:[email-masked] and say "unsubscribe 
> > ipfix" in message body
> > Archive     http://ipfix.doit.wisc.edu/archive/
> 
>

---

From: Ganesh Sadasivan <[email-masked]>
Date: Tue, 17 Jun 2003 13:12:04 -0700

Reinaldo Penno wrote:

>
>
> How about we simplify even more? IMO we could do away with the
> "reaches". We just say that it has to be reliable and one of the
> methods is using a reliable transport. If someone has a different
> method but it is also reliable then it is okay.
>

I initially wrote this sentence before sending the e-mail. But this
sentence is
partial in the sense that it does not talk about the receiver getting
information
reliably. So is it not prone to mis-interpretation?

-ganesh

---

From: Peter Ludemann <[email-masked]>
Date: Tue, 17 Jun 2003 13:42:01 -0700 (PDT)

Insufficient: reliable transport does not guarantee reliable
delivery. There must be something like an application-level
"ack" to be fully reliable. (This is also necessary if you
want to guarantee that the control information arrives before
any data.)

- peter

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/