Subject: Re: [ipfix] Middle box functions

From: Ganesh Sadasivan <[email-masked]>
Date: Tue, 10 Jun 2003 17:02:38 -0700

Sorry for the brevity.
There is a line in the architecture spec. on the function of Observation Domain.

"Perform appropriate middle-box functions to translate the
flow information."

1. This is not a function of the Observation Domain as it is a logical block
rather
than a functional block.
2.It would be moslty a IPFIX protocol function in which case I would like to put

in some more words. So if someone can provide a few sentences stating what is
intended by "Middle box functions" I can put it into the arch. spec.

Thanks
Ganesh

Tal Givoly wrote:

> Ganesh,
>
> I personally didn't quite understand the question, perhaps you would like to
> elaborate or provide some more context for us to clarify/respond.
>
> Thanks,
>
> Tal
>
> -----Original Message-----
> From: majordomo listserver [mailto:[email-masked]]On Behalf
> Of Ganesh Sadasivan
> Sent: Tuesday, June 10, 2003 1:49 PM
> To: [email-masked]
> Subject: [ipfix] Middle box functions
>
> Can someone restate what  "middle-box functions" need to be done
> by an IPFIX device?
>
> Thanks
> Ganesh
>
> --
> Help        mailto:[email-masked] and say "help" in message
> body
> Unsubscribe mailto:[email-masked] and say
> "unsubscribe ipfix" in message body
> Archive     http://ipfix.doit.wisc.edu/archive/

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: "Reinaldo Penno" <[email-masked]>
Date: Wed, 11 Jun 2003 15:22:00 -0400

I guess the text is a little bit misleading...

The discussion at the time was that *if* the exporter is *also* performing
middlebox functions such as NAT, firewall, etc, it should let the collector
know that it is modifying the flows and what modifications it is doing
(dropping, translating addresses, etc).

reghards,

Reinaldo
----- Original Message -----
From: "Ganesh Sadasivan" <[email-masked]>
To: "Tal Givoly" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, June 10, 2003 8:02 PM
Subject: Re: [ipfix] Middle box functions

body

---

From: Ganesh Sadasivan <[email-masked]>
Date: Wed, 11 Jun 2003 14:31:59 -0700

> (dropping, translating addresses, etc).

So what was the decision on this topic?

Thanks
Ganesh

---

From: "Reinaldo Penno" <[email-masked]>
Date: Wed, 11 Jun 2003 17:38:10 -0400

In the "original" data model there were fields to represent translated
addresses, ports, etc, etc

Not sure how it is today. Maybe we should ask the list and see if people
think sending modified flow information (dropped, translated, shaped, etc)
is useful and what degree of compliance is needed (MUST, SHOULD or MAY).

IMO I would like to know such information.

regards,

Reinaldo

----- Original Message -----
From: "Ganesh Sadasivan" <[email-masked]>
To: "Penno, Reinaldo [BL60:SB20:EXCH]" <[email-masked]>
Cc: "Tal Givoly" <[email-masked]>; <[email-masked]>
Sent: Wednesday, June 11, 2003 5:31 PM
Subject: Re: [ipfix] Middle box functions

> > > There is a line in the architecture spec. on the function of
Observation
> > Domain.
> > > 2.It would be moslty a IPFIX protocol function in which case I would
like
> > to put
> > >
> > > in some more words. So if someone can provide a few sentences stating
what
> > is