Subject: [ipfix] Encoding the fields in flow records/templates

From: Ganesh Sadasivan <[email-masked]>
Date: Fri, 01 Aug 2003 14:54:40 -0700

Should IPFIX mention anything about the order in which fields
in flow records/templates are encoded, i.e.
network order/host order? Any suggestions?

Thanks
Ganesh

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Simon Leinen <[email-masked]>
Date: Fri, 08 Aug 2003 08:54:18 +0200

Ganesh Sadasivan writes:
> Should IPFIX mention anything about the order in which fields in
> flow records/templates are encoded, i.e.  network order/host order?

Of course this must be mentioned in the protocol definition.
Otherwise there will be an interoperability issue.

> Any suggestions?

I suggest using network byte order (big-endian), in the interest of
protocol and implementation simplicity, as well as consistency with
earlier versions of NetFlow and with other IETF protocols.
-- 
Simon.