Subject: RE: [ipfix] Encoding the fields in flow records/templates

From: "MEYER,JEFFREY D (HP-Cupertino,ex1)" <[email-masked]>
Date: Fri, 1 Aug 2003 18:02:59 -0400

Hi,

  I'd strongly recommend network byte order like most other IETF
protocols use (and current NFvX uses).

  I would expect this to be in the protocol draft and used in 
reference to encoding of types defined in the information model.

Regards,

  Jeff Meyer

> -----Original Message-----
> From: Ganesh Sadasivan [mailto:[email-masked]]
> Sent: Friday, August 01, 2003 2:55 PM
> To: [email-masked]
> Subject: [ipfix] Encoding the fields in flow records/templates
> 
> 
> 
> Should IPFIX mention anything about the order in which fields
> in flow records/templates are encoded, i.e.
> network order/host order? Any suggestions?
> 
> Thanks
> Ganesh
> 
> 
> --
> Help        mailto:[email-masked] and say "help" 
> in message body
> Unsubscribe mailto:[email-masked] and say
> "unsubscribe ipfix" in message body
> Archive     http://ipfix.doit.wisc.edu/archive/
> 

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Nevil Brownlee <[email-masked]>
Date: Wed, 13 Aug 2003 07:24:54 +1200

> reference to encoding of types defined in the information model.

This seems obvious, but it does need to be said explicitly.

Cheers, Nevil

> > network order/host order? Any suggestions?

-----------------------------------------------------------------------
   Nevil Brownlee                   Director, Technology Development
   Phone: +64 9 373 7599 x88941     ITSS, The University of Auckland
   FAX: +64 9 373 7021      Private Bag 92019, Auckland, New Zealand

-------------------------------------------------
This mail sent through University of Auckland
http://www.auckland.ac.nz/

---

From: Benoit Claise <[email-masked]>
Date: Wed, 13 Aug 2003 13:50:44 +0200

>This seems obvious, but it does need to be said explicitly.
It will be added in the protocol draft.

Regards, Benoit.