Subject: RE: [ipfix] STCP as a default transport not

From: "Carter Bullard" <[email-masked]>
Date: Thu, 2 Oct 2003 15:59:45 -0400

Hey Alex,
   Did I say something wrong?  I firmly believe that people adopt
technology when it solves problems.  STCP will get around as
its found to be a real solution.  But with regard to STCP and
IPFIX, I read RFC 3257, the SCTP Applicability Statement, and
I don't see where IPFIX fits.  Benefits of SCTP over TCP are:

   multi-streams support
   multi-homing support
   preservation of message boundaries
   unordered reliable message delivery

The first three I don't see as requirements for IPFIX.
I actually believe the last one to be a problem for IPFIX.
STCP is less efficient that TCP, and so if IPFIX doesn't need
any of these 4 items, then I don't see the applicability.

Carter

> -----Original Message-----
> From: Alex Audu [mailto:[email-masked]]
> Sent: Thursday, October 02, 2003 2:51 PM
> To: [email-masked]
> Cc: [email-masked]; 'Reinaldo Penno';
> [email-masked]; [email-masked]
> Subject: Re: [ipfix] STCP as a default transport not
>
>
> Hello Carter,
>
> If it is true that SCTP hasn't been widely deployed, it is
> probably because
> of statements like you have made below. Look, we all know SCTP has
> a lot of benefits over TCP.  If folks like you don't drive
> its deployement
> by specifying it as default transport, how will it be
> ubiquitous? It is a
> self fulfilling prophesy.
>
> For IETF protocols that recommend SCTP as defaults, see rfc
> 3057, rfc 3331
> and rfc 3332 just to name a few.
>
> Regards,
> Alex.
>
> Carter Bullard wrote:
>
> > I believe that SCTP-PR is not deployed widely enough
> > to be considered a default for any IETF technology.
> > It is not on my Linux RedHat 9.0 distribution, nor
> > my Mac OS-X or my Windows XP system.  I don't see it
> > available on any Solaris machine that I have access
> > to.
> >
> > What IETF technology is currently using SCTP as a
> > default transport?
> >
> > Carter
> >
> > > -----Original Message-----
> > > From: majordomo listserver
> > > [mailto:[email-masked]] On Behalf Of Stewart Bryant
> > > Sent: Thursday, October 02, 2003 12:14 PM
> > > To: Reinaldo Penno
> > > Cc: [email-masked]; [email-masked]
> > > Subject: Re: [ipfix] Ipfix Protocol open items
> > >
> > >
> > >
> > >
> > > Reinaldo Penno wrote:
> > >
> > > > Hello,
> > > >
> > > > Have we zeroed in a certain transport protocol? TCP, SCTP-PR or
> > > > something else?
> > > >
> > > > I need to write something to explain how Netflow runs over
> > > TCP, but it
> > > > seems to me somewhat of a lower priority if this is not
> > > going to be the
> > > > default protocol. We should focus on explaning how this
> > > should work on
> > > > the "choosen one".
> > >
> > > I think that perhaps the question should be put another
> way. There are
> > > WG members who propose SCTP-PR as the default, and SCTP-PR has
> > > advantage because of its better flexibility in coping
> with congestion.
> > >
> > > So the real question is whether there are WG members who
> think that
> > > the default should be TCP. If no group comes forward, then we have
> > > our answer. If there is support then we need to perform a detailed
> > > analysis of the relative merits of the two protocols.
> > >
> > > Stewart
> > >
> > >
> > > --
> > > Help        mailto:[email-masked] and say "help"
> > > in message body
> > > Unsubscribe mailto:[email-masked] and say
> > > "unsubscribe ipfix" in message body
> > > Archive     http://ipfix.doit.wisc.edu/archive/
> > >
> >
> > --
> > Help        mailto:[email-masked] and say
> "help" in message body
> > Unsubscribe mailto:[email-masked] and say
> > "unsubscribe ipfix" in message body
> > Archive     http://ipfix.doit.wisc.edu/archive/
>
>

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Alex Audu <[email-masked]>
Date: Thu, 02 Oct 2003 16:01:20 -0500

Hi Carter,

How is SCTP less efficient than TCP?  Shouldn't this be the other way round?

My experience has been that SCTP starts faster than TCP (meaning its
Slow Start mode is less severe than TCP's). That should translate into a
more efficient protocol.

It is true that IPFIX didn't mandate multi-streams, multi-homing and
message boundary preservation, but these are features that make
designing with SCTP somewhat of a joy. SCTPs streams simplifies
redundant designs. Just set up multi-streams from the Exporter to
different Collectors and you have a design that quickly protects your
Exporter-collector path.

Multi-homing also adds to the survivability of the Exporter-Collector
link. If you can't get to the Collector via one network address, you
just try the other.

Message boundary preservation becomes helpful in the processing
of the messages. Your application doesn't have to worry about
where a message starts or a new one begins. This makes for an
efficient over-all implementation.

You know you can chose between Ordered and Unordered reliable
message delivery modes. So, this shouldn't be an issue. It just gives
more flexibility.

SCTP is more secure than TCP. Though not critical in this case, it
needs to be mentioned all the same.

Regards,
Alex.