Subject: RE: [ipfix] Congestion management

From: "Carter Bullard" <[email-masked]>
Date: Mon, 13 Oct 2003 23:59:19 -0400

Well, when you have the other Transport WG AD co-authoring
a draft that uses RTP/UDP to transport SMPTE video
at 1.485 Gbps with the intent that it be used over
"the Big-I", and the IESG approves it in 2003 (RFC 3497),
it is very difficult for me to accept the notion that
the IESG has a mandatory requirement that new IP
applications must use congestion friendly transport.
Unless of course RTP/UDP is considered by the IESG to
be congestion friendly.  (I didn't think RTP was friendly,
just aware, so I possibly erred when I suggested the
IESG was only concerned about awareness).

If an IESG mandatory requirement for congestion friendly
transport actually existed and RTP/UDP wasn't a congestion
friendly transport, the Transport WG AD that co-authored
the draft surely would have known there was a problem, but
of course if she missed the meeting, the other Transport
WG AD would have reminded her, the chair of the WG and
possibly the authors of the draft of the problem.  Of
course if somehow these mechanisms failed, the draft
surely would not have been approved and promoted to Standards
Track RFC by the IESG itself.  Seems like a pretty big
booo-booo for so many checks and balances to have failed on
an IP application that runs at

   1.485 GIGABITS per second

minimum.  Obviously, RTP/UDP is congestion friendly, but
given the possibility that it is not, then I'm sure that
the IESG has begun the process to retract the RFC, now
that this potential violation of the IESG mandatory
congestion friendly transport requirement has been
identified.

I don't know, maybe there isn't really a requirement.

Carter

> -----Original Message-----
> From: majordomo listserver
> [mailto:[email-masked]] On Behalf Of Peter Lei
> Sent: Monday, October 13, 2003 5:45 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [ipfix] Congestion management
>
>
> > Hey Peter,
> >    The default transport has to have some congestion awareness,
> > and given the IESG recent track record, that doesn't mean
> > integrated congestion control, just awareness.  There is no
> > requirement that any other transport bindings must support
> > congestion awareness.
>
> Umm.... are you sure about that?!  Randy's (Bush) previous
> email stated "congestion-friendly transport is mandatory to
> implement and the default."  In order to be "friendly" the
> transport has to do something to mitigate congestion, not
> just be "aware" that it's happening...
>
> >    You still work for Cisco, right?  So, maybe you can
> > tell us when you guys will be able to demonstrate Netflow over
> > PR-SCTP in an existing router.  That really should be the
> > litmus test for getting a binding in the IPFIX protocol.
> > Hopefully without having to put in a specific blade to
> > enable it.
>  >
> > Carter
> >
> >
> >
> >
> > --
> > Help        mailto:[email-masked] and say
> "help" in message body
> > Unsubscribe mailto:[email-masked] and say
> > "unsubscribe ipfix" in message body
> > Archive     http://ipfix.doit.wisc.edu/archive/
> >
>
>
>
> --
> Help        mailto:[email-masked] and say "help"
> in message body
> Unsubscribe mailto:[email-masked] and say
> "unsubscribe ipfix" in message body
> Archive     http://ipfix.doit.wisc.edu/archive/
>

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Sebastian Zander <[email-masked]>
Date: Tue, 14 Oct 2003 18:45:36 +0200

Carter,

fact is that some media formats are inelastic and are therefore
basically unusable with congestion control. IMO IPFIX is still
very useful / can be used with congestion control. I agree with
you that in some cases UDP may be nice etc. etc. etc.

However you have raised an interesting point. Reading RFC 3550
and remembering the IPFIX transport protocol discussion last year
all I can say right now is :-)

Quoting section 10, p. 67, RFC 3550 (RTP):
"Therefore, congestion control SHOULD be defined in each RTP profile as
appropriate.  For some profiles, it may be sufficient to include an
applicability statement restricting the use of that profile to environments
where congestion is avoided by engineering. For other profiles, specific
methods such as data rate adaptation based on RTCP feedback may be required."

Cheers,

Sebastian

-- 
Sebastian Zander                         E-mail: [email-masked]
Fraunhofer FOKUS / METEOR                Tel: +49-30-3463-7287
Kaiserin-Augusta-Allee 31                Fax: +49-30-3463-8287
D-10589 Berlin, Germany                  www.fokus.fraunhofer.de/usr/sebastian.zander