Subject: [ipfix] STCP as a default transport not

From: "Carter Bullard" <[email-masked]>
Date: Thu, 2 Oct 2003 13:27:54 -0400

I believe that SCTP-PR is not deployed widely enough
to be considered a default for any IETF technology.
It is not on my Linux RedHat 9.0 distribution, nor
my Mac OS-X or my Windows XP system.  I don't see it
available on any Solaris machine that I have access
to.

What IETF technology is currently using SCTP as a
default transport?

Carter

> -----Original Message-----
> From: majordomo listserver
> [mailto:[email-masked]] On Behalf Of Stewart Bryant
> Sent: Thursday, October 02, 2003 12:14 PM
> To: Reinaldo Penno
> Cc: [email-masked]; [email-masked]
> Subject: Re: [ipfix] Ipfix Protocol open items
>
>
>
>
> Reinaldo Penno wrote:
>
> > Hello,
> >
> > Have we zeroed in a certain transport protocol? TCP, SCTP-PR or
> > something else?
> >
> > I need to write something to explain how Netflow runs over
> TCP, but it
> > seems to me somewhat of a lower priority if this is not
> going to be the
> > default protocol. We should focus on explaning how this
> should work on
> > the "choosen one".
>
> I think that perhaps the question should be put another way. There are
> WG members who propose SCTP-PR as the default, and SCTP-PR has
> advantage because of its better flexibility in coping with congestion.
>
> So the real question is whether there are WG members who think that
> the default should be TCP. If no group comes forward, then we have
> our answer. If there is support then we need to perform a detailed
> analysis of the relative merits of the two protocols.
>
> Stewart
>
>
> --
> Help        mailto:[email-masked] and say "help"
> in message body
> Unsubscribe mailto:[email-masked] and say
> "unsubscribe ipfix" in message body
> Archive     http://ipfix.doit.wisc.edu/archive/
>

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Alex Audu <[email-masked]>
Date: Thu, 02 Oct 2003 14:51:04 -0500

Hello Carter,

If it is true that SCTP hasn't been widely deployed, it is probably because
of statements like you have made below. Look, we all know SCTP has
a lot of benefits over TCP.  If folks like you don't drive its deployement
by specifying it as default transport, how will it be ubiquitous? It is a
self fulfilling prophesy.

For IETF protocols that recommend SCTP as defaults, see rfc 3057, rfc 3331
and rfc 3332 just to name a few.

Regards,
Alex.