Subject: RE: [ipfix] STCP as a default transport not

From: "Reinaldo Penno" <[email-masked]>
Date: Mon, 6 Oct 2003 09:34:24 -0700

Okay...

It seems we haven't reached a (firm) conclusion, but we need to get the
draft going and this is a big piece of it. Jeff seems to propose specifying
both (TCP and SCTP). Anyone opposes this? Or should we stick with one
protocol mapping?

We need to start converging on this really soon. 

Thanks,

Reinaldo 

> -----Original Message-----
> From: MEYER,JEFFREY D (HP-Cupertino,ex1) [mailto:[email-masked]] 
> Sent: Thursday, October 02, 2003 5:05 PM
> To: [email-masked]'; [email-masked]'
> Cc: [email-masked]'; Penno, Reinaldo [BL60:SF30:EXCH]; 
> [email-masked]'; [email-masked]'
> Subject: RE: [ipfix] STCP as a default transport not
> 
> 
> I'd be interested in knowing what the specific aspects of 
> SCTP are that the IPFIX protocol authors want to use, and how 
> they do or do not conflict in some way with a parallel mapping to TCP.
> 
> Taking the Diameter approach of specifying both TCP and SCTP 
> would allow for the market to decide if ubiquity of 
> availability or the special capabilities of SCTP are more important.
> 
> -- Jeff
> 
> > -----Original Message-----
> > From: Carter Bullard [mailto:[email-masked]]
> > Sent: Thursday, October 02, 2003 1:00 PM
> > To: [email-masked]
> > Cc: [email-masked]; 'Reinaldo Penno'; 
> > [email-masked]; [email-masked]
> > Subject: RE: [ipfix] STCP as a default transport not
> > 
> > 
> > Hey Alex,
> >    Did I say something wrong?  I firmly believe that people adopt 
> > technology when it solves problems.  STCP will get around 
> as its found 
> > to be a real solution.  But with regard to STCP and IPFIX, 
> I read RFC 
> > 3257, the SCTP Applicability Statement, and I don't see where IPFIX 
> > fits.  Benefits of SCTP over TCP are:
> > 
> >    multi-streams support
> >    multi-homing support
> >    preservation of message boundaries
> >    unordered reliable message delivery
> > 
> > The first three I don't see as requirements for IPFIX.
> > I actually believe the last one to be a problem for IPFIX. STCP is 
> > less efficient that TCP, and so if IPFIX doesn't need any 
> of these 4 
> > items, then I don't see the applicability.
> > 
> > Carter
> > 
> > 
> > > -----Original Message-----
> > > From: Alex Audu [mailto:[email-masked]]
> > > Sent: Thursday, October 02, 2003 2:51 PM
> > > To: [email-masked]
> > > Cc: [email-masked]; 'Reinaldo Penno'; 
> > > [email-masked]; [email-masked]
> > > Subject: Re: [ipfix] STCP as a default transport not
> > >
> > >
> > > Hello Carter,
> > >
> > > If it is true that SCTP hasn't been widely deployed, it 
> is probably 
> > > because of statements like you have made below. Look, we all know 
> > > SCTP has a lot of benefits over TCP.  If folks like you 
> don't drive
> > > its deployement
> > > by specifying it as default transport, how will it be
> > > ubiquitous? It is a
> > > self fulfilling prophesy.
> > >
> > > For IETF protocols that recommend SCTP as defaults, see rfc 3057, 
> > > rfc 3331 and rfc 3332 just to name a few.
> > >
> > > Regards,
> > > Alex.
> > >
> > > Carter Bullard wrote:
> > >
> > > > I believe that SCTP-PR is not deployed widely enough
> > > > to be considered a default for any IETF technology.
> > > > It is not on my Linux RedHat 9.0 distribution, nor
> > > > my Mac OS-X or my Windows XP system.  I don't see it 
> available on 
> > > > any Solaris machine that I have access to.
> > > >
> > > > What IETF technology is currently using SCTP as a
> > > > default transport?
> > > >
> > > > Carter
> > > >
> > > > > -----Original Message-----
> > > > > From: majordomo listserver 
> [mailto:[email-masked]] 
> > > > > On Behalf Of Stewart Bryant
> > > > > Sent: Thursday, October 02, 2003 12:14 PM
> > > > > To: Reinaldo Penno
> > > > > Cc: [email-masked]; [email-masked]
> > > > > Subject: Re: [ipfix] Ipfix Protocol open items
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > Reinaldo Penno wrote:
> > > > >
> > > > > > Hello,
> > > > > >
> > > > > > Have we zeroed in a certain transport protocol? TCP,
> > SCTP-PR or
> > > > > > something else?
> > > > > >
> > > > > > I need to write something to explain how Netflow runs over
> > > > > TCP, but it
> > > > > > seems to me somewhat of a lower priority if this is not
> > > > > going to be the
> > > > > > default protocol. We should focus on explaning how this
> > > > > should work on
> > > > > > the "choosen one".
> > > > >
> > > > > I think that perhaps the question should be put another
> > > way. There are
> > > > > WG members who propose SCTP-PR as the default, and 
> SCTP-PR has 
> > > > > advantage because of its better flexibility in coping
> > > with congestion.
> > > > >
> > > > > So the real question is whether there are WG members who
> > > think that
> > > > > the default should be TCP. If no group comes forward,
> > then we have
> > > > > our answer. If there is support then we need to perform
> > a detailed
> > > > > analysis of the relative merits of the two protocols.
> > > > >
> > > > > Stewart
> > > > >
> > > > >
> > > > > --
> > > > > Help        mailto:[email-masked] and say "help"
> > > > > in message body
> > > > > Unsubscribe mailto:[email-masked] and say 
> > > > > "unsubscribe ipfix" in message body
> > > > > Archive     http://ipfix.doit.wisc.edu/archive/
> > > > >
> > > >
> > > > --
> > > > Help        mailto:[email-masked] and say
> > > "help" in message body
> > > > Unsubscribe mailto:[email-masked] and say 
> > > > "unsubscribe ipfix" in message body
> > > > Archive     http://ipfix.doit.wisc.edu/archive/
> > >
> > >
> > 
> > 
> > 
> > 
> > --
> > Help        mailto:[email-masked] and say "help" 
> > in message body
> > Unsubscribe mailto:[email-masked] and say "unsubscribe 
> > ipfix" in message body
> > Archive     http://ipfix.doit.wisc.edu/archive/
> > 
>

---

From: "Tal Givoly" <[email-masked]>
Date: Mon, 6 Oct 2003 12:33:22 -0700

RE: [ipfix] STCP as a default transport notReinaldo,

It seems better to first specify TCP and when there are compelling reasons,
a future version may define mapping to SCTP. Several issues, in particular,
reliability, become a bit hairy when you start deciding what do you want to
send over reliable vs. non-reliable SCTP and this would prolong the process.
With TCP, less options exist to get hung up over.

Just my $0.02.

Tal
  -----Original Message-----
  From: majordomo listserver [mailto:[email-masked]]On Behalf
Of Reinaldo Penno
  Sent: Monday, October 06, 2003 9:34 AM
  To: 'MEYER,JEFFREY D (HP-Cupertino,ex1)'; [email-masked]';
[email-masked]'
  Cc: [email-masked]'; [email-masked]';
[email-masked]'
  Subject: RE: [ipfix] STCP as a default transport not

  Okay...

  Thanks,

  Reinaldo