Subject: RE: [ipfix] [issue] INFO-22 Flow Label is 3 bytes long? x - addre ss through d oc...

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Fri, 21 Nov 2003 23:29:12 +0100

This is what we defined in RFC3595:
 
  IPv6FlowLabel      ::= TEXTUAL-CONVENTION
      DISPLAY-HINT  "d"
      STATUS         current
      DESCRIPTION   "The flow identifier or Flow Label in an IPv6
                     packet header that may be used to discriminate
                     traffic flows.
                    "
      REFERENCE     "Internet Protocol, Version 6 (IPv6) specification,
                     section 6.  RFC 2460.
                    "
      SYNTAX         Integer32 (0..1048575)
 
  IPv6FlowLabelOrAny ::= TEXTUAL-CONVENTION
      DISPLAY-HINT  "d"
      STATUS         current
      DESCRIPTION   "The flow identifier or Flow Label in an IPv6
                     packet header that may be used to discriminate
                     traffic flows.  The value of -1 is used to
                     indicate a wildcard, i.e. any value.
                    "
      SYNTAX         Integer32 (-1 | 0..1048575)
 
So it is an integer but is indeed limited 20 bits

Thanks,
Bert 

-----Original Message-----
From: MEYER,JEFFREY D (HP-Cupertino,ex1) [mailto:[email-masked]]
Sent: vrijdag 21 november 2003 22:16
To: 'Ipfix Wg' (E-mail)
Subject: [ipfix] [issue] INFO-22 Flow Label is 3 bytes long? x - address through d oc...

Issue: INFO-22 Flow Label is 3 bytes long? x - address through doc...
Description
  the flow label field only has 20 bytes allocated to it.  Hence it doesn't
  need a full int.  Is this an issue, or simply indicate this fact in
  info model.
  http://ipfix.doit.wisc.edu/archive/1919.html <http://ipfix.doit.wisc.edu/archive/1919.html>

---

From: "MEYER,JEFFREY D (HP-Cupertino,ex1)" <[email-masked]>
Date: Fri, 21 Nov 2003 14:38:46 -0800

Bert,
 
  Looks like the SMIv2 model of "Textual Conventions" formally expresses the
ranges and distinguishes between an IPv6FlowLabel which is well formed and
an IPv6FlowLabel which can include -1 to indicate a wildcard.
 
  Do people want to have both in IPFIX info, it simply involves assigning
another field id?  Alternatively the IPv6FlowLabelOrAny model could be used?
 
  Is simply stating the range of this integer type as being restricted to
(-1 | 0..1048575) sufficient?  Or do people want a length 3 encoding?
 
Regards,
 
  Jeff Meyer

-----Original Message-----
From: Wijnen, Bert (Bert) [mailto:[email-masked]]
Sent: Friday, November 21, 2003 2:29 PM
To: MEYER,JEFFREY D (HP-Cupertino,ex1); 'Ipfix Wg' (E-mail)
Subject: RE: [ipfix] [issue] INFO-22 Flow Label is 3 bytes long? x - addre
ss through d oc...

 

Thanks,
Bert 

-----Original Message-----
From: MEYER,JEFFREY D (HP-Cupertino,ex1) [mailto:[email-masked]]
Sent: vrijdag 21 november 2003 22:16
To: 'Ipfix Wg' (E-mail)
Subject: [ipfix] [issue] INFO-22 Flow Label is 3 bytes long? x - address
through d oc...

Issue: INFO-22 Flow Label is 3 bytes long? x - address through doc...
Description
  the flow label field only has 20 bytes allocated to it.  Hence it doesn't
  need a full int.  Is this an issue, or simply indicate this fact in
  info model.
  http://ipfix.doit.wisc.edu/archive/1919.html
<http://ipfix.doit.wisc.edu/archive/1919.html>

---

From: "MEYER,JEFFREY D (HP-Cupertino,ex1)" <[email-masked]>
Date: Mon, 24 Nov 2003 14:30:31 -0500

Stewart,

  In the -02 draft, the text states:

http://www.ipdr.org/documents/ipfix/infomodel/draft-ietf-ipfix-info-02.html#
anchor44

6.13 flowLabel
Description: 

The Flow Label information element contains the IPV6 Flow Label information
as defined by RFC 2460. Note that a flow label only occupies 20 bits in the
IPv6 header. 

Type: unsignedInt. 

Field Id: 31 

Range: The valid range is 0..1048575.

  So, I think this is covered, from the model perspective.  I do think there
is a question on the protocol side whether (signed/unsigned) integers should
only be shortened as either 4, 2 or 1 byte quantities, excluding 3 bytes.

-- Jeff

-----Original Message-----
From: Stewart Bryant [mailto:[email-masked]]
Sent: Monday, November 24, 2003 2:39 AM
To: MEYER,JEFFREY D (HP-Cupertino,ex1)
Cc: 'Ipfix Wg' (E-mail)
Subject: Re: [ipfix] [issue] INFO-22 Flow Label is 3 bytes long? x -
address through d oc...

>   http://ipfix.doit.wisc.edu/archive/1919.html 

Clearly you have to specify the semantics as that of a 20 bit object, but
given the clumbsy way that most processors will have to go about extracting
just 3 bytes and writing them out, I would have thought that it was worth
"wasting" the byte and using a 4 byte field.

Stewart

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/