Subject: RE: [ipfix] [issue] INFO-23 Explicit IP version in message

From: "MEYER,JEFFREY D (HP-Cupertino,ex1)" <[email-masked]>
Date: Tue, 25 Nov 2003 09:53:29 -0800

Mark,

  The proposal was to ADD an information element, not take any away.

  What we have with the IPFIX info model today is a set of elements which
may
be selected from to form a flow information record.  Implementations at
this point are free to pick and chose which ones they transmit.

  Today, there is no formal restriction on what may be sent in
a flow record.  E.g. from my reading sending a flow record containing 
only:

   srcIPv4Address

  Is valid as would be sending a flow record with only:

   ipVersion

  Although I believe the much more likely use case will be sending flow
records which look in content like NFv5 records, with some fields augmented
or other uninteresting fields stripped.

  Defininig minimal content for some messages, like Diameter does may
be useful.  The leveraged IPDR Information model based on XML-Schema
allows for this to be done using the XML-Schema standard construct,
<complexType>.

  Alternatively, constraining what we say is a valid flow record, may
preclude
unanticipated valid use cases.

Regards,

  Jeff Meyer

-----Original Message-----
From: Mark Fullmer [mailto:[email-masked]]
Sent: Tuesday, November 25, 2003 9:12 AM
To: [email-masked]
Cc: MEYER,JEFFREY D (HP-Cupertino,ex1); 'Ipfix Wg' (E-mail)
Subject: Re: [ipfix] [issue] INFO-23 Explicit IP version in message

Aren't there cases where an IPv4 address gets translated
into an IPv6 address.  In this case you might have both
a v4 and v6 address in the same flow.

Why not have both an IPv4 and IPv6 IE?

mark

On Nov 25, 2003, at 5:28 AM, Stewart Bryant wrote:

> Works for me
>
> Stewart
>
> MEYER,JEFFREY D (HP-Cupertino,ex1) wrote:
>
>> Any proposed wording?  How about:
>> 6.XX ipVersion
>> Description: The IPVersion identifier for this flow as defined in STD 
>> 5, RFC 791.
>> Type: unsignedByte. Field Id: XX
>> Range: The valid range is 0..15.
>> -- Jeff
>> -----Original Message-----
>> From: Stewart Bryant [mailto:[email-masked]]
>> Sent: Monday, November 24, 2003 2:27 AM
>> To: MEYER,JEFFREY D (HP-Cupertino,ex1)
>> Cc: 'Ipfix Wg' (E-mail)
>> Subject: Re: [ipfix] [issue] INFO-23 Explicit IP version in message
>> MEYER,JEFFREY D (HP-Cupertino,ex1) wrote:
>>> Issue: INFO-23  Explicit IP version in message
>>> Descriptin:
>>>  Should IP version be explicit in the flow or implied by the type of
>>>  address element passed?  For now it will remain implicit.  Although
>>>  could introduce a byte or short information element called 
>>> ipVersion,
>>>  which would have either 4 or 6 as meaningful values.
>>> original e-mail:
>>>  http://ipfix.doit.wisc.edu/archive/1920.html
>> This is an issue of future proofing.
>> If the IETF ever introduced IPv7 that used IPv6 address we could
>> figure that out from the datagrams because they are all self
>> describing, but ipfix would report the wrong thing.
>> Therefore we should have an IP version IE.
>> Stewart
>
>
> --
> Help        mailto:[email-masked] and say "help" in 
> message body
> Unsubscribe mailto:[email-masked] and say
> "unsubscribe ipfix" in message body
> Archive     http://ipfix.doit.wisc.edu/archive/
>

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Mark Fullmer <[email-masked]>
Date: Tue, 25 Nov 2003 13:57:11 -0500

Forget it, you already have what I was asking for in the draft.

The last time I looked at the information model there was only
an IP address and the version was implied from the length.

mark