Subject: RE: [ipfix] Forming consensus on IPFIX default protocol

From: "Carter Bullard" <[email-masked]>
Date: Mon, 17 Nov 2003 11:31:36 -0500

Randall,
   You confuse so many points.  First, you cannot claim
that SCTP is a superior technology for IPFIX without
a demonstration.  Second, you cannot claim that SCTP
is even appropriate for IPFIX without applying the SCTP
applicability statement to IPFIX requirements.

   You seem to actually believe a company's claims, and
you make quite a bunch of them.  Cisco has been talking
about SCTP support in routers for at least a year now,
maybe two.  I still can't buy one.

   Does make we wonder about the credibility of those
making all these wild claims.

Carter

-----Original Message-----
From: majordomo listserver [mailto:[email-masked]] On Behalf Of
Randall Stewart (cisco)
Sent: Monday, November 17, 2003 7:45 AM
To: Bound, Jim
Cc: Meyer, Jeffrey D (http://usage.fc.hp.c); Danny McPherson; ipfix wg
Subject: Re: [ipfix] Forming consensus on IPFIX default protocol

Bound, Jim wrote:

>Randy,
>
>I don't buy whoever is telling you it's a one line change but that is
>not the point.
>
Jim, I am not talking about the Java Sockets API.. I am talking about
a one line change in the actually collector program. I have made
mozilla run over SCTP in a grand total of two lines of code change. One
socket() call and one socketopt() call. Thats it. It is quite possible to
make minimalistic changes to a piece of code (such as our internal
"pre-collector" process ). Where it gets tricky is if you want to
change the Java sockets themselves and support all three.. that is not
a quick change... and it is not what I was talking about...

> If you program in Java you program in Java and take the
>total performance relations and benefits.
>

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Danny McPherson <[email-masked]>
Date: Mon, 17 Nov 2003 09:58:55 -0700

Folks,
Let's please make this about technologies and the
best technical solution for the problem set/requirements
at hand and not about Cisco.

And please recall that existing _deployment is NOT
a qualification for inclusion in a standard.

-danny