Subject: RE: [ipfix] Slides from IETF presentation.

From: "MEYER,JEFFREY D (HP-Cupertino,ex1)" <[email-masked]>
Date: Wed, 19 Nov 2003 09:48:21 -0800

Hi,

  In the interest of trying to borrow from existing IETF work.  My
recommendation would be to go with Stewart and Ganesh's proposal in 4.2
Compressed VI Qualified Template Flowset.

  http://www.ietf.org/internet-drafts/draft-bryant-ipfix-vendor-ie-00.txt

  This most closely resembles the way in which Diameter deals with vendor
proprietary and IETF defined field (attribute) id's.

  See section 4.1 AVP Header in http://www.faqs.org/rfcs/rfc3588.html

  I would recommend that instead of having "reserved ranges" of id's,
however that we reduce the size of field id's from 2**16 to 2**15 and
specify the high order bit as a "Vendor" flag.  (Similar to the Diameter
model)

  This gives us about 32,000 IETF defined fields which can be transmitted.
Hopefully this will be enough, along with 2**32 * 2**15 additional namespace
for proprietary fields.

  The diagram in 4.2 would be modified as:

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |V|       Field Type            |         Field Length          |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                        Vendor-ID (opt)                        |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

  Instead of talking about codepoint ranges for field types, you would just
discuss whether the "V" bit was set.  If the V bit is set, then the
Vendor-Id is present, otherwise it is not.

Regards,

  Jeff Meyer

> -----Original Message-----
> From: majordomo listserver 
> [mailto:[email-masked]]On Behalf
> Of Ganesh Sadasivan
> Sent: Tuesday, November 18, 2003 7:26 PM
> To: Mark Fullmer
> Cc: [email-masked]; [email-masked]
> Subject: Re: [ipfix] Slides from IETF presentation.
> 
> 
> 
> 
> Mark Fullmer wrote:
> 
> >
> > Stuart, could you please post your slides detailing the options for
> > extending the field ID space to include vendor extensions.
> >
> > If my memory is correct you proposed an optional 32 bit vendor
> > ID which would either always be in the template or optionally
> > in the template based on a "magic" field type which indicates
> > a vendor extension. 
> 
> Yes based on fixed ranges assigned to IETF defined and Vendor
> defined  field types (some thing like {0-32767} for IETF defined
> and {32768-65535} for vendor specified field types).
> 
> >
> >
> > After thinking about this for a few days I'd prefer the always
> > there version of your proposal.  I don't see any reason to save
> > a few bytes in the template at the expense of extra work in the
> > decode/encode process. 
> 
> When there is a mixture of IETF defined and  Vendor specified fields
> and we are using large number of fields in the templates, 
> this would be
> useful. But otherwise there are'nt any major advantages.
> I don't know how much extra work is involved in encoding/decoding.
> Could be as simple as :
> if (field_type < IETF_DEFINED_MAX) { ..} else {..}
> 
> Or do you see something more worse?
> 
> I am ok either way.
> 
> 
> > Also have you considered just using
> > a 32 bit vs. 16 bit field type with say the first 16 bits reserved
> > as a vendor ID?
> 
> We just wanted to give a 48 bit id for the field type.
> 
> Thanks
> Ganesh
> 
> >
> > mark
> >
> >
> > -- 
> > Help        mailto:[email-masked] and say "help" in 
> > message body
> > Unsubscribe mailto:[email-masked] and say
> > "unsubscribe ipfix" in message body
> > Archive     http://ipfix.doit.wisc.edu/archive/
> >
> 
> 
> 
> --
> Help        mailto:[email-masked] and say "help" 
> in message body
> Unsubscribe mailto:[email-masked] and say
> "unsubscribe ipfix" in message body
> Archive     http://ipfix.doit.wisc.edu/archive/
> 

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 20 Nov 2003 14:20:09 +0000

OK, I am happy to change to this encoding.

I would imagine that when the IETF runs out of 2**15 IEs it
will register iteslf as a vendor giving it another 2**15 IEs :)

Stewart