Subject: RE: [ipfix] [issue] INFO-23 Explicit IP version in message

From: "MEYER,JEFFREY D (HP-Cupertino,ex1)" <[email-masked]>
Date: Mon, 24 Nov 2003 12:05:55 -0800

Resending this because of mail reflector issue.  (It didn't like the word
unsigned).  Sorry if you get dup's

-- Jeff

-----Original Message-----
From: MEYER,JEFFREY D (HP-Cupertino,ex1) 
Sent: Monday, November 24, 2003 11:47 AM
To: [email-masked]'; MEYER,JEFFREY D (HP-Cupertino,ex1)
Cc: 'Ipfix Wg' (E-mail)
Subject: RE: [ipfix] [issue] INFO-23 Explicit IP version in message

Any proposed wording?  How about:

6.XX ipVersion
Description: 

The IPVersion identifier for this flow as defined in STD 5, RFC 791.

Type: unsignedByte. 

Field Id: XX

Range: The valid range is 0..15.

-- Jeff

-----Original Message-----
From: Stewart Bryant [mailto:[email-masked]]
Sent: Monday, November 24, 2003 2:27 AM
To: MEYER,JEFFREY D (HP-Cupertino,ex1)
Cc: 'Ipfix Wg' (E-mail)
Subject: Re: [ipfix] [issue] INFO-23 Explicit IP version in message

MEYER,JEFFREY D (HP-Cupertino,ex1) wrote:

> Issue: INFO-23  Explicit IP version in message
> Descriptin:
>   Should IP version be explicit in the flow or implied by the type of
>   address element passed?  For now it will remain implicit.  Although
>   could introduce a byte or short information element called ipVersion,
>   which would have either 4 or 6 as meaningful values.
> original e-mail:
>   http://ipfix.doit.wisc.edu/archive/1920.html
>  

This is an issue of future proofing.

If the IETF ever introduced IPv7 that used IPv6 address we could
figure that out from the datagrams because they are all self
describing, but ipfix would report the wrong thing.

Therefore we should have an IP version IE.

Stewart

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 25 Nov 2003 10:28:27 +0000

Works for me

Stewart