Subject: RE: [ipfix] DRAFT IPFIX meeting minutes, 58th IETF, Minneapolis

From: "MEYER,JEFFREY D (HP-Cupertino,ex1)" <[email-masked]>
Date: Wed, 12 Nov 2003 13:03:37 -0800

It also seems to ignore the basic implementation issues which I
had cited previously.

If default means, all things being equal use this.  Then OK.

If default means, you must implement this, but may implement
others, then NOT OK.

-- Jeff

> -----Original Message-----
> From: majordomo listserver 
> [mailto:[email-masked]]On Behalf
> Of Tal Givoly
> Sent: Wednesday, November 12, 2003 11:13 AM
> To: Nevil Brownlee
> Cc: [email-masked]; Benoit Claise
> Subject: RE: [ipfix] DRAFT IPFIX meeting minutes, 58th IETF, 
> Minneapolis
> 
> 
> Nevil,
> 
> I saw in Dave's note that there wasn't a consensus on the 
> default transport
> protocol. What you say below contradicts those minutes.
> 
> Tal
> 
> -----Original Message-----
> From: majordomo listserver 
> [mailto:[email-masked]]On Behalf
> Of Nevil Brownlee
> Sent: Wednesday, November 12, 2003 9:15 AM
> To: Benoit Claise
> Cc: [email-masked]
> Subject: Re: [ipfix] DRAFT IPFIX meeting minutes, 58th IETF, 
> Minneapolis
> 
> 
> Hello Benoit:
> 
> > The reply from Randy Bush to Stewart Bryant's question: 
> what about the
> > use of UDP in case of TTL=1?
> > Note that this was also addressed by Jeff Meyer on the mailing list.
> 
> That question was raised, but not discussed (following Ops 
> and Transport
> AD comment) at Monday's meeting.
> 
> The IPFIX charter says its transport has to be congestion-aware.
> UDP - even with TTL=1 - is not congestion-aware.
> We spent many, many months thrashing out the use of UDP at 
> least a year
> ago.
> 
> Now we have a meeting consensus for SCTP as the IPFIX default 
> transport.
> Any vendor is free to implement whatever other transports 
> they think their
> customers need, but at this stage what we're looking for is 
> text for the
> IPFIX protocol draft to explain how to use SCTP, TCP (and maybe DCCP).
> 
> Let's move on and get the drafts finished!
> 
> CHeers, Nevil
> 
> --------------------------------------------------------------
> ---------
>    Nevil Brownlee                   Director, Technology Development
>    Phone: +64 9 373 7599 x88941     ITSS, The University of Auckland
>    FAX: +64 9 373 7021      Private Bag 92019, Auckland, New Zealand
> 
> 
> -------------------------------------------------
> This mail sent through University of Auckland
> http://www.auckland.ac.nz/
> 
> --
> Help        mailto:[email-masked] and say "help" 
> in message
> body
> Unsubscribe mailto:[email-masked] and say
> "unsubscribe ipfix" in message body
> Archive     http://ipfix.doit.wisc.edu/archive/
> 
> 
> --
> Help        mailto:[email-masked] and say "help" 
> in message body
> Unsubscribe mailto:[email-masked] and say
> "unsubscribe ipfix" in message body
> Archive     http://ipfix.doit.wisc.edu/archive/
> 

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Pratap Pereira <[email-masked]>
Date: Wed, 12 Nov 2003 13:58:34 -0800

Folks,

I concur with this opinion... I have been following/lurking
in the mailing list for a long time ;-)

Any default MUST should favor a lowest common denominator,
widely available protocol and I would think that means
TCP.

Statements to the effect that SCTP is preferred/recommended
is up to the working group to reach an agreement on, it
should not be the default.

UDP has been out for a while as noted.

Thanks,

-pratap