Subject: RE: [ipfix] [issue] INFO-24 High-res time encoding

From: "MEYER,JEFFREY D (HP-Cupertino,ex1)" <[email-masked]>
Date: Tue, 9 Dec 2003 01:58:04 -0500

Hi,

  My preference would be milliseconds with a signed quantity.

  This gives you about +/- 2147 seconds on either side of the sentinel time.
If you do not use a signed offset it forces a flow record to be adjusted
"backward" so that all time offsets are positive (could be tricky for
FlowCreationTime).

  Using microseconds would yield only +/- 2.14 seconds which is a pretty
narrow window for grouping flows.

-- Jeff

-----Original Message-----
From: Mark Fullmer [mailto:[email-masked]]
Sent: Monday, December 08, 2003 10:18 PM
To: MEYER,JEFFREY D (HP-Cupertino,ex1)
Cc: ''Ipfix Wg' (E-mail)'
Subject: Re: [ipfix] [issue] INFO-24 High-res time encoding

Microsecond might be okay...

mark

On Mon, Dec 08, 2003 at 10:04:48PM -0800, MEYER,JEFFREY D (HP-Cupertino,ex1)
wrote:
> OK,
> 
>   I'll get it right yet...
> 
>   It should say for dateTimeMsec   "...32-bit integer count of (signed)
>   millisecond offset... [not microsecond]"

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Mark Fullmer <[email-masked]>
Date: Tue, 9 Dec 2003 02:19:17 -0500

I think you're off by one SI unit, or I'm sending e-mail too late at night...

Millisecond : 10^-3 seconds
Microsecond : 10^-6 seconds
Nanosecond  : 10^-9 seconds

2^32 * 10^-3 = 4294967 seconds
2^32 * 10^-6 = 4294 seconds
2^32 * 10^-9 = 4 seconds

I'm not sure running down the list of flows per export packet to fix
the timestamps is that big a deal, but it probably doesn't matter.  An
implementation that wants the full range can put the header/sentinel
time in the middle of the range.

mark