Subject: [ipfix] draft-ietf-ipfix-protocol-02.txt

From: Benoit Claise <[email-masked]>
Date: Tue, 20 Jan 2004 19:52:49 +0100

Dear all,

Here is the changes in the new version of the IPFIX protocol draft, 
posted today.

New sections:

- overview section written
- Vendor Specific Information Element
	New section 8.3.1 "IETF Exclusive Template FlowSet Format"
	New section 8.3.2 "Vendor Specified Template FlowSet Format"
	New section 9.1.1 "IETF Exclusive Options Template FlowSet Format"
	New section 9.1.2 "Vendor Specified Options Template FlowSet Format"
- Metering Process Statistics Option Template
 	New section 9.3 "Specific IPFIX Options Templates"
  	New section 9.3.1 "Metering Process Statistics Option Template"
  I've been trying to write down text that IMHO is the WG group consensus, as a starting point
**- time synchronization:
	UNIX Secs new definition
	sysUpTime removed from the header format
	New Section 10 "Export Packet UNIX Secs Computation and Flow Records Times"
	New Section 10.1 "microsecond precision"
	New Section 10.2 "nanosecond precision"
	New Section 10.3 "millisecond precision"
	New Section 10.4 "multiple precisions"
  I've been trying to write down text that IMHO is the WG group consensus, as a starting point
  Note that the example in section 17.1 has been updated with the new change
- A new section on the "Linkage with Information Model" defining the encoding rules and the 
"Reduced Size Encoding of Integral Types". Initial text proposed by Jeff Meyer
	New Section 11 "Linkage with the Information Model"
	New Section 11.1 "Boolean"
	New Section 11.2 "Byte"
	New Section 11.3 "UnsignedByte"
	New Section 11.4 "Short"
	...
	New Section 11.5 "Reduced Size Encoding of Integral Types"
  Again, this is a starting point for further discussion.
- A new section 15 Security Considerations.
  Initial proposed by Stewart Bryant. 
	New section 15.1 "IPsec Profile"
	New section 15.1.1 "Selectors"
	New section 15.1.2 "Mode"
	New section 15.1.3 "Key Management"
	New section 15.1.4 "Security Policy"
	New section 15.1.5 "Authentication"
	New section 15.1.6 "Availability"
	New section 15.2 "Network Architecture"
	New section 15.3 "When IPsec is not an Option"
	New section 15.4 "Transport Issues"
	New section 15.5 "Logging an IPFIX Attack"
  Again, this is a starting point for further discussion.
- quick "IANA considerations" section 16, which still needs some more work
- meterstats

Updates
- Length replaced the Count in the header. Example at the end of the draft is updated.
- Updated the Variable Length Data Type 
  As a consequence, the new term "Information Element" exists in the terminology section
- normative versus informative references

Editorial changes

- "Packet Layout" changed "IPFIX Message Layout"
- latest references: SCTP-PR, INFO_MODEL
- reference to [IPFIX-INFO] instead of "Field Type Definitions" section, which was a section in the NetFlow version 9 draft
- "Header" changed to "Message Header"
  Note that the example in section 17.1 has been updated with the new change
- changed the section 5.2.3.4 to stream
- removed any NetFlow or NetFlow collector references
- remove the UDP reference (anyway not used in the draft)
- Section 5.2.2 introduces 'SCTP streams,' I'd add "referred to hereafter
      as 'streams;' 'streams' is one of those words which means many different
      things in different contexts.
- Section 5.2.3.2, Source ID:
  change "MUST be kept unique for each such [Observation] domain" into "'MUST be kept unique for each such Observation domain"
- Section 5.2.5. What are "diverting" SID values?  Is it just a typo for "differing?" Corrected!
- Section 5.2.4, Collecting Process: typo in line 2, s/Collecting Process/Exporting Process/
Corrected.
- Section 5.2.4.  Wouldn't hurt to say SID (Source ID) to remin readers where SID was defined.
- add Ganesh Sadasivan and Stewart Bryant as authors as they prepared the text for Vendor Specific Information Element
- IPFIX Packet Header version changed from 0x0009 to 0x000a

As always, your feedback is welcome.
The first sections "open issues" and "action items" have been updated. 
Please correct me if I missed some.
Don't forget to also propose some new text when you address an issue ;)

To get the draft right, follow the procedure below

Regards, Benoit.

The file name is draft-ietf-ipfix-protocol-02.txt (IPFIX protocol draft 
version 2)

To get these files, please do the following...
   1. With a Netscape or Internet Explorer web browser open
      the following URL:
        http://www.cisco.com/pcgi-bin/specialaccess.cgi
   2. Enter all your details and at the 'Special Access Code' prompt,
      enter in MEANLSKM
   3. Click on the 'Submit' button.  This will bring you
      to a web page listing your files for pickup.
   4. Select each file listed.  Each selection will take
      you to the Software Download web page; click on any
      Site listed to download your file to your local disk.

---

From: Benoit Claise <[email-masked]>
Date: Tue, 27 Jan 2004 08:37:57 +0100

Dear all,

While rereading the protocol draft, I realized that I did a mistake 
(forgot to update something).
To be consistent with the time proposal, the packet header should look like:

1.1 Section 8.1 Header Format

 0                   1                   2                   3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|       Version Number          |            Length             |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                           UNIX Secs                           |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                       Sequence Number                         |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                          Source ID                            |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

This will be corrected for the next protocol draft version.

Regards, Benoit.

>- time synchronization:
> The file name is draft-ietf-ipfix-protocol-02.txt (IPFIX protocol 
> draft version 2)
>