Subject: [ipfix] [issue] INFO-27 Information model reconciliation with NetflowV9 Draft

From: "Jeff Meyer" <[email-masked]>
Date: Mon, 26 Jan 2004 23:51:24 -0800

There are a large number of information elements defined in the NFv9 draft 
in
section 8 "Field Type Definitions" which are not currently part of the IPFIX 
information
model.

There are a smaller set of information elements currently defined in 
ipfix-info which
are not defined in NFv9.

Note all common IE's are defined to have the same fieldId value.

A summary of the deltas between the two documents is available at:

  http://inetpix.com/ipfix/NFv9_IPFIX_info_comparison.xls

It would appear that some of the information elements defined in NFv9 are 
actually
option data vs. flow data (see issue INFO-26 at 
http://ipfix.doit.wisc.edu/archive/2360.html).

Proposal would be to take a subset of these information elements from NFv9 
into ipfix.

The value of the current ipfix-info elements which fall outside of NFv9 is 
also worth
questioning.

-- Jeff Meyer

_________________________________________________________________
Let the new MSN Premium Internet Software make the most of your high-speed 
experience. http://join.msn.com/?pgmarket=en-us&page=byoa/prem&ST=1

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 29 Jan 2004 12:57:57 +0100

Jeff,

The open problem I see here is fixing
the set of information elements
that are part of the IPFIX INFO model.
We are free to choose this set except that
we should avoid conficting numbers between
NFv9 and IPFIX.

Regards,

    Juergen

--On 26.01.2004 23:51 Uhr -0800 Jeff Meyer wrote:

> There are a large number of information elements defined in the NFv9 draft in
> section 8 "Field Type Definitions" which are not currently part of the IPFIX information
> model.
>
> There are a smaller set of information elements currently defined in ipfix-info which
> are not defined in NFv9.
>
> It would appear that some of the information elements defined in NFv9 are actually
> option data vs. flow data (see issue INFO-26 at http://ipfix.doit.wisc.edu/archive/2360.html).
>
> Proposal would be to take a subset of these information elements from NFv9 into ipfix.
>
> The value of the current ipfix-info elements which fall outside of NFv9 is also worth
> questioning.
>
> -- Jeff Meyer
>
> Let the new MSN Premium Internet Software make the most of your high-speed experience. http://join.msn.com/?pgmarket=en-us&page=byoa/prem&ST=1
>
>
> --