Subject: Re: [ipfix-protocol] IPFIX protocol draft: list of issues

From: "Jeff Meyer" <[email-masked]>
Date: Mon, 16 Feb 2004 10:11:52 -0800

Hi,

  If I have a declaration of the form:

     int var1;
     int var2;
     char *var3;

  Is "var1" a type?  Or is the type of "var1" int?  var1 and var2 are 
"identifiers" in my opinion which distinguish among two variables (fields) 
of the same type.  I believe the templating structure is doing the same 
thing as the example above, but using numeric id's versus string id's.

  The IPFIX protocol authors chose not to include type information, instead 
opting to include information about the length of the encoding for a field 
of a given type (e.g. int, short, dateTime, etc.).  So there are 
(unfortunately) no provisions to hold type information in IPFIX-proto.

  E.g. the logical equivalent in ipfix-proto templating model to the above 
would be:

    length (4)  fieldId(1);
    length (4)  fieldId(2);
    length(VARIABLELEN)  fieldId(3)

  Calling these information element ids would be most accurate, but the term 
"field" seems heavily used and is equivalent.  Calling these identifiers 
"types" seems odd to me.

-- Jeff

>From: Stewart Bryant <[email-masked]>
>Reply-To: [email-masked]
>To: Jeff Meyer <[email-masked]>
>CC: [email-masked], [email-masked]
>Subject: Re: [ipfix-protocol] IPFIX protocol draft: list of issues
>Date: Mon, 16 Feb 2004 09:47:24 +0000
>
>
>
>Jeff Meyer wrote:
>
>>Benoit,
>>
>>  Regarding [Proto-2] I'd recommend Field Id over Field Type.  The word 
>>"type" seems overloaded to me, does type refer to unsigned int, time, etc. 
>>  Or does it refer a specific field definition (via a numeric identifier).
>>
>>>From its usage it would seem that this portion of the protocol message is
>>
>>holding an identifier, not a type.
>>
>>-- Jeff
>>
>
>Isn't it holding a type identifier?
>
>It's a codepoint that identifies the type of the field that will be
>contained in the corresponding field in the data message.
>
>That would suggest that the name should be field type identifier (FTI)
>or perhaps field type codepoint (FTC).
>
>- Stewart
>
>
>

_________________________________________________________________
Click here for a FREE online computer virus scan from McAfee. 
http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Juergen Quittek <[email-masked]>
Date: Tue, 17 Feb 2004 16:58:57 +0100

Jeff,

--On 16.02.2004 10:11 Uhr -0800 Jeff Meyer wrote:

>   Is "var1" a type?  Or is the type of "var1" int?

The DATA type of var1 is int.  That's why the proposal ...

>> PROTO-2: Some discrepancies between data types, field type and Information
>>    Element terminology.
>>    - field type (IPFIX-PROTO) conflicts with field ID (IPFIX-INFO)
>>    - suggestion: use field type instead of field Id in IPFIX-INFO
>>    - rename 'type' to 'data type' and

 ... suggests to rename 'type' in the info model doc to 'data type'
and use 'field type' as the semantic type of the field.

Field type would still be a consistent term.

However, I have more sympathy for the term 'field ID',
because intuitively this is interpreted correctly
while 'field type' could easily be mis-interpreted as
'field data type'.

Thanks,

    Juergen
-- 
Juergen Quittek        [email-masked]        Tel: +49 6221 90511-15
NEC Europe Ltd.,       Network Laboratories        Fax: +49 6221 90511-55
Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   http://www.ccrle.nec.de

>  var1 and var2 are "identifiers" in my opinion which distinguish among two variables (fields) of the same type.  I believe the templating structure is doing the same thing as the example above, but
> using numeric id's versus string id's.
>
>   The IPFIX protocol authors chose not to include type information, instead opting to include information about the length of the encoding for a field of a given type (e.g. int, short, dateTime, etc.).  So there are (unfortunately) no provisions to
> hold type information in IPFIX-proto.
>
>   E.g. the logical equivalent in ipfix-proto templating model to the above would be:
>
>     length (4)  fieldId(1);
>     length (4)  fieldId(2);
>   Calling these information element ids would be most accurate, but the term "field" seems heavily used and is equivalent.  Calling these identifiers "types" seems odd to me.
>
> -- Jeff
>
> Click here for a FREE online computer virus scan from McAfee. http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963
>
>
> --

---

From: Juergen Quittek <[email-masked]>
Date: Tue, 17 Feb 2004 16:58:57 +0100

Jeff,

Thanks,

    Juergen