Subject: [ipfix-protocol] about section 17:Examples

From: 冯文峰 <[email-masked]>
Date: Fri, 06 Feb 2004 12:07:42 +0800 (CST)

In draft-ietf-ipfix-protocol-02.txt,Section 17,Page 42.

The example seems to be a NETFLOW9 example,rather than a IPFIX example.
First,the message header's Version Number Field should to be 0x000a instead of 0x0009; Second, in the message header there should be a SysUpTime Field besides the Unix Secs Field; and in Section 17.5 Data FlowSet with Options Data Records Example,there may be some error: According to IPFIX Protocol Specification the Length Field should be 20 rather than 14.

Best Regards
yours wenfeng

---

From: Benoit Claise <[email-masked]>
Date: Fri, 06 Feb 2004 16:40:21 +0100

Hi Wenfeng,

>First,the message header's Version Number Field should to be 0x000a instead of 0x0009; 
>
Corrected.

>Second, in the message header there should be a SysUpTime Field besides the Unix Secs Field; 
>
This one has been reported already. Actually the example is right!
http://ipfix.doit.wisc.edu/archive/2362.html

>and in Section 17.5 Data FlowSet with Options Data Records Example,there may be some error: According to IPFIX Protocol Specification the Length Field should be 20 rather than 14.
>
Corrected.

Thanks.

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Benoit Claise <[email-masked]>
Date: Tue, 17 Feb 2004 11:39:21 +0100

Hi Wenfeng,

After looking (more) carefully, there was a mistake in that example, there was an extra 2 in the Flow Record.
It should be:

     In this example, we report the following two records:

     Line Card ID | Export Packet| Export Flow
     ------------------------------------------
     Line Card 1  | 345          | 10201
     Line Card 2  | 690          | 20402

      0                   1                   2                   3
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |    FlowSet ID = 257           |         Length = 16           |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |             1                 |             345               |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |           10201               |              2                |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |            690                |            20402              |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

This is corrected in 03 protocol draft version.

Regards, Benoit.

>> and in Section 17.5 Data FlowSet with Options Data Records 
>> Example,there may be some error: According to IPFIX Protocol 
>> Specification the Length Field should be 20 rather than 14.
>>
> Corrected.
>
> Thanks.
>
>>
>> Best Regards
>> yours wenfeng
>>
>>
>>  
>>
>
>
>
> --

---

From: Benoit Claise <[email-masked]>
Date: Tue, 17 Feb 2004 11:42:31 +0100

>     Line Card ID | Export Packet| Export Flow

Ooops.
This is _NOT _corrected in the 03 protocol draft version.
But corrected in the interim version.