Subject: [ipfix-protocol] PROTO-14: padding.

From: Benoit Claise <[email-masked]>
Date: Thu, 17 Jun 2004 22:06:35 +0200

Dear all,

 From the IPFIX protocol specification:

    14. PROTO-14: Why do we need padding? Should we shift it to MAY?
           limit the size of the padding? Yes
           solution:
           - padding shorter than actual Record Length
           - fill with 0
           - only at end of flowset
           - applies to all flowsets
           - padding is OPTIONAL (MAY) , not RECOMMENDED (SHOULD)

 From the Seoul meeting minutes:

    - Padding: currently a should for the exporting process, and a must for
     the collector.  Proposal to have a MAY for the exporting process

In the current IPFIX protocol draft version 3, the same definition is 
applied to the following section:
    8.4   Data FlowSet Format
    8.5.1   Options Template FlowSet Format 
    8.5.2   Options Data Record Format

   Padding
           The Exporting Process SHOULD insert some padding bytes so
           that the subsequent FlowSet starts at a 4-byte aligned
           boundary. It is important to note that the Length field
           includes the padding bits.

The proposal is to change it to:

    8.4   Data FlowSet Format
   Padding
           The Exporting Process MAY insert some padding bytes,
           so that the subsequent FlowSet starts at an aligned boundary.
           Padding MUST be composed of zero (0) bits.
           The padding length MUST be shorter than one Flow Data Record.
          It is important to note that the Length field includes the 
padding bits.

    8.5.1   Options Template FlowSet Format 
   Padding
          The Exporting Process MAY insert some padding bytes,
           so that the subsequent FlowSet starts at an aligned boundary.
           Padding MUST be composed of zero (0) bits.
           The padding length MUST be shorter
           than one Options Template Record. It is important to note 
that the
          Length field includes the padding bits.

    8.5.2   Options Data Record Format
   Padding
          The Exporting Process MAY insert some padding bytes,
           so that the subsequent FlowSet starts at an aligned boundary.
           Padding MUST be composed of zero (0) bits.
           The padding length MUST be shorter
           than one Options Data Record. It is important to note that the
          Length field includes the padding bits.

 I think we are OK with Template FlowSet, as it will always have  
"4-byte aligned" boundaries.

Feedback?

Regards, Benoit.

---

From: Sebastian Zander <[email-masked]>
Date: Wed, 23 Jun 2004 10:15:17 +1000

Hi Benoit,

shouldn't it always read "... starts at a _4-byte_ aligned boundary"?

Cheers,

Sebastian

-- 
Sebastian Zander
http://caia.swin.edu.au

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/