Subject: [IPFIX] RFC 7101, 7102, 7103?

From: Benoit Claise <[email-masked]>
Date: Wed, 12 Jan 2011 17:15:17 +0100

Dear all,

Based on the previous meeting minutes:

    Juergen led a discussion on "should we move the IPFIX base standards
    (RFCs 5101, 5102 and 5103) to Draft Standard.  There was consensus
    that this would be worthwhile if it corrected all the bugs discovered
    to date in the documents, and added explanatory text to make them
    easier to understand.  We also need to remove 'IP' from the IPFIX Flow
    definition, since that is proving to be a blocking factor or the ITU-T
    NGN to reference IPFIX.

Do you think it's a good idea to reserve the following RFC 7101, 7102, 
7103 numbers?
Looking at http://www.ietf.org/download/rfc-index.txt, it's apparently 
too late for the 61xx series.

Regards, Benoit.

---

From: Nevil Brownlee <[email-masked]>
Date: Thu, 13 Jan 2011 11:33:02 +1300

Hi Benoit:

RFC Editor policy is that RFC numbers don't get allocated until a draft
reaches AUTH48 state.

However, for new RFCs that replace old ones, we can send an informal
request to RFC Editor letting them know what we're doing so that they
consider such a request when they're allocating numbers close to the
ones we'd like.  Note that there's no guarantee that we'd actually get
them!

Shall I send them an informal request like this?

Cheers, Nevil

On 13/01/11 5:15 AM, Benoit Claise wrote:
> Do you think it's a good idea to reserve the following RFC 7101, 7102, 7103 numbers?
> Looking at http://www.ietf.org/download/rfc-index.txt, it's apparently too late for the 61xx series.
>
> Regards, Benoit.

-- 
---------------------------------------------------------------------
  Nevil Brownlee                    Computer Science Department | ITS
  Phone: +64 9 373 7599 x88941             The University of Auckland
  FAX: +64 9 373 7453   Private Bag 92019, Auckland 1142, New Zealand

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 13 Jan 2011 11:37:47 +0100

Actually according to the RFC index 6101, 6102, 6103 were not published
yet. They may have been reserved however, as the last one published is
6106. If they were reserved I would suggest that we do not wait until
7101, 7102, 7103 - this means a few years and I expect the Draft
Standards to show up much sooner (please do not tell me I am wrong!). 

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Nevil Brownlee
> Sent: Thursday, January 13, 2011 12:33 AM
> To: Benoit Claise
> Cc: [email-masked]
> Subject: Re: [IPFIX] RFC 7101, 7102, 7103?
> 
> 
> Hi Benoit:
> 
> RFC Editor policy is that RFC numbers don't get allocated 
> until a draft reaches AUTH48 state.
> 
> However, for new RFCs that replace old ones, we can send an 
> informal request to RFC Editor letting them know what we're 
> doing so that they consider such a request when they're 
> allocating numbers close to the ones we'd like.  Note that 
> there's no guarantee that we'd actually get them!
> 
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix
>

---

From: Brian Trammell <[email-masked]>
Date: Thu, 13 Jan 2011 11:40:36 +0100

hi, Dan, all,

I say we look for the next xx01, xx02, xx03 available when we are ready to publish -- these could be 660x, for example, just as well as 710x.

(+1 to the idea in general)

Cheers,

Brian

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 13 Jan 2011 11:42:24 +0100

Good compromise. 

Dan

> From: Brian Trammell [mailto:[email-masked]] 
> Sent: Thursday, January 13, 2011 12:41 PM
> To: Romascanu, Dan (Dan)
> Cc: Nevil Brownlee; Benoit Claise; [email-masked]
> I say we look for the next xx01, xx02, xx03 available when we 
> are ready to publish -- these could be 660x, for example, 
> just as well as 710x.
> 
> > Actually according to the RFC index 6101, 6102, 6103 were not 
> > published yet. They may have been reserved however, as the last one 
> > published is 6106. If they were reserved I would suggest that we do 
> > not wait until 7101, 7102, 7103 - this means a few years 
> and I expect 
> > the Draft Standards to show up much sooner (please do not 
> tell me I am wrong!).
> > 
> > Dan
> > 
> > 
> >> From: [email-masked] [mailto:[email-masked]] On 
> >> Behalf Of Nevil Brownlee
> >> RFC Editor policy is that RFC numbers don't get allocated until a 
> >> draft reaches AUTH48 state.
> >> 
> >> ones we'd like.  Note that there's no guarantee that we'd actually 
> >> get them!
> >>

---

From: Benoit Claise <[email-masked]>
Date: Thu, 13 Jan 2011 18:13:42 +0100

Dan,

I did some more investigations.
Some RFCs are in AUTH48. For example, 
http://www.rfc-editor.org/auth48/rfc6074
However, I don't see any entries for
http://www.rfc-editor.org/auth48/rfc6101
http://www.rfc-editor.org/auth48/rfc6102
http://www.rfc-editor.org/auth48/rfc6103

So unless there were reserved, they might still be free.
Worth asking RFC-editor now?
> Standards to show up much sooner (please do not tell me I am wrong!).
No, you're not wrong. ;-)

Regards, Benoit.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 13 Jan 2011 18:44:55 +0100

Indeed! 

> From: Benoit Claise [mailto:[email-masked]] 
> Sent: Thursday, January 13, 2011 7:14 PM
> To: Romascanu, Dan (Dan)
> Cc: Nevil Brownlee; [email-masked]