Subject: [IPFIX] [Technical Errata Reported] RFC5101 (2791)

From: RFC Errata System <[email-masked]>
Date: Thu, 28 Apr 2011 06:53:19 -0700 (PDT)

The following errata report has been submitted for RFC5101,
"Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of IP Traffic Flow Information".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5101&eid=2791

--------------------------------------
Type: Technical
Reported by: Adrian Farrel <[email-masked]>

Section: 7

Original Text
-------------
   If the length of the Information Element is greater than or equal to
   255 octets, the length is encoded into 3 octets before the
   Information Element.  The first octet is 255, and the length is
   carried in the second and third octets, as shown in Figure S.

Corrected Text
--------------
   The length may also be encoded into 3 octets before the Information
   element allowing the length of the Information Element to be
   greater than or equal to 255 octets. In this case, first octet of
   the Lenght field MUST be 255, and the length is carried in the 
   second and third octets, as shown in Figure S.

Notes
-----
The original text is ambiguous as to whether it is possible to carry a length of less than 255 encoded in a 3 octet Length field. The quoted text seems to say it is not allowed, but Figure S says that the 2nd and 3rd octets may be set to "Length (0 to 65535)".

Since there is absolutely no harm (except a little inefficiency) in using a 3 octet Length field to encode a small length, the document should be clarified to remove the ambiguity.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5101 (draft-ietf-ipfix-protocol-26)
--------------------------------------
Title               : Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of IP Traffic Flow Information
Publication Date    : January 2008
Author(s)           : B. Claise, Ed.
Category            : PROPOSED STANDARD
Source              : IP Flow Information Export
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Paul Aitken <[email-masked]>
Date: Thu, 28 Apr 2011 15:07:32 +0100

Adrian,

"allowing the length of the Information Element to be greater than or 
equal to 255 octets" doesn't clearly state that 0-254 are also acceptable.

So with your agreement, I'd like to modify your "Corrected Text" :

OLD

NEW

    The length may also be encoded into 3 octets before the Information
    element allowing the length of the Information Element to be
    between 0 and 65535 octets. In this case, the first octet of
    the Length field MUST be 255, and the length is carried in the
    second and third octets, as shown in Figure S.

Also NB: I added "the" and corrected "Lenght".

Cheers.
P.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 28 Apr 2011 17:33:32 +0200

ACK.

Dan 

> -----Original Message-----
> From: Adrian Farrel [mailto:[email-masked]] 
> Sent: Thursday, April 28, 2011 6:27 PM
> To: 'Paul Aitken'
> Cc: 'RFC Errata System'; [email-masked]; Romascanu, Dan 
> (Dan); [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: RE: [IPFIX] [Technical Errata Reported] RFC5101 (2791)
> 
> Paul,
> 
> Lenght is my favourite typo.
> 
> wfm
> 
> Resolving AD can patch it up.
> 
> A
> 
> > -----Original Message-----
> > From: Paul Aitken [mailto:[email-masked]]
> > Sent: 28 April 2011 15:08
> > To: [email-masked]
> > Cc: RFC Errata System; [email-masked]; [email-masked]; 
> > [email-masked]; [email-masked]; [email-masked]; 
> > [email-masked]
> > Subject: Re: [IPFIX] [Technical Errata Reported] RFC5101 (2791)
> > 
> > Adrian,
> >

---

From: Adrian Farrel <[email-masked]>
Date: Thu, 28 Apr 2011 16:26:59 +0100

Paul,

wfm

A