Subject: Re: [IPFIX] modifying existing IEs

From: Benoit Claise <[email-masked]>
Date: Mon, 04 Apr 2011 09:59:46 +0200

On 30/03/2011 10:20, Brian Trammell wrote:
> Hi, Paul,
>
> a couple of points inline...
>
> On Mar 29, 2011, at 6:34 PM, Paul Aitken wrote:
>
>> Brian,
>>
>>> This was a point on the open
>>        issues slide, but was trying to speed
>>
>>
>>        >  through things today so it got missed...
>>
>>
>>        >
>>
>>
>>        >  So, do we need IE versions? In my opinion, yes: otherwise we
>>        can't
>>
>>
>>        >  change "future reserved" values in flags or code table IEs.
>>
>>
>> We can, though there won't be any reference point for us to indicate exactly what we support.
> Unless the registry contains _every_ version of each IE.
Why not a simple description field: in this version, explaining in plain 
english text what has been added per IE version?

Regards, Benoit.
> But then there would still be no _runtime_ support for this...
>>> I'd suggest a new column in the
>>        registry, initialized to 0 for
>>
>>
>>        >  existing IEs. If these are essentially code tables linked to
>>
>>
>>        >  subregistries, then the subregistries should probably have
>>        version
>>
>>
>>        >  numbers themselves.
>>
>>
>> OK.
>>
>>
>>> A second question: what about
>>        an IANA Registry version - a serial
>>
>>
>>        >  number incremented by one on each modification, deprecation,
>>        or
>>
>>
>>        >  addition? The case for this is less clear for me.
>>
>>
>> Agreed:  if I add export of a new IE, or add new values in an existing IE, thus creating a new registry version,
>> then I'd be obliged to bring all my exports up to date in order to comply with the version I just made.
>>
>> That may not be necessary, desirable or even possible.
> Hm. Good point. Okay, so the consensus of two would be "versioned IEs, versioned subregistries referenced by IEs, no versioned registry"...
>
> Cheers,
>
> Brian
>
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix

---

From: Brian Trammell <[email-masked]>
Date: Mon, 4 Apr 2011 10:21:24 +0200

On Apr 4, 2011, at 9:59 AM, Benoit Claise wrote:
> Why not a simple description field: in this version, explaining in plain english text what has been added per IE version?

That'll make IANA happier, certainly. (And the multiversion thing would be better for some unspecified _future_ automated support, maybe, but on second thought would be terribly confusing to people who weren't expecting it, i.e. almost everyone...)

Cheers,

Brian