Subject: Re: [IPFIX] Fwd: New Version Notification fordraft-kashima-ipfix-data-link-layer-monitoring-05

From: Shingo KASHIMA <[email-masked]>
Date: Wed, 06 Apr 2011 00:23:15 +0900

Hi Laxmi,

Thank you for your comments.

Please see in-line.

On Mon, 28 Mar 2011 16:28:17 +0530
"Laxmi Mukund (lmukund)" <[email-masked]> san wrote:

> Hi Shingo San,
> I think this would be very useful to include in the draft. We have been
> working on this but didn't get to put it in a draft. Glad you could put
> them in here.
> I have some comments about the draft.
> 1) 
> 3.6.  dot1qServiceInstanceTag
> Maybe this could be reworded to:
>       This Information Element, which may have 16 octets length,
> represents 
>       the Backbone Service Instance Tag (I-TAG) Tag Control Information
>       (TCI) field of an Ethernet frame as described in
>       [IEEE802.1ah-2008]. It encodes the priority, drop_eligible,
> destination
>       and source address.  

Yes.
I will modify in a next revision.

> 2) It looks like Section 3.7 and 3.8 have got interchanged. The
> description and the information elements have been switched.

Oh.. This is my mistake.
I will modify in a next revision.

> 
> 3) Could we include a section that would say the current and new
> information elements needed to export all the 802.1ah header fields like
> so:
> 
> This is a summary of the 802.1ah fields and the new and current
> informational elements that would be used to represent each of the
> fields.
> 
> <-----6---------><------6-------><--4-----><-----6--------><-----6------
> --><-----6-------><---4--->
> +---------------+---------------+---------+---------------+-------------
> --+--------------+--------+
> +               +               +         +               +
> +              +        +
> +     B-DA      +       B-A     + B TAG   +     I-TAG     +      C-DA
> +     C-SA     +  C-TAG +
> +       1       +        2      +    3    +       4       +        5
> +      6       +    7   +
> +---------------+---------------+---------+---------------+-------------
> --+--------------+--------+
> 
> 1.(Existing Element) destinationMacAddress 80
> 2.(Existing Element) sourceMacAddress 56
> 3.(Existing Element) dot1qVlanId 243, dot1qPriority 244
> 4.(New Element) defined in section 3.6, 3.7, 3.8 of this draft
> 5.(New Element) defined in section 3.9 of this draft
> 6.(New Element) defined in section 3.10 of this draft
> 7.(Existing Element) dot1qCustomerVlanId 245, dot1qCustomerPriority 246
> 

Nice comments.
But as you know, I-TAG includes C-DA and C-SA
How about the following ?

<----6----><----6----><----4----><------18------><----4---->
+----------+----------+----------+---------------+----------+
+          +          +          +               +          +
+   B-DA   +   B-SA   +   B-TAG  +     I-TAG     +   C-TAG  +
+    1     +    2     +     3    +       4       +     5    +
+----------+----------+----------+---------------+----------+

1.(Existing Element) destinationMacAddress 80
2.(Existing Element) sourceMacAddress 56
3.(Existing Element) dot1qVlanId 243, dot1qPriority 244
4.(New Element) defined in section 3.6, 3.7, 3.8, 3.9 and 3.10 of this draft
5.(Existing Element) dot1qCustomerVlanId 245, dot1qCustomerPriority 246

> 
> Very sorry about what happened in Japan, it is very unfortunate.
> My best wishes, please take care,

Thank you.

> Thanks,
> Laxmi.
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Shingo KASHIMA
> Sent: Thursday, March 24, 2011 8:04 AM
> To: [email-masked]
> Subject: [IPFIX] Fwd: New Version Notification
> fordraft-kashima-ipfix-data-link-layer-monitoring-05
> 
> 
> Dear all,
> 
> Here is a new version of the draft, which includes:
> - new information elements related to 802.1ah (MAC-in-MAC)
> - generic offset and observed octets
> 
> Is this valuable for WG item ?
> 
> I wanted to make a presentaion in Prague.
> But I cannot go to Prague due to huge earthquak in Japan.
> Sorry.
> 
> Best Regards,
> Shingo.
> 
> ----- Original Message -----
> Date: Tue, 15 Mar 2011 09:59:12 +0900
> From: "IETF I-D Submission Tool" <[email-masked]>
> Subject: New Version Notification for
> draft-kashima-ipfix-data-link-layer-monitoring-05
> 
> A new version of I-D,
> draft-kashima-ipfix-data-link-layer-monitoring-05.txt 
> has been successfully submitted by Kensuke Nakata and posted to the IETF
> repository.
> 
> Filename: draft-kashima-ipfix-data-link-layer-monitoring
> Revision: 05
> Title: Information Elements for Data Link Layer Traffic Measurement
> Creation_date: 2011-03-15
> WG ID: Independent Submission
> Number_of_pages: 26
> 
> Abstract:
> This document describes Information Elements related to data link
> layer.  They are used by the IP Flow Information Export (IPFIX)
> protocol for encoding measured data link layer traffic information.
> 
> The IETF Secretariat.
> 
> -- 
> Shingo KASHIMA <[email-masked]>
> 
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix

-- 
Shingo KASHIMA <[email-masked]>

---

From: "Laxmi Mukund (lmukund)" <[email-masked]>
Date: Thu, 7 Apr 2011 09:50:55 +0530

Hi Shingo San,
Thank you for the reply. Yes we can combine 4.5.6 in the list.
Thanks,
Laxmi.

-----Original Message-----
From: Shingo KASHIMA [mailto:[email-masked]] 
Sent: Tuesday, April 05, 2011 8:53 PM
To: Laxmi Mukund (lmukund)
Cc: [email-masked]
Subject: Re: [IPFIX] Fwd: New Version Notification

Hi Laxmi,

Please see in-line.

Yes.

Oh.. This is my mistake.

Nice comments.

4.(New Element) defined in section 3.6, 3.7, 3.8, 3.9 and 3.10 of this
draft

Thank you.