Subject: Re: [IPFIX] Fwd: I-D Action:draft-ietf-ipfix-configuration-model-09.txt

From: Gerhard Muenz <[email-masked]>
Date: Tue, 05 Apr 2011 12:38:52 +0200

Hi Jürgen,

 Some time ago, the future of PSAMP MIB was uncertain. So, we decided to 
 removed most of the references to PSAMP MIB.

 Now, as PSAMP MIB seems to be completed before (or at the same time as) 
 IPFIX-CONFIG, it would make sense to add references to those objects in 
 the SELECTOR MIB which have the same meaning as parameters in the 
 configuration model. We have done the same for those parameters which 
 also appear in IPFIX MIB.

 Note that this would not cause any change in the model since it already 
 is inline with PSAMP MIB. It just means adding some references in the 
 text and in the YANG module definition.
 Therefore, I suggest to continue with the AD evaluation and add such 
 references in a next revision of the draft.

 Regards,
 Gerhard

 On Thu, 10 Mar 2011 10:07:14 +0100, Gerhard Muenz wrote:
> Hi Jürgen,
>
> I will not be in Prague. So, from my side, there is no need to
> discuss the yang module there.
>
> We could wait for a brief feedback from the yang doctors. Otherwise,
> the draft is ready for publication.
>
> Regards,
> Gerhard
>
> On Thu, 10 Mar 2011 03:15:49 +0000, Juergen Quittek wrote:
>> Hi Gerhard,
>>
>> Do you consider this draft ready for requesting publication?
>> Or would it be better to discuss the YANG module at Prague?
>>
>> Thanks,
>>
>>     Juergen
>>
>>
>> Am 09.03.11 17:30 schrieb "Gerhard Muenz" unter 
>> <[email-masked]>:
>>
>>>
>>>  Dear all,
>>>
>>>  I have submitted a new version of the configuration draft which
>>>  addresses the comments made by Lada and Mehmet/Bernd during the 
>>> second
>>>  WGLC. Thanks again for your valuable feedback.
>>>
>>>  There was some concern about the size of the yang module. The
>>>  configuration could be split into Exporter and Collector 
>>> configuration,
>>>  or even into OP/MP, EP, and CP configuration. However, if I 
>>> understand
>>>  correctly, references (leafrefs) across yang modules are only 
>>> possible
>>>  if the source module imports the destination module. Hence, as MP 
>>> refers
>>>  to EP, the MP module would need to import the EP module. Similary, 
>>> the
>>>  CP module would need to import the EP module as well. In addition, 
>>> all
>>>  modules would need to import one module with common type 
>>> definitions.
>>>
>>>  All in all, it seems that we would not gain much by splitting the
>>>  module. So, the current draft still contains a single yang module.
>>>
>>>  Kind regards,
>>>  Gerhard
>>>
>>>  -------- Original Message --------
>>>  Subject: [IPFIX] I-D 
>>> Action:draft-ietf-ipfix-configuration-model-09.txt
>>>  Date: Wed, 09 Mar 2011 02:15:02 -0800
>>>  From: [email-masked]
>>>  To: [email-masked]
>>>  Cc: [email-masked]
>>>
>>>  A New Internet-Draft is available from the on-line Internet-Drafts
>>>  directories.
>>>  This draft is a work item of the IP Flow Information Export 
>>> Working
>>>  Group of the IETF.
>>>
>>>
>>> Title           : Configuration Data Model for IPFIX and PSAMP
>>> Author(s)       : G. Muenz, et al.
>>> Filename        : draft-ietf-ipfix-configuration-model-09.txt
>>> Pages           : 124
>>> Date            : 2011-03-09
>>>
>>>  This document specifies a data model for configuring and 
>>> monitoring
>>>  Selection Processes, Caches, Exporting Processes, and Collecting
>>>  Processes of IPFIX and PSAMP compliant Monitoring Devices using 
>>> the
>>>  NETCONF protocol [RFC4741].  The data model is defined using UML
>>>  (Unified Modeling Language) class diagrams and formally specified
>>>  using YANG [RFC6020].  The configuration data is encoded in
>>>  Extensible Markup Language (XML).
>>>
>>>  A URL for this Internet-Draft is:
>>>
>>>
>> 
>> http://www.ietf.org/internet-drafts/draft-ietf-ipfix-configuration-model-09.tx>
>> t
>>>
>>>  Internet-Drafts are also available by anonymous FTP at:
>>>  ftp://ftp.ietf.org/internet-drafts/
>>>
>>>  Below is the data which will enable a MIME compliant mail reader
>>>  implementation to automatically retrieve the ASCII version of the
>>>  Internet-Draft.
>>>
>>> _______________________________________________
>>> IPFIX mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/ipfix
>
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix

---

From: Juergen Quittek <[email-masked]>
Date: Mon, 11 Apr 2011 06:17:58 +0000

Hi Gerhard,

Yes, please go on as you suggested.

Thanks,

    Juergen

Am 05.04.11 12:38 schrieb "Gerhard Muenz" unter <[email-masked]>:

Hi Jürgen, Some time ago, the future of PSAMP MIB was uncertain. So, we decided to removed most of the references to PSAMP MIB. Now, as PSAMP MIB seems to be completed before (or at the same time as) IPFIX-CONFIG, it would make sense to add references to those objects in the SELECTOR MIB which have the same meaning as parameters in the configuration model. We have done the same for those parameters which also appear in IPFIX MIB. Note that this would not cause any change in the model since it already is inline with PSAMP MIB. It just means adding some references in the text and in the YANG module definition. Therefore, I suggest to continue with the AD evaluation and add such references in a next revision of the draft. Regards, Gerhard On Thu, 10 Mar 2011 10:07:14 +0100, Gerhard Muenz wrote: > Hi Jürgen, > > I will not be in Prague. So, from my side, there is no need to > discuss the yang module there. > > We could wait for a brief feedback from the yang doctors. Otherwise, > the draft is ready for publication. > > Regards, > Gerhard > > On Thu, 10 Mar 2011 03:15:49 +0000, Juergen Quittek wrote: >> Hi Gerhard, >> >> Do you consider this draft ready for requesting publication? >> Or would it be better to discuss the YANG module at Prague? >> >> Thanks, >> >>     Juergen >> >> >> Am 09.03.11 17:30 schrieb "Gerhard Muenz" unter >> <[email-masked]>: >> >>> >>>  Dear all, >>> >>>  I have submitted a new version of the configuration draft which >>>  addresses the comments made by Lada and Mehmet/Bernd during the >>> second >>>  WGLC. Thanks again for your valuable feedback. >>> >>>  There was some concern about the size of the yang module. The >>>  configuration could be split into Exporter and Collector >>> configuration, >>>  or even into OP/MP, EP, and CP configuration. However, if I >>> understand >>>  correctly, references (leafrefs) across yang modules are only >>> possible >>>  if the source module imports the destination module. Hence, as MP >>> refers >>>  to EP, the MP module would need to import the EP module. Similary, >>> the >>>  CP module would need to import the EP module as well. In addition, >>> all >>>  modules would need to import one module with common type >>> definitions. >>> >>>  All in all, it seems that we would not gain much by splitting the >>>  module. So, the current draft still contains a single yang module. >>> >>>  Kind regards, >>>  Gerhard >>> >>>  -------- Original Message -------- >>>  Subject: [IPFIX] I-D >>> Action:draft-ietf-ipfix-configuration-model-09.txt >>>  Date: Wed, 09 Mar 2011 02:15:02 -0800 >>>  From: [email-masked] >>>  To: [email-masked] >>>  Cc: [email-masked] >>> >>>  A New Internet-Draft is available from the on-line Internet-Drafts >>>  directories. >>>  This draft is a work item of the IP Flow Information Export >>> Working >>>  Group of the IETF. >>> >>> >>> Title           : Configuration Data Model for IPFIX and PSAMP >>> Author(s)       : G. Muenz, et al. >>> Filename        : draft-ietf-ipfix-configuration-model-09.txt >>> Pages           : 124 >>> Date            : 2011-03-09 >>> >>>  This document specifies a data model for configuring and >>> monitoring >>>  Selection Processes, Caches, Exporting Processes, and Collecting >>>  Processes of IPFIX and PSAMP compliant Monitoring Devices using >>> the >>>  NETCONF protocol [RFC4741].  The data model is defined using UML >>>  (Unified Modeling Language) class diagrams and formally specified >>>  using YANG [RFC6020].  The configuration data is encoded in >>>  Extensible Markup Language (XML). >>> >>>  A URL for this Internet-Draft is: >>> >>> >> >> http://www.ietf.org/internet-drafts/draft-ietf-ipfix-configuration-model-09.tx> >> t >>> >>>  Internet-Drafts are also available by anonymous FTP at: >>>  ftp://ftp.ietf.org/internet-drafts/ >>> >>>  Below is the data which will enable a MIME compliant mail reader >>>  implementation to automatically retrieve the ASCII version of the >>>  Internet-Draft. >>> >>> _______________________________________________ >>> IPFIX mailing list >>> [email-masked] >>> https://www.ietf.org/mailman/listinfo/ipfix > > _______________________________________________ > IPFIX mailing list > [email-masked] > https://www.ietf.org/mailman/listinfo/ipfix _______________________________________________ IPFIX mailing list [email-masked] https://www.ietf.org/mailman/listinfo/ipfix