Subject: Re: [IPFIX] RFC 5101bis - UDP checksum

From: Brian Trammell <[email-masked]>
Date: Fri, 3 Feb 2012 18:44:51 +0100

Hi, Paul,

This seems reasonable, and I see no problem at all with adding it, but I'm not really sure if there's a win... A couple of comments on that point.

First, practically, I'm not aware of a UDP stack that doesn't do checksums by default (though I have limited experience with embedded systems and none at all on routers), so I would assume an implementor would have to go out of their way to switch UDP checksum calculation off. 

Second, given all the various (unavoidable) issues with respect to IPFIX over UDP (mainly related to template management) which would seem to have occurrence probabilities on the order of magnitude of that of a transmission error that would be caught by the UDP checksum (at least over MAC layers with which I have experience), it's not clear why we'd want to say, hey, you can use UDP if you can't afford anything else, but you can't make it a (very) little bit faster and a (very) little bit less reliable by dropping checksums.

Cheers,

Brian

On Jan 30, 2012, at 9:17 PM, Paul Aitken wrote:

> Dear all,
> 
> Per RFC 768 and RFC 1122, UDP checksums are not mandatory.
> 
> Since the IPv4 checksum is only calculated over the header (not the data) and there is no IPv6 checksum, 5101bis should include a line recommending that UDP checksums are enabled when exporting over UDP.
> 
> P.
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix

---

From: Paul Aitken <[email-masked]>
Date: Fri, 03 Feb 2012 21:04:47 +0000

Brian,

The reason for mentioning it is that someone contacted us last week with 
a proposal not to checksum UDP.

So it'd be great to cover this in an RFC in case it comes up again.

P.