Subject: [IPFIX] I-D Action: draft-ietf-ipfix-protocol-rfc5101bis-01.txt

From: [email-masked]
Date: Wed, 07 Mar 2012 23:28:11 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the IP Flow Information Export Working Group of the IETF.

	Title           : Specification of the IP Flow Information eXport (IPFIX) Protocol for the Exchange of Flow Information
	Author(s)       : Benoit Claise
                          Brian Trammell
	Filename        : draft-ietf-ipfix-protocol-rfc5101bis-01.txt
	Pages           : 66
	Date            : 2012-03-07

   This document specifies the IP Flow Information Export (IPFIX)
   protocol that serves for transmitting Traffic Flow information over
   the network.  In order to transmit Traffic Flow information from an
   Exporting Process to an information Collecting Process, a common
   representation of flow data and a standard means of communicating
   them is required.  This document describes how the IPFIX Data and
   Template Records are carried over a number of transport protocols
   from an IPFIX Exporting Process to an IPFIX Collecting Process.  This
   document obsoletes RFC 5101.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ipfix-protocol-rfc5101bis-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-ipfix-protocol-rfc5101bis-01.txt

---

From: Brian Trammell <[email-masked]>
Date: Thu, 8 Mar 2012 09:11:02 +0100

Greetings, all,

Revision -01 of rfc5101bis has been posted, encompassing commentary to date on the draft. The biggest changes are the reorganization of Sections 8, 9, and 10 to improve readability by:

1. moving all Template management considerations into section 8 (as template management is the most complex part of the protocol);

2. identifying Template management and Collecting Process considerations common to all transports; and

3. aligning the structure of the transport-specific considerations sections.

Additionally:

References to the IP-ness of packets have been removed where not necessary.

RFC6520 (DTLS heartbeat) now SHOULD be used for long-lived sessions.

Given the impracticality of signaling receiver error in a fundamentally unidirectional protocol, situations where the CP MUST drop an association in 5101 have been changed to MUST ignore SHOULD log in 5101bis; this goes along with the relaxation of template management restrictions in the -00 revision.

Full diffs can be read at http://tools.ietf.org/rfcdiff?url2=draft-ietf-ipfix-protocol-rfc5101bis-01.

The big remaining open issue would appear to be that we need to interop several features which have never been interop'd; I presume this would be a point of discussion at the WG meeting in Paris.

Best regards,

Brian

Begin forwarded message:

> From: [email-masked]
> Subject: [IPFIX] I-D Action: draft-ietf-ipfix-protocol-rfc5101bis-01.txt
> Date: March 8, 2012 8:28:11 AM GMT+01:00
> To: [email-masked]
> Cc: [email-masked]
> 
> 
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix