Subject: [IPFIX] RFC5102bis vs http://www.iana.org/assignments/ipfix.xml

From: Brian Trammell <[email-masked]>
Date: Fri, 6 Jul 2012 11:05:49 +0200

Greetings, all,

In editing rfc5101bis and rfc5102bis, I've noticed that both of these documents carry over the basic assumption that RFC5102 (-bis) is the normative reference for the IPFIX Information Element Registry. Indeed, there have been a few conversations on this list that I read as, in part, being caused by confusion by implementors or potential implementors about which reference is canonical.

From discussions over time, I believe the intention of the WG is that the IANA registry be normative; I've already edited the working copy of rfc5102bis-03 to reflect this, and to point people at the IANA registry. 

This in itself raises a procedural question: can an IANA registry be normative?

Second, almost everywhere in 5101 (and therefore 5101bis), readers are pointed to 5102 (5102bis) as a reference for any specific Information Element or Information Elements as a whole. I believe that these references (where the target of the reference is an IE definition, and not the definition of the information model itself) should be changed to point to the registry instead. But this raises the procedural question above, again.

Thoughts? Can we do this? Or should be keep referring to 5102bis, and hope that people will follow the references down to IANA?

Many thanks, best regards,

Brian

---

From: Paul Aitken <[email-masked]>
Date: Fri, 06 Jul 2012 16:22:48 +0100

Brian,

I agree that the IANA registry needs to be normative, and the IPFIX docs 
should point there.

I've requested around 70 new Information Elements from IANA - and more 
every week - which simply aren't listed anywhere else.

We should not refer to 5102 as the master reference unless we plan to 
update it on a regular basis.

Let's look at how other WGs with IANA registries have addressed this.

P.

On 06/07/12 10:05, Brian Trammell wrote:
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix