Subject: [IPFIX] "ID" in Information Element names

From: Paul Aitken <[email-masked]>
Date: Tue, 23 Oct 2012 13:25:21 +0100

I've just been looking at how inconsistently "ID" and "Id" are used for 
IE names.

Since the bulk of the existing names are "...Id", can we assume that the 
following are all good:

vlanId
postVlanId
classificationEngineId
commonPropertiesId
observationPointId
lineCardId
portId
meteringProcessId
exportingProcessId
templateId
wlanChannelId
flowId
observationDomainId
dot1qVlanId
dot1qCustomerVlanId
metroEvcId
pseudoWireId
postDot1qVlanId
postDot1qCustomerVlanId
exportSctpStreamId
connectionTransactionId
selectionSequenceId
selectorId
informationElementId
virtualStationInterfaceId
layer2SegmentId

And that the following should change? :

applicationID -> applicationId
natPoolID     -> natPoolId

Finally, I'm not sure about the following:

wlanSSID           -> "SSID"seems to be an established term.
ingressVRFID       -> should it be "VRFId" ?
egressVRFID        -> should it be "VRFId" ?
virtualStationUUID ->should it be "UUId" ?

Feedback?

Thanks,
P.

---

From: Brian Trammell <[email-masked]>
Date: Tue, 23 Oct 2012 14:43:42 +0200

Hi, Paul,

UUID is an established term too, no? So we should keep that as is.

Not sure about VRF.

I'd rename applicationId and natPoolId.

Cheers,

Brian

On Oct 23, 2012, at 2:25 PM, Paul Aitken <[email-masked]> wrote:

> I've just been looking at how inconsistently "ID" and "Id" are used for IE names.
> 
> Since the bulk of the existing names are "...Id", can we assume that the following are all good:
> 
> vlanId
> postVlanId
> classificationEngineId
> commonPropertiesId
> observationPointId
> lineCardId
> portId
> meteringProcessId
> exportingProcessId
> templateId
> wlanChannelId
> flowId
> observationDomainId
> dot1qVlanId
> dot1qCustomerVlanId
> metroEvcId
> pseudoWireId
> postDot1qVlanId
> postDot1qCustomerVlanId
> exportSctpStreamId
> connectionTransactionId
> selectionSequenceId
> selectorId
> informationElementId
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix

---

From: Andrew Feren <[email-masked]>
Date: Tue, 23 Oct 2012 09:30:04 -0400

Hi Paul and Brian,

I agree on renaming applicationId and natPoolId and keeping UUID.

My personal bias is to also keep VRFID, but I can't claim any evidence 
that is an established term.  I just prefer to keep it upper case, but I 
won't object either way.

-Andrew

---

From: Paul Aitken <[email-masked]>
Date: Tue, 23 Oct 2012 14:51:01 +0100

Thanks Brian and Andrew.

I've asked IANA to rename "applicationId" and "natPoolId" for 
consistency with the other fields.

I'll leave wlanSSID, ingressVRFID, egressVRFID, and virtualStationUUID 
unchanged.

P.

On 23/10/12 14:30, Andrew Feren wrote:
> that is an established term.  I just prefer to keep it upper case, but 
> I won't object either way.
>
> -Andrew
>
>