Subject: [IPFIX] DRAFT minutes of IPFIX meting at IETF 85

From: Nevil Brownlee <[email-masked]>
Date: Sat, 10 Nov 2012 05:20:53 +1300

Hi all:

The DRAFT minutes are available at
   http://www.ietf.org/proceedings/85/minutes/minutes-85-ipfix

Please have a look; if you were at the meeting and feel that
changes or corrections are needed, please email them to me.

Cheers, Nevil

-- 
---------------------------------------------------------------------
  Nevil Brownlee                    Computer Science Department | ITS
  Phone: +64 9 373 7599 x88941             The University of Auckland
  FAX: +64 9 373 7453   Private Bag 92019, Auckland 1142, New Zealand

---

From: Nevil Brownlee <[email-masked]>
Date: Sat, 10 Nov 2012 06:27:42 +1300

On 10/11/12 05:43, Andrew Feren wrote:
> Those don't look like the IPFIX minutes.
>
> -Andrew

Hi Andrew:

Nicely spotted, thanks very much!

I've submitted the correct file to the meeting materials manager,
but it takes quite a while for it to update.

Meantime, here are the DRAFT minutes ...

DRAFT-00 Minutes of the IPFIX meeting at IETF 85 in Atlanta
About 22 people present
Scribes: Chris Inacio, Nevil Brownlee
Meeting chair: Juergen Quittek, Nevil Brownlee

Juergen opened the meeting, Nevil gave the IPFIX status update:
  - Flow Selection draft is in AD Review, progressing
  - IE-Doctors in AD Followup: in response to DISCUSS, IANA Actions
    will be moved to 5102bis, IE-Doctors will need normative
    reference to it
  - Aggregation draft: on IESG telechat agenda, will need a new
    revision before going to RFC Editor
  - No work done on Mediation-Protocol since IETF 84, expect
    some progress by IETF 86 (Orlando)

Brian presented our 5101bis and 5102bis drafts
- Benoit Claise commented that IPR needs to be re-asserted in
   bis documents, Cisco legal will do that for these two
- 5102 (IPFIX Information Model)
   - WGLC ran from 14 to 22 October, lots of comments
   - Section 5, Information element Categories, is no longer
     needed, proposedto replace it with stub pointing to IANA
     registry
   - Benoit suggests a summary/history as well as that pointer,
     including text about categories of IEs, so that 5102 remains
     a complete description of our model
   - Meeting agreed to this, to be done in next revision
- 5101 (IPFIX Protocol)
   - No updates since IETF 84, authors working on next revision
   - AD comment: we don't have to interop all features of
     protocol to advance standards level
   - List comment about byte ordering, Brian will add a reference
     for that
   - WGLC to start when document is stable

Paul Aitken presented (via Meetecho) the Link Layer IEs draft.
- WGLC for this started 15 Oct 12; it will end after next week's
   (bi-monthly) IEEE 802.3 meeting
- Juergen commented that the draft has a VXLAN I-D as an
   Informative Reference
- Brian pointed out that several IPFIX IEs cover VLANs, we
   need to check that the proposed VXLAN IEs will not cause
   interoperation with them
- Paul will find a VLAN-tag expert to check that
- Will need a new revision, when that's stable Nevil will
   submit to IESG

Paul presented the MIB Variable Export draft
- Most issues have now been resolved
- 'Extended Field Specifiers' introduced as a good way to
   represent OIDs in an IPFIX template.  Clear agreement
   in the room on this
- Field Lengths in the EFS were discussed.  Brian asked
   how variable-length fields would be handled?
- New version needed, WGLC when draft is stable

Paul presented two new individual drafts
- IE Equivalence
   - Addresses question "how does a collector know that a
     Private IE is equivalent to an IANA IE?"
   - Four possible methods explored, Paul proposes exporting
     an 'equivalence table'
   - How long does an exporter need to keep sending the table?
   - Benoit suggests using URIs instead, as Chris proposed
     at IETF 84.  Brian wants to see Chris' draft about that
     completed first
- Recent IANA IE Registry Changes
   - Summarises changes to the registry over about the last
     18 months; this is a useful document
   - Brian pointed out that IE 353 should have an upper-case
     O in 'octets'
   - Benoit asked whether these changes meet the guidelines
     set out in IE-Doctors?
   - A general review of IE semantics would be 'a good thing'
   - Nevil will ask for volunteers on the list

Any Other Business discussions
- IPFIX Milestones
   - Exporting MIB Objects and Mediation Protocol
     changed to July 2013
   - Aim for Mediation Protocol WGLC in April 2013
- Interop
   - Interop testing is useful whether or not we need it
     to advance standards level
   - Brian's Open Source implementation (ripfix) is now
     available, he will post instructions on how to use it
     to the list
  - IPFIX work in other WGs
    - Benoit reported on RADIUS Accounting draft
    - Brian commented that ALTO have a new draft that describes
      exporting values as text strings; he would like others
      to read it and comment on the IPFIX list

The meeting finished at 1435

Cheers again, Nevil

> On 11/09/2012 11:20 AM, Nevil Brownlee wrote:
>>
>> Hi all:
>>

---

From: Nevil Brownlee <[email-masked]>
Date: Fri, 23 Nov 2012 10:34:28 +1300

Hi Paul:

Thanks for pointing that out, I'll change the line in the minutes
to say "Will probably need a new revision."

Please wait for the feedback from IEEE 802, when we have that
(you'll have seen Benoit's emails about it, we're pushing for
feedback by 30 November) please publish a new revision with all
the changes you've listed, plus any prompted by the IEEE feedback.

Cheers, Nevil

On 10/11/12 10:29 AM, Paul Aitken wrote:
> Nevil, All,
> I don't recall that. Why is a new version needed?
>
> The only issues I can see are the IE names, per Brian's feedback at the
> mic (ie, uppercase "Octet").
>
> Also for consistency with existing IEs (layer2SegmentId,
> layer2OctetDeltaCount, layer2octetTotalCount), the "l2" (that's
> "el-two") names should be "layer2".
>
> So:
>
>     |TBD09| l2octetDeltaCount          -> layer2OctetDeltaCount
> -> already exists (352)
>     |TBD10| postMCastL2OctetDeltaCount -> postMCastLayer2OctetDeltaCount
>     |TBD11| postL2OctetDeltaCount      -> postLayer2OctetDeltaCount
>     |TBD12| minimumL2TotalLength       -> minimumLayer2TotalLength
>     |TBD13| maximumL2TotalLength       -> maximumLayer2TotalLength
>     |TBD14| l2octetTotalCount          -> layer2octetTotalCount
> -> already exists (353)
>     |TBD15| droppedL2OctetDeltaCount   -> droppedLayer2OctetDeltaCount
>     |TBD16| droppedL2OctetTotalCount   -> droppedLayer2OctetTotalCount
>     |TBD17| ignoredL2OctetTotalCount   -> ignoredLayer2OctetTotalCount
>     |TBD18| notSentL2OctetTotalCount   -> notSentLayer2OctetTotalCount
>     |TBD19| postL2OctetTotalCount      -> postLayer2OctetTotalCount
>     |TBD20| postMCastL2OctetTotalCount -> postMCastLayer2OctetTotalCount
>     |TBD21| l2octetDeltaSumOfSquares   -> layer2OctetDeltaSumOfSquares
>     |TBD22| l2octetTotalSumOfSquares   -> layer2OctetTotalSumOfSquares
>
>
> Hmm, nobody noticed...
>
> Shall I quickly make a new version with those changes?
>
> Or, shall I wait for IEEE feedback?
>
> Or, simply save those changes for AUTH48?
>
>
> Thanks,
> P.
>

---

From: Paul Aitken <[email-masked]>
Date: Thu, 22 Nov 2012 21:37:20 +0000

Nevil,

Per Benoit's earlier email, I'll wait until after Nov 30th for any IEEE 
feedback before producing the (hopefully) final version.

P.