Subject: [IPFIX] RFC 3550 jitter

From: Paul Aitken <[email-masked]>
Date: Wed, 28 Nov 2012 15:25:38 +0000

Dear IPFIX experts,

I'd like to request an IPFIX IE for jitter from IANA. RFC 3550 defines a 
suitable "interarrival jitter". Unfortunately it's measured in 
"timestamp units":

       An estimate of the statistical variance of the RTP data packet
       interarrival time, measured in timestamp units and expressed as an
       unsigned integer.

Therefore it seems we may need multiple IEs: one for units of 
milliseconds, one for microseconds, one for nanoseconds...
Else comparison of two jitter values would be meaningless.

So I request your feedback on the following:

Name: interarrivalJitterMilliseconds
Type: unsigned32
Semantic: quantity
Description: interarrival jitter as defined in section 6.4.1 of RFC 
3550, measured in milliseconds.
Units: milliseconds
References: [RFC3550]

Name: interarrivalJitterMicroseconds
Type: unsigned32
Semantic: quantity
Description: interarrival jitter as defined in section 6.4.1 of RFC 
3550, measured in microseconds.
Units: microseconds
References: [RFC3550]

Name: interarrivalJitterNanoseconds
Type: unsigned32
Semantic: quantity
Description: interarrival jitter as defined in section 6.4.1 of RFC 
3550, measured in nanoseconds.
Units: nanoseconds
References: [RFC3550]

Thanks,
P.

---

From: Paul Aitken <[email-masked]>
Date: Wed, 28 Nov 2012 17:30:55 +0000

Dear all,

I received feedback that the name should include "mean" and 'rfc3550', 
since there are other jitter metrics which take into account all samples 
rather than running average based last 16 samples as done by RFC3550.

So the proposed names could be rfc3550JitterMeanMilliseconds, 
rfc3550JitterMeanMicroseconds, and rfc3550JitterMeanNanoseconds.

P.

On 28/11/12 15:25, Paul Aitken wrote:
> Dear IPFIX experts,
>
> I'd like to request an IPFIX IE for jitter from IANA. RFC 3550 defines 
> a suitable "interarrival jitter". Unfortunately it's measured in 
> "timestamp units":
>
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix