Subject: Re: [IPFIX] Feedback: regarding draft-ietf-ipfix-mediation-protocol

From: Benoit Claise <[email-masked]>
Date: Mon, 15 Apr 2013 11:47:15 +0200

Hi Rahul,

Addressing a specific point below.
> Hi Rahul,
>
> Thanks for your review.
> See in line.
>>
>>
>> Few comments.
>>
>>  1. Page 8:
>>      1. The difference between "Intermediate Selection Process" and
>>         "Intermediate Flow Selection Process" is not clear. Is the
>>         first one selecting record purely on matching content (value
>>         of the fields) in the record and the second one selecting on
>>         matching attributes of the fields that are not part of the
>>         record in *addition* to matching content in the record? An
>>         example would help here.
>>
> Granted, this is difficult to understand from the definitions only. 
> There is some history behind these two separate definitions. Anyway, 
> you get it right from your message above.
> I was thinking to add to a section 2.1 "Differences between 
> Intermediate Selection Process and Intermediate Flow Selection 
> Process" in the draft-ietf-ipfix-mediation-protocol draft. However, 
> thinking about it some more, this section should really be done in 
> draft-ietf-ipfix-flow-selection-tech-14, to avoid some more confusion.
> There is already section 3. "Difference between Intermediate Flow 
> Selection Process and Packet Selection". Some more text should be 
> added on the difference between Intermediate Selection Process and 
> Intermediate Flow Selection Process
>
> When created, draft-ietf-ipfix-mediation-protocol will refer to that 
> new section.
The new section has been added.
Please refer to 
http://tools.ietf.org/html/draft-ietf-ipfix-flow-selection-tech-15#section-4, 
and tell us if this is clear
If it's easier, have a look at the diffs.

Regards, Benoit

---

From: "Rahul Patel (rahulp)" <[email-masked]>
Date: Mon, 15 Apr 2013 17:08:53 +0000

Hi Benoit,

It is very clear, looks good.

-Rahul

From: "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, April 15, 2013 1:47 AM
To: Cisco Employee <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [IPFIX] Feedback: regarding draft-ietf-ipfix-mediation-protocol

Hi Rahul,

Thanks for your review.
See in line.

Few comments.

  1.  Page 8:
     *   The difference between "Intermediate Selection Process" and "Intermediate Flow Selection Process" is not clear. Is the first one selecting record purely on matching content (value of the fields) in the record and the second one selecting on matching attributes of the fields that are not part of the record in *addition* to matching content in the record? An example would help here.

Granted, this is difficult to understand from the definitions only. There is some history behind these two separate definitions. Anyway, you get it right from your message above.
I was thinking to add to a section 2.1 "Differences between Intermediate Selection Process and Intermediate Flow Selection Process" in the draft-ietf-ipfix-mediation-protocol draft. However, thinking about it some more, this section should really be done in draft-ietf-ipfix-flow-selection-tech-14, to avoid some more confusion.
There is already section 3. "Difference between Intermediate Flow Selection Process and Packet Selection". Some more text should be added on the difference between Intermediate Selection Process and Intermediate Flow Selection Process

When created, draft-ietf-ipfix-mediation-protocol will refer to that new section.
The new section has been added.
Please refer to http://tools.ietf.org/html/draft-ietf-ipfix-flow-selection-tech-15#section-4, and tell us if this is clear
If it's easier, have a look at the diffs.

Regards, Benoit