Subject: [IPFIX] BBF WT-352

From: Marta Seda <[email-masked]>
Date: Sun, 15 Jan 2017 21:18:14 +0000

Hello,

I am the editor of Broadband Forum WT-352 Inter-Channel Termination Protocol (ICTP) for NGPON2 (Next Generation Passive Optical Networks) protocol.  We have been discussing in WT-352 the use of IPFIX as a unicast stream protocol for transporting the following data elements across NGPON2 Channel Terminations (CTs):

*       dhcp leases

*       pppoe session information

*       Igmp data (e.g., channel, uptime, etc)

*       ARP data

*       OMCI ME instance (optional)

Any bidirectional TLVs are transported using ICTP (not IPFIX).

We are proposing to reuse some IANA TLVs for WT-352 (rather than re-inventing new ones) and BBF introduce new TLVs not covered by IANA (e.g., NGPON2 specific TLVs).  WT-352 needs these TLVs to be defined for the purpose of interoperability among NGPON2 vendors.

RFC 7013 provides guidance to authors interested in expanding IANA registry (for Flow applications) and the existence of IPFIX doctors.  RFC 7013 provides guidance for those interested in expanding IANA registries.  What I would like to understand is the following:

A)    Where can BBF pull the latest (or in progress) IPFIX IE?  I have been using: http://www.iana.org/assignments/ipfix/ipfix.xhtml (is this the most up to date registry)

B)     Would it be possible to have WT-352 proposed TLVs reviewed by IPFIX doctors (to verify there is no overlap in definitions).  Who could I contact with respect to this?

Regards,
Marta Seda

---

From: PJ Aitken <[email-masked]>
Date: Mon, 16 Jan 2017 21:38:52 +0000

Marta, it's good to hear that you're thinking of using some IPFIX 
Information Elements.

The latest IPFIX elements are in IANA's registry.

You can contact [email-masked] to discuss and review new proposals. 
The formal request for new elements is usually made either in an RFC or 
through a request to IANA.

P.

On 15/01/17 21:18, Marta Seda wrote:
>
> Hello,
>
> I am the editor of Broadband Forum WT-352 Inter-Channel Termination 
> Protocol (ICTP) for NGPON2 (Next Generation Passive Optical Networks) 
> protocol.  We have been discussing in WT-352 the use of IPFIX as a 
> unicast stream protocol for transporting the following data elements 
> across NGPON2 Channel Terminations (CTs):
>
> ·dhcp leases
>
> ·pppoe session information
>
> ·Igmp data (e.g., channel, uptime, etc)
>
> ·ARP data
>
> ·OMCI ME instance (optional)
>
> We are proposing to reuse some IANA TLVs for WT-352 (rather than 
> re-inventing new ones) and BBF introduce new TLVs not covered by IANA 
> (e.g., NGPON2 specific TLVs).  WT-352 needs these TLVs to be defined 
> for the purpose of interoperability among NGPON2 vendors.
>
> RFC 7013 provides guidance to authors interested in expanding IANA 
> registry (for Flow applications) and the existence of IPFIX doctors. 
> RFC 7013 provides guidance for those interested in expanding IANA 
> registries.  What I would like to understand is the following:
>
> A)Where can BBF pull the latest (or in progress) IPFIX IE?  I have 
> been using: http://www.iana.org/assignments/ipfix/ipfix.xhtml 
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.iana.org_assignments_ipfix_ipfix.xhtml&d=DwMFAg&c=IL_XqQWOjubgfqINi2jTzg&r=Xx9729xYDYoCgBDdcp1FKt5PyYd1TCoXNKhyPY8CFp8&m=bDtxxCIPW_T3jeiYOQCvkKo800_8HuyXUPQHGVom_6E&s=2VPV6V0iOc6sir2gtzZxjFfUZUnFnDatfeUfeEppBm4&e=> 
> (is this the most up to date registry)
>
> B)Would it be possible to have WT-352 proposed TLVs reviewed by IPFIX 
> doctors (to verify there is no overlap in definitions).  Who could I 
> contact with respect to this?
>
> Regards,
>
> Marta Seda
>
>
>
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ipfix&d=DwICAg&c=IL_XqQWOjubgfqINi2jTzg&r=Xx9729xYDYoCgBDdcp1FKt5PyYd1TCoXNKhyPY8CFp8&m=bDtxxCIPW_T3jeiYOQCvkKo800_8HuyXUPQHGVom_6E&s=vf4XRV9bB7AyXYDckfsLCtJ5IpdRwD9wtGKGbdqcWjk&e=

---

From: Marta Seda <[email-masked]>
Date: Wed, 25 Jan 2017 20:15:50 +0000

Thank you - P.  I am including others at BBF in clarifications we need in WT-352.

I would like clarification on the following IANA Informational Elements:

1)     minFlowStartSeconds:  The earliest absolute timestamp of the first packet within any Flow within the scope containing this Information Element, rounded down to the second if necessary. This Information Element SHOULD be bound to its containing IPFIX Transport Session via an options record and the sessionScope Information Element.

Q:  Is this informational element specific to netflow?  Could it be re-purposed for other purposes (e.g., the length of time a PPPoE session started)?  (if not supported in IANA,  BBF can create one for WT-352 purposes)

2)     dot1qVlanId:  The value of the 12-bit VLAN Identifier portion of the Tag Control Information field of an Ethernet frame.  The structure and semantics within the Tag Control Information field are defined in [IEEE802.1Q

Q:  I guess this question is more about confirming this definition.  In WT-352, we need to be able to identify the S-tag and C-tag.  This definitions seems to point to the S-tag.  Is this the correct interpretation of the IANA IPFIX IE?

3)     dot1qCustomerVlanId: The value represents the Customer VLAN identifier in the Customer field as described

in IEEE802.1Q].

Q:  This definitions seems to point to the C-tag.  Is this the correct interpretation of the IANA IPFIX IE?

Appreciate your feedback.  Regards,

Marta
From: PJ Aitken [mailto:[email-masked]]
Sent: Monday, January 16, 2017 1:39 PM
To: Marta Seda <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [IPFIX] BBF WT-352

Marta, it's good to hear that you're thinking of using some IPFIX Information Elements.

You can contact [email-masked]<mailto:[email-masked]> to discuss and review new proposals. The formal request for new elements is usually made either in an RFC or through a request to IANA.

P.

*       dhcp leases

*       ARP data

A)    Where can BBF pull the latest (or in progress) IPFIX IE?  I have been using: http://www.iana.org/assignments/ipfix/ipfix.xhtml<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.iana.org_assignments_ipfix_ipfix.xhtml&d=DwMFAg&c=IL_XqQWOjubgfqINi2jTzg&r=Xx9729xYDYoCgBDdcp1FKt5PyYd1TCoXNKhyPY8CFp8&m=bDtxxCIPW_T3jeiYOQCvkKo800_8HuyXUPQHGVom_6E&s=2VPV6V0iOc6sir2gtzZxjFfUZUnFnDatfeUfeEppBm4&e=> (is this the most up to date registry)

Regards,
Marta Seda

IPFIX mailing list

[email-masked]<mailto:[email-masked]>