Subject: Re: [IPFIX] [GROW] [OPSAWG] WG adoption poll fordraft-li-opsawg-ipfix-bgp-community-02

From: PJ Aitken <[email-masked]>
Date: Thu, 16 Feb 2017 12:17:25 +0000

If the list would be longer than can be accommodated in a single IPFIX 
message, then some mechanism would need to be defined to allow the list 
to be exported.

Ideally this should be a generic mechanism allowing the export of any 
large IPFIX content. However, it might be simpler to define a mechanism 
that's specific to the export of long lists.

There may be several solutions. eg, it might be a compression mechanism 
allowing the content to fit into a single message. Or the content might 
be carried across multiple messages.

If you feel it's an issue - especially if it would block your current 
work - then please start the discussion in the OPSAWG because the IPFIX 
WG is closed.

Thanks,
P.

On 16/02/17 12:02, 李振强 wrote:
> The length of IPFIX message is sufficient for BGP standard 
> communities, since the length of standard community is 4 octets. But 
> the sizes of extended community, large community and wide community 
> are bigger than the size of standard community. If the working group 
> agrees to cover the above all kinds of communities in this draft, do 
> you think we should open the discussion for IPFIX and basicList 
> message splitting?

---

From: 李振强 <[email-masked]>
Date: Thu, 16 Feb 2017 20:02:40 +0800

Thank you P.J. Aitken.

The length of IPFIX message is sufficient for BGP standard communities, since the length of standard community is 4 octets. But the sizes of extended community, large community and wide community are bigger than the size of standard community. If the working group agrees to cover the above all kinds of communities in this draft, do you think we should open the discussion for IPFIX and basicList message splitting?

Sorry for the duplicate mails.

Best Regards
Zhenqiang Li

--发自139邮箱APP
点击下载使用，轻松管理邮箱pushemail.10086.cn/d/d.html(http://pushemail.10086.cn/d/d.html)

在2017-02-16 19:59:59
李振强<[email-masked]>写道:

发件人:PJ Aitken<[email-masked]>
日期:2017-02-16 19:16:00
收件人:[email-masked]<[email-masked]>, grow-bounces<[email-masked]>, zhoutianran<[email-masked]>
主题:Re: [IPFIX] [GROW] [OPSAWG] WG adoption poll fordraft-li-opsawg-ipfix-bgp-community-02

Ignas Bagdonas wrote:

>The upper limit may be reaching 16000 standard communities per prefix - would that fit into resulting IPFIX IE? If there is a limit, how does it work?

A quick calculation suggests that the maximum would be 16376 x 4-octet ASNs. See the figure below.

The constraining factor is the RFC7011 IPFIX Message Header "Length" field, since this is only 16 bits.

Splitting a list across multiple IPFIX messagesis a question which the IPFIX community hasn't discussed.Unfortunately the basicList "Semantic" field only defines the relationship among the different values within a single message; the relationship among values in different messages is not defined.

IPFIX Collectors might reasonably assume that information in subsequent messages supersedes information in earlier messages, so splitting a list across multiple messages would not have the desired effect.

0          1          2          3   0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+   |    Version Number     |    Length =65532|   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+   |              Export Time             |   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+   |            Sequence Number             |   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+   |          Observation Domain ID           |   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+   |     Set ID = 256     |     Length =65516|   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+   |   255   |   List Length =65509| semantic=allOf|   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+   |   bSCL FieldId = 459    |   bSCL Field Length=4   |   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+   |       bgpSourceCommunityList value 1 = x        |   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+   |       bgpSourceCommunityList value 2 = x        |   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+                  ...   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+   |       bgpSourceCommunityList value16376= x      |   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

P.

_______________________________________________
IPFIX mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipfix