Subject: Re: [IPFIX] Review of draft-irtf-nmrg-location-ipfix-07.txt

From: PJ Aitken <[email-masked]>
Date: Fri, 3 Mar 2017 10:42:41 +0000

Authors, has this document been reviewed by any IPFIX experts?

I see a request on November 23rd, but no reviews. So let me sign up for 
that.

First, I took a quick look at the Figures in Appendix B:

Figure 1: the Field Count should be 5, not 2.

Figure 2: the size of the optional Padding field is wrong: the figure 
shows 9 bits rather than 8.

Figure 4: the Length of 32 should be 28. The "geospatialLocationPosLat" 
Information Element isn't defined.

Figure 5: the Field Count of 2 should be 3.

Figure 7: The "geospatialLocationPostLng" and "geospatialLocationtLng" 
Information Elements aren't defined.

Figure 9: The sizes of the "CivicValue" data fields are not shown 
correctly. eg, "Inria Nancy-Grand Est" is depicted in 6 octets when it 
should contain 21. Therefore the Figure is misleading and difficult to 
understand; it is not a good example. Please redraw the figure 
correctly. Please mark the variable-lengths eg "vlen = 21".

Figure 11:
     The Set IDs (311, 312, 313) do not correspond to the Template IDs 
in Figure 10 (306, 307, 308).
     Again, the "Inria Nancy-Grand Grand Est" field is depicted in 6 
octets rather than the requisite 27. Without the repeated "Grand", the 
21 would be correct. Please write "vlen=21"
     The "Civic location Attr length" of 25 seems wrong.

This document is not ready for publication. Please post an updated 
version so I can check that all the IPFIX details are correct.

Thanks,
P.

---

From: Abdelkader Lahmadi <[email-masked]>
Date: Fri, 3 Mar 2017 12:01:59 +0100

Hello,
We haven’t really get a "proper review" of the document by IPFIX experts. Recently, we had a discussion with IANA and they asked IE-doctors to make a review, since that we received some points to be fixed regarding the proposed IE. I can forward to you the other comments from IE-doctors that we have received by IANA.

Thank you for your comments, Ok we will fix the raised issues in the document.
Best regards.

> On 03 Mar 2017, at 11:42, PJ Aitken <[email-masked]> wrote:
> 
> I see a request on November 23rd, but no reviews. So let me sign up for that.
> 
> 
> Figure 2: the size of the optional Padding field is wrong: the figure shows 9 bits rather than 8.
> 
> Figure 4: the Length of 32 should be 28. The "geospatialLocationPosLat" Information Element isn't defined.
> 
> Figure 7: The "geospatialLocationPostLng" and "geospatialLocationtLng" Information Elements aren't defined.
> 
> Figure 9: The sizes of the "CivicValue" data fields are not shown correctly. eg, "Inria Nancy-Grand Est" is depicted in 6 octets when it should contain 21. Therefore the Figure is misleading and difficult to understand; it is not a good example. Please redraw the figure correctly. Please mark the variable-lengths eg "vlen = 21".
> 
> Figure 11:
>    The Set IDs (311, 312, 313) do not correspond to the Template IDs in Figure 10 (306, 307, 308).
>    Again, the "Inria Nancy-Grand Grand Est" field is depicted in 6 octets rather than the requisite 27. Without the repeated "Grand", the 21 would be correct. Please write "vlen=21"
> This document is not ready for publication. Please post an updated version so I can check that all the IPFIX details are correct.
> 
> Thanks,
> P.

---

From: PJ Aitken <[email-masked]>
Date: Fri, 3 Mar 2017 11:07:22 +0000

Abdelkader, it was me who did the IE-doctors review. That's only 
concerned with the IANA request; it's not an IPFIX review of the document.

P.

---

From: Abdelkader Lahmadi <[email-masked]>
Date: Fri, 3 Mar 2017 12:17:56 +0100

Ok, more clear now.
So, we work on a new text to resolve ALL the raised issues and send you a version.

Best,
> On 03 Mar 2017, at 12:07, PJ Aitken <[email-masked]> wrote:
> 
> Abdelkader, it was me who did the IE-doctors review. That's only concerned with the IANA request; it's not an IPFIX review of the document.
> 
> P.
> 
> 
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix

---

From: PJ Aitken <[email-masked]>
Date: Fri, 3 Mar 2017 11:26:23 +0000

Great, thanks.

P.

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 3 Mar 2017 11:28:39 +0000

> So, we work on a new text to resolve ALL the raised issues and send you a version.

Hang on. Your RG chair should have explained how the process works.

This IRTF document is now being reviewed (per RFC5742) by the IESG. That review is *not* the same review that happens for IETF documents. Specifically, the IESG can really only say one of these five things:

>    1. The IESG has concluded that there is no conflict between this
>       document and IETF work.
> 
>    2. The IESG has concluded that this work is related to IETF work done
>       in WG <X>, but this relationship does not prevent publishing.
> 
>    3. The IESG has concluded that publication could potentially disrupt
>       the IETF work done in WG <X> and recommends not publishing the
>       document at this time.
> 
>    4. The IESG has concluded that this document violates IETF procedures
>       for <Y> and should therefore not be published without IETF review
>       and IESG approval.
> 
>    5. The IESG has concluded that this document extends an IETF protocol
>       in a way that requires IETF review and should therefore not be
>       published without IETF review and IESG approval.

At the moment, you are getting individual comments from IPFIX experts as part of the IANA review process of the registry actions your document wants to make happen. Those are very valuable (thank you!), but before you make any changes to the document, please wait until an Area Director says that the issues raised are at a significance where they will ask for an IESG response other than #1 or #2 above.

It sounds like this is likely going to be the case here, but please wait until the ADs have caught up on the discussion. And please wait with submitting a new revision until that happens as well.

Lars

---

From: Abdelkader Lahmadi <[email-masked]>
Date: Fri, 3 Mar 2017 13:16:15 +0100

Ok. That’s clear. Thank you.
> On 03 Mar 2017, at 12:28, Eggert, Lars <[email-masked]> wrote:
>

---

From: Abdelkader Lahmadi <[email-masked]>
Date: Wed, 29 Mar 2017 19:57:45 +0200

Dear Lars, and NMRG chairs,
How we can proceed now with the draft?

According to this: https://datatracker.ietf.org/doc/conflict-review-irtf-nmrg-location-ipfix/00/ <https://datatracker.ietf.org/doc/conflict-review-irtf-nmrg-location-ipfix/00/>, It seems that the draft is not in conflict with IETF work.
But, it seems that an IETF review and IESG approval are required for registering the location method tokens according to this:
https://datatracker.ietf.org/doc/conflict-review-irtf-nmrg-location-ipfix/ <https://datatracker.ietf.org/doc/conflict-review-irtf-nmrg-location-ipfix/>

I suppose that we can now update the draft with the IANA recommendation and also the review provided IPFIX expert (Paul).
Thank you.
Best regards.

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 29 Mar 2017 18:21:18 +0000

Hi,

Allison has taken over as chair, so this is a question for her. However:

> According to this: https://datatracker.ietf.org/doc/conflict-review-irtf-nmrg-location-ipfix/00/, It seems that the draft is not in conflict with IETF work.

The IESG has not yet concluded its review - that link at the moment captures the current status of individual ADs positions. They will send a formal response when their review has concluded.

> https://datatracker.ietf.org/doc/conflict-review-irtf-nmrg-location-ipfix/

All IANA actions coming from the IETF require IESG approval. Typically, that approval is implicit in a review that results in a document being publishable.

> I suppose that we can now update the draft with the IANA recommendation and also the review provided IPFIX expert (Paul).

I'd wait until the IESG review has concluded.

Lars

---

From: Abdelkader Lahmadi <[email-masked]>
Date: Wed, 29 Mar 2017 20:26:46 +0200

Thank you for the answers.
Best,

> On 29 Mar 2017, at 20:21, Eggert, Lars <[email-masked]> wrote:
> 
> Hi,
>

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 29 Mar 2017 18:28:27 +0000

Correction: My spy on the IESG informs me that you linked to an outdated version of the review; the current one being https://datatracker.ietf.org/doc/conflict-review-irtf-nmrg-location-ipfix/

The current review *does* call out a problem with the draft, but has not concluded yet.

Lars

> On 2017-3-29, at 13:21, Eggert, Lars <[email-masked]> wrote:
> 
> Hi,
>