Subject: OPS - I've posted the updated Set 1 IPP Ops spec for the bake-off

From: Tom Hastings <[email-masked]>
Date: Tue, 15 Sep 1998 11:58:57 PDT

I sent the updated spec to the bake-off attendees last week, but could not
copy to the ftp server until today.  We'd like to discuss at tommorrow's
(9/16/98) telecon if there are any remaining issues.

The same files as sent last week as attachements are now available in:

ftp://ftp.pwg.org/export/home/ftp/pub/pwg/ipp/new_OPS/draft-pwg-ipp-ops-set1
-00-980909.doc
ftp://ftp.pwg.org/export/home/ftp/pub/pwg/ipp/new_OPS/draft-pwg-ipp-ops-set1
-00-980909.pdf
ftp://ftp.pwg.org/export/home/ftp/pub/pwg/ipp/new_OPS/draft-pwg-ipp-ops-set1
-00-980909.txt
ftp://ftp.pwg.org/export/home/ftp/pub/pwg/ipp/new_OPS/draft-pwg-ipp-ops-set1
-00-980909-rev.doc
ftp://ftp.pwg.org/export/home/ftp/pub/pwg/ipp/new_OPS/draft-pwg-ipp-ops-set1
-00-980909-rev.pdf

on the Lexmark FTP server.  The files are:

-rw-rw-r--   1 pwg      staff      80896 Sep 15 13:15
draft-pwg-ipp-ops-set1-00-980909.doc
-rw-rw-r--   1 pwg      staff      35898 Sep 15 13:16
draft-pwg-ipp-ops-set1-00-980909.pdf
-rw-rw-r--   1 pwg      staff      36053 Sep 15 13:17
draft-pwg-ipp-ops-set1-00-980909.txt
-rw-rw-r--   1 pwg      staff      99840 Sep 15 13:18
draft-pwg-ipp-ops-set1-00-980909-rev.doc
-rw-rw-r--   1 pwg      staff      52045 Sep 15 13:18
draft-pwg-ipp-ops-set1-00-980909-rev.pdf

Here is the mail I sent last week to the bake-off attendees which describes
the
changes:

>X-Sender: hastings@garfield
>X-Mailer: QUALCOMM Windows Eudora Pro Version 3.0.5 (32)
>Date: Thu, 10 Sep 1998 16:58:24 -0700
>To: "Allen Waugerman (E-mail)" <[email-masked]>,
>        "Atsushi Uchino (E-mail)" <[email-masked]>,
>        "Babak Jahromi (E-mail)" <[email-masked]>,
>        "Bill Wagner (E-mail)" <[email-masked]>,
>        "Bis Guha (E-mail)"
<GUHA_BISWAROOP/[email-masked]>,
>        "Bob Herriot (E-mail)" <[email-masked]>,
>        "Brian R Glass (E-mail)" <[email-masked]>,
>        "Carl Kugler (E-mail)" <[email-masked]>,
>        "Carl-Uno Manros (E-mail)" <[email-masked]>,
>        "Daniel Fung (E-mail)" <[email-masked]>,
>        "Dave Stewart (E-mail)"
<STEWART_DAVE/[email-masked]>,
>        "David Kuntz (E-mail)" <[email-masked]>,
>        "Don Wright (E-mail)" <[email-masked]>,
>        "Harry Lewis (E-mail)" <[email-masked]>,
>        "Henrik Holst (E-mail)" <[email-masked]>,
>        "Hugo Parra (E-mail)" <[email-masked]>,
>        "Jeff Hancock (E-mail)" <[email-masked]>,
>        "Kris Schoff (E-mail)" <[email-masked]>,
>        "Maulik Desai (E-mail)" <[email-masked]>,
>        "Nick Webb (E-mail)" <[email-masked]>,
>        "Norimi Kawashima (E-mail)" <[email-masked]>,
>        "Ole Pedersen (E-mail)" <[email-masked]>,
>        "Patrick Powell (E-mail)" <[email-masked]>,
>        "Paul Kwan (E-mail)" <[email-masked]>,
>        "Paul Moore (E-mail)" <[email-masked]>,
>        "Peter Michalek (E-mail)" <[email-masked]>,
>        "Peter Zehler (E-mail)" <[email-masked]>,
>        "Phil DeBecker (E-mail)" <[email-masked]>,
>        "Rajesh Chawla (E-mail)" <[email-masked]>,
>        "Randy Turner (E-mail)" <[email-masked]>,
>        "Rick Yardumiun (E-mail)" <[email-masked]>,
>        "Shivan Albright (E-mail)"
<[email-masked]>,
>        "Steve Thorne (E-mail)"
<THORNE_STEVE/[email-masked]>,
>        "Swen Johnson (E-mail)" <[email-masked]>,
>        "Tetsuya Morita (E-mail)" <[email-masked]>,
>        "Tom Hastings (E-mail)" <[email-masked]>,
>        "Toshiya Nakazawa (E-mail)" <[email-masked]>,
>        "Xavier Riley (E-mail)" <[email-masked]>,
>        "Yuji Sasaki (E-mail)" <[email-masked]>
>From: Tom Hastings <[email-masked]>
>Subject: Updated IPP Set 1 operations spec (attached)
>
>I've updated the Set 1 operations (Hold-Job, Release-Job, Restart-Job,
>Pause-Printer, Resume-Printer, and Purge-Jobs) as result of the August
>20 Toronto meeting and the telecon, Wednesdayd, Sept 2 and 9.  
>
>I've not been able to post them to the PWG server, so I've attached them
>as agreed on the Sept 9 telecon and sent this message to the 9/3 bakeoff
>mailing list.  I'll also post them as soon as I can.
>
>Attached are the .doc file with revisions and the .pdf with revisions
>and the .pdf without revisions and the .txt without revisions.
>
>This spec is the one that will be used during the bake off for testing
>these new OPTIONAL operations.  
>
>Please read and send any comments to the mailing list.  We will also discuss
>the spec at next Wednesday's telecon: 9/16, 10-12 PDT, 1(800)857-5607,
>passcode: cmanros.
>
>The changes are:
>
>1. Changed the document from an IETF to a PWG DRAFT
>
>2. Removed the Reprocess-Job operation altogether.  We need to analyze
>the accounting problem starting with requirements, rather than adding
>the Reprocess-Job operation now in the name of helping accounting
>applications.
>
>3. I did not close up the opcode assignments, as agreed to on the telecon,
>since Paul had already changed his code to agree with the previous version
>(without implementing the Reprocess-Job operation).
>
>4. Clarified that the job operations return the "job-state" and,
>OPTIONALLY, "job-state-reasons" attributes as Group 3 Job Attributes.
>
>5. Made the following changes to the Restart-Job operation:
>
>a. added the OPTIONAL "job-held-until" operation attribute, so that the job 
>can be restarted but put into the 'pending-held' state immediately.  (Then
we 
>can add a Modify-Job operation in the future to modify other Job Template 
>attributes before the client releases the job using Release-Job).
>
>b. Indicated that Restart-Job MAY be supported for jobs in the 'processing'
>or 'processing-stopped' states.
>
>c. Added the 'job-restartable' value to the "job-state-reasons" attribute
>to indicate when a job is restartable using the Restart-Job operation.
>
>6. Clarified the "job history" concept as an OPTIONAL sub-state of
>'completed',
>'aborted', or 'canceled' job states.  If the "job history" concept is
>supported, clients may query such jobs using the Get-Job-Attributes and 
>Get-Jobs operations. 
>
>7. Add a 'restartable' value to the "job-state-reasons" job attribute which
>is present in the job's job-state-reasons attribute when the client is
>able to restart the job using the Restart-Job operation and is absent
>when the job cannot be restarted. 
>
>8. Added the picture to the Printer operations section, so that we can see
>the source of print jobs to a device that do not come throuth the IPP
>Printer object, so that we can talk about that other job source.
>
>9. Indicated for Pause-Printer and Purge-Jobs, whether it affects job 
>submitted from other sources than the IPP Printer object in question,
>depends on implementation.
>
>10. Clarified that the Purge-Jobs operation deletes all jobs regardless of
>state, including all jobs in the Printer object's "job-history".  Indicated
>that an operator can cancel all jobs and put them into the "job history",
>by using the Cancel-Job operation on each job.  Presumably a client that
>shows the active jobs is likely to allow the operator to select some or
>all of the jobs and hit the cancel button (cancelling the selected jobs).
>
>Tom

---

From: Ron Bergman <[email-masked]>
Date: Tue, 15 Sep 1998 14:31:41 -0700 (Pacific Daylight Time)

Tom,

I didn't see an email notice on the telecon.  What is the phone number?

I am guessing that the time is 10AM PDT and the passcode is CMANROS.

(I am also testing to see if I am still on the IPP server.)

	Ron Bergman
	Dataproducts Corp.