Subject: [IPP] Interim draft of IPP Everywhere Project Charter (2 March 2010)

From: Ira McDonald <[email-masked]>
Date: Tue, 2 Mar 2010 16:24:31 -0500

Hi,

Based on Mike Sweet's comments, I have just posted an Interim
draft of the IPP Everywhere Project Charter at:

  ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeverywhere-charter-20100302.pdf / doc
  - clean copy with line numbers

  ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeverywhere-charter-20100302-rev.pdf
/doc
  - redline copy with line numbers

Please send comments ASAP and before next IPP WG meeting on 15 March.

Cheers,
- Ira (IPP co-editor)

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
winter:
  579 Park Place  Saline, MI  48176
  734-944-0094
summer:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Wed, 3 Mar 2010 22:04:23 -0800

> Please send comments ASAP and before next IPP WG meeting on 15 March.

I still think we need to remove OSS-2 and add an objective to identify and/or (re)define a raster format.

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Ira McDonald <[email-masked]>
Date: Thu, 4 Mar 2010 11:21:27 -0500

Hi Mike,

If you really think that we're going to need not just a subset of
an existing raster format, but actually to (re)define a raster
format, then we're going to have to add a 3rd spec.

Because the SC will want a separate document, because the
PWG prototyping requirements for document formats are much
higher - i.e., a full coverage implementation, example files, and
details.

Both PWG PDF/is and PWG XHTML-Print went through this
more stringent process.

For PDF/is, the principal editor Rick Seeler (Adobe) just
implemented every feature as the design firmed up in his
sample documents and demonstrated correct behavior with
Acrobat Reader and another application - he also formally
collaborated with the PDF/A folks about the nuts and bolts.

A raster format is much simpler than PDF but if we bury it in
the one standards-track IPP EW spec, then that whole spec
will be held up in Prototype status by the more stringent
process - not desirable.

I suggest, if CUPS Raster is the starting point then Apple
and CUPS team revise the CUPS Raster format officially
(with a named variant?) to cover the IPP Everywhere
mobile requirements and then let the PWG IPP EW just
reference that revised format.

The new raster format could still be done *with* the PWG,
 it's just not ideal *in* the PWG (which has put the "don't
develop any new document formats" in most every project
charter for a decade).

Cheers,
- Ira

---

From: "William Wagner" <[email-masked]>
Date: Thu, 4 Mar 2010 13:12:34 -0500

Considering that, as stated in the PWG Process document, the requirements
are established after the Charter is approved, the Charter perhaps should
not be so specific. Since requirements have not yet been considered by the
group in general, it would seem premature to say whether or not a new
protocol may be considered or how many documents must be generated.

I would observe that I see nothing in the Problem Statement that clearly
predicates either the OSS or OBJ statements. Indeed, this Charter appears to
suggest that the solution has already been decided upon, which may indeed be
the case. Considering that the problem statement is real and should be
addressed for the benefit of the industry as well as the users, presupposing
the solution seems inappropriate.

At any rate, I suggest dropping OSS-2 and, if desired, making the "use of
existing data formats, protocols and bindings" an objective. (I regard
objectives as more amenable to reconsideration as a solution to the problem
is considered than out-of-scope statements.) I would not suggest adding
"(re)design of a raster format" as an objective, although "defining a
solution appropriate to a broad range of print capable devices from low end
ink-jets to enterprise MFDs" (or whatever) might be an appropriate objective
that follows from the problem statement.

Bill Wagner

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ira
McDonald
Sent: Thursday, March 04, 2010 11:21 AM
To: Michael Sweet; Ira McDonald
Cc: [email-masked]
Subject: [IPP] Re: Interim draft of IPP Everywhere Project Charter (2 March
2010)

Hi Mike,

Cheers,
- Ira

---

From: Ira McDonald <[email-masked]>
Date: Thu, 4 Mar 2010 13:20:01 -0500

Hi Bill,

Agreed - I'll rewrite it as an Objective per your suggestions.

But I'll note, that if we do decide we need a new document
format (new protocols are out-of-scope entirely in IPP EW),
we'll have to revise and re-approve the charter.

Working Group charters have open-ended continuing update
activities.  But Project charters have always had to enumerate
and give a proposed schedule for every deliverable spec.

For example, we had to revise IPPv2 Charter to allow Tom
to finish the spec that's now known as JPS2.

Cheers,
- Ira