Subject: [IPP] Error in IANA registration for number-up-supported

From: Michael Sweet <[email-masked]>
Date: Wed, 14 Sep 2011 12:53:08 -0700

All (particularly Ira... :),

Looks like the IANA registration for number-up-supported is messed up. It currently just says:

Job Template	number-up-supported			integer(1:MAX)	[RFC2911]
but it should be:

Job Template	number-up-supported			1setOf (integer(1:MAX) | rangeOfInteger(1:MAX))	[RFC2911]

__________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Wed, 14 Sep 2011 18:25:58 -0400

Hi Mike,

Yes - it looks like a bug to me too.

We should look through RFC 2911 to see if there are other
complex "xxx-supported" capabilities attributes that didn't
get originally registered correctly in IANA IPP Registry.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - IEEE-ISTO PWG IPP WG
Chair - TCG Embedded Systems Hardcopy SWG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Christmas through April:
  579 Park Place  Saline, MI  48176
  734-944-0094
May to Christmas:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

On Wed, Sep 14, 2011 at 3:53 PM, Michael Sweet <[email-masked]> wrote:

> Job Templatenumber-up-supportedinteger(1:MAX)[RFC2911<http://www.iana.org/go/rfc2911>
> ]but it should be:
>
> Job Templatenumber-up-supported1setOf (integer(1:MAX) |
> rangeOfInteger(1:MAX))[RFC2911 <http://www.iana.org/go/rfc2911>]
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.
>

---

From: Michael Sweet <[email-masked]>
Date: Wed, 14 Sep 2011 15:34:30 -0700

Ira,

I've been doing that as I go through the new-and-improved IPP conformance tests; this is the only one I saw for the required IPP/1.1, 2.0, 2.1, or 2.2 printer attributes.

---

From: Ira McDonald <[email-masked]>
Date: Thu, 15 Sep 2011 16:54:10 -0400

Hi Mike,

Right - I checked RFC 2911 and there aren't any other IPP/1.1
xxx-supported attributes with strange complex datatypes - just
the usual keyword or name stuff.

Searching the IANA registry seems the best way to look for other
quirks - I think we avoided strange complex datatypes for other
xxx-supported in the later IETF/PWG IPP specs.

Note that PWG SM XML schema discarded this strange type
for Capabilities.NumberUp (it's just a set of discrete integers,
no ranges allowed).

Cheers,
- Ira

On Wed, Sep 14, 2011 at 6:34 PM, Michael Sweet <[email-masked]> wrote:

> Ira,
>
> I've been doing that as I go through the new-and-improved IPP conformance
> tests; this is the only one I saw for the required IPP/1.1, 2.0, 2.1, or 2.2
> printer attributes.
>
>>  Job Template number-up-supported  integer(1:MAX) [RFC2911<http://www.iana.org/go/rfc2911>
>> ]but it should be:
>>
>>  Job Template number-up-supported  1setOf (integer(1:MAX) |
>> rangeOfInteger(1:MAX)) [RFC2911 <http://www.iana.org/go/rfc2911>]

---

From: Michael Sweet <[email-masked]>
Date: Thu, 15 Sep 2011 14:23:45 -0700

> for Capabilities.NumberUp (it's just a set of discrete integers,

Yeah, not much to gain from using rangeOfInteger with number-up...

I have a related issue I want to bring up, but in a separate email thread...