Subject: [IPP] Addition to PWG Raster Spec

From: "Petrie, Glen" <[email-masked]>
Date: Mon, 12 Sep 2011 14:57:11 -0700

Please add

Section on Bounding Box 

Definition (Values) of "OrientationEnum"

Suggest adding

Definition (Values) of "FeedOrientationEnum"

            i.e. Normal = 1, Reverse = -1 (??)

New Attribute

PrintContentType: Text, Text+Graphics, Graphics(vector), Photo

This is combined with "OutputType" to optimize output.

This was big discussion in JTAPI definition and it was determine that is
necessary to have both values.

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 12 Sep 2011 15:48:42 -0700

Begin forwarded message:

> From: Michael Sweet <[email-masked]>
> Subject: Re: [IPP] Addition to PWG Raster Spec
> Date: September 12, 2011 3:40:54 PM PDT
> To: "Petrie, Glen" <[email-masked]>
> 
> On Sep 12, 2011, at 2:57 PM, Petrie, Glen wrote:
>> Please add
>>  
>> Section on Bounding Box
> 
> OK.
> 
>> Definition (Values) of “OrientationEnum”
> 
> Oops.
> 
>> Suggest adding
>> Definition (Values) of “FeedOrientationEnum”
> Since these are actual multipliers, not sure this is necessary. I.e. if you were plugging these into a transform matrix they would be the X and Y scaling values applied to the matrix.
> 
>> New Attribute
>> This is combined with “OutputType” to optimize output.
>> This was big discussion in JTAPI definition and it was determine that is necessary to have both values.
> 
> We don't have this in the semantic model or IPP yet. Where do you propose I put this?
> 
> ________________________________________________________________________
> Michael Sweet, Senior Printing System Engineer, PWG Chair
> 
> 
> 
> 
> 

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: "Petrie, Glen" <[email-masked]>
Date: Mon, 12 Sep 2011 15:53:40 -0700

New Attribute

	This was big discussion in JTAPI definition and it was determine
that is necessary to have both values.

We don't have this in the semantic model or IPP yet. Where do you
propose I put this?

I am not sure what you mean "where do you propose I put this"?

If you mean --

Within the PWG Raster it can occupy the first; no, better yet the last 4
bytes of the vender data space and shorten the vendor data space.

If you mean--

Where will the information come from in a SM or IPP "job ticket"; then,
I agree there is no source.  But if an application choices to create a
PWG Raster file and knows the PrintContentType value; then the
application can fill in the field.  The default value of zero ('0') can
represent the value of "unknown" or "not specified".  So the enum could
be

typedef enum {

            NotSpecifed = 0,

            TextOnly,

            TextAndGraphics,

            GraphicsOnly,

            Photo

} ContentTypeEnum

---

From: Ira McDonald <[email-masked]>
Date: Mon, 12 Sep 2011 20:08:19 -0400

Hi,

About "where" - I suggest that this is an IPP Job Template
class attribute and belongs in the PWG Job Ticket as well.
So we'd add it to JPS3 for IPP, I presume.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - IEEE-ISTO PWG IPP WG
Chair - TCG Embedded Systems Hardcopy SWG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Christmas through April:
  579 Park Place  Saline, MI  48176
  734-944-0094
May to Christmas:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

On Mon, Sep 12, 2011 at 6:53 PM, Petrie, Glen <[email-masked]>wrote:

>  ** **
>
> ** **
>
> ****
>
> New Attribute****
>
> PrintContentType: Text, Text+Graphics, Graphics(vector), Photo********
>
> This is combined with “OutputType” to optimize output.********
>
> necessary to have both values.****
>
>  ** **
>  ****
>
> We don't have this in the semantic model or IPP yet. Where do you propose I
> put this?****
>
> ** **
>
> I am not sure what you mean “where do you propose I put this”?****
>
> ** **
>
> If you mean --****
>
> bytes of the vender data space and shorten the vendor data space.****
>
> ** **
>
> If you mean--****
>
> Where will the information come from in a SM or IPP “job ticket”; then, I
> agree there is no source.  But if an application choices to create a PWG
> Raster file and knows the PrintContentType value; then the application can
> fill in the field.  The default value of zero (‘0’) can represent the value
> of “unknown” or “not specified”.  So the enum could be****
>
> ** **
>
> typedef enum {****
>
>             NotSpecifed = 0,****
>
>             TextOnly,****
>
>             TextAndGraphics,****
>
>             GraphicsOnly,****
>
>             Photo****
>
> } ContentTypeEnum****
>
> ** **
>
>
>
> ****
>
> ** **
>
> --
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.
>

---

From: Michael Sweet <[email-masked]>
Date: Sun, 18 Sep 2011 21:31:45 -0700

Glen,

I was more thinking "where to put it in the header", but I've since decided to put PrintQuality in one of the empty cupsInteger slots and put your PrintContentType in the OutputType string field.

Ira,

As for which specification, since the first use is in the PWG Raster Format spec, I'm thinking we should put it in the PWG Raster Format spec and then include it in the list of required IPP Everywhere job template attributes...

Thoughts?

On Sep 12, 2011, at 3:53 PM, Petrie, Glen wrote:

> I am not sure what you mean “where do you propose I put this”?
>  
> If you mean --
> Within the PWG Raster it can occupy the first; no, better yet the last 4 bytes of the vender data space and shorten the vendor data space.
>  
> If you mean--
> Where will the information come from in a SM or IPP “job ticket”; then, I agree there is no source.  But if an application choices to create a PWG Raster file and knows the PrintContentType value; then the application can fill in the field.  The default value of zero (‘0’) can represent the value of “unknown” or “not specified”.  So the enum could be
>  
> typedef enum {
>             NotSpecifed = 0,
>             TextOnly,
>             TextAndGraphics,
>             GraphicsOnly,
>             Photo
> } ContentTypeEnum
>  
> 
> 
>  
> 
> -- 
> believed to be clean. _______________________________________________
> ipp mailing list
> [email-masked]

__________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Ira McDonald <[email-masked]>
Date: Mon, 19 Sep 2011 09:42:23 -0400

Hi Mike,

About putting "print-content-type" (or whatever name) into
PWG Raster rather than JPS3.

I suggest this is an architectural error - it's NOT just useful
for PWG Raster - it's useful for any raster or other opaque
document format.

It was the broader use case that we were concerned about
in the Open Printing Job Ticket API work.

Cheers,
- Ira

On Mon, Sep 19, 2011 at 12:31 AM, Michael Sweet <[email-masked]> wrote:

> Glen,
>
> I was more thinking "where to put it in the header", but I've since decided
> to put PrintQuality in one of the empty cupsInteger slots and put your
> PrintContentType in the OutputType string field.
>
>
> Ira,
>
> As for which specification, since the first use is in the PWG Raster Format
> spec, I'm thinking we should put it in the PWG Raster Format spec and then
> include it in the list of required IPP Everywhere job template attributes...
>
> Thoughts?
>
>
>

---

From: Michael Sweet <[email-masked]>
Date: Mon, 19 Sep 2011 07:45:16 -0700

Ira,

I agree it isn't a great fit in PWG Raster, but if we put it in JPS3 then JPS3 has to be completed before we can finish PWG Raster...

---

From: Ira McDonald <[email-masked]>
Date: Mon, 19 Sep 2011 11:18:29 -0400

Hi Mike,

I see this "print-content-optimize" as bells-and-whistles
anyway.

But practically speaking PWG Raster and IPP JPS3
probably *will* be finished (prototypes complete and
drafts updated to stable and into PWG Last Call) at
about the same time - they're supposed to be - for the
overall IPP Everywhere 1.0 timeline.

You're referring to an explicit PWG Raster dependency
on JPS3 for "print-content-optimize" - I don't think we
need one (PWG Raster can have the header field and
JPS3 can "later" define the IPP attribute).

Cheers,
- Ira

On Mon, Sep 19, 2011 at 10:45 AM, Michael Sweet <[email-masked]> wrote:

> Ira,
>
> I agree it isn't a great fit in PWG Raster, but if we put it in JPS3 then
> JPS3 has to be completed before we can finish PWG Raster...
>
>> I was more thinking "where to put it in the header", but I've since
>> decided to put PrintQuality in one of the empty cupsInteger slots and put
>> your PrintContentType in the OutputType string field.
>>
>>
>> Ira,
>>
>> As for which specification, since the first use is in the PWG Raster
>> Format spec, I'm thinking we should put it in the PWG Raster Format spec and
>> then include it in the list of required IPP Everywhere job template
>> attributes...
>>
>> Thoughts?
>>
>>
>>
>> We don't have this in the semantic model or IPP yet. Where do you propose
>> I put this?****
>>  ** **

---

From: "Paul Tykodi" <[email-masked]>
Date: Mon, 19 Sep 2011 11:34:56 -0400

Hi Mike,

If we follow the idea to put the new value in JPS3 because it is a better
fit and we also reach a point where we believe that PWG Raster is stable but
JPS3 still needs some work to be completed, I believe that our "customers"
could make an informed decision as to whether they believed it would be in
their best interest to begin developing software that was compliant with the
draft PWG Raster specification knowing that changes were still possible but
not probable while we waited for JPS3 to be finished.

Best Regards,

/Paul

--

Paul Tykodi
Principal Consultant
TCS - Tykodi Consulting Services LLC

Tel/Fax: 603-343-1820
Mobile:  603-866-0712
E-mail:  [email-masked]
WWW:   <http://www.tykodi.com/> http://www.tykodi.com

From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael
Sweet
Sent: Monday, September 19, 2011 10:45 AM
To: Ira McDonald
Cc: [email-masked]
Subject: Re: [IPP] Addition to PWG Raster Spec

Ira,

Hi Mike,

Cheers,
- Ira

 <http://sites.google.com/site/highnorthinc>

Glen,

 

Ira,

Thoughts?

 

New Attribute

put this?

If you mean --

If you mean--

Where will the information come from in a SM or IPP "job ticket"; then, I
agree there is no source.  But if an application choices to create a PWG
Raster file and knows the PrintContentType value; then the application can
fill in the field.  The default value of zero ('0') can represent the value
of "unknown" or "not specified".  So the enum could be

typedef enum {

            NotSpecifed = 0,

            TextOnly,

            TextAndGraphics,

            GraphicsOnly,

            Photo

} ContentTypeEnum

-- 
This message has been scanned for viruses and 
dangerous content by  <http://www.mailscanner.info/> MailScanner, and is 

ipp mailing list
[email-masked]

-- 
This message has been scanned for viruses and 
dangerous content by  <http://www.mailscanner.info/> MailScanner, and is 
believed to be clean. 

 

-- 
This message has been scanned for viruses and 
dangerous content by  <http://www.mailscanner.info/> MailScanner, and is 
believed to be clean.

---

From: "Yousey, Marc" <[email-masked]>
Date: Mon, 19 Sep 2011 20:32:21 +0000

PWG 5100.7 already defines the attribute 'print-content-optimize' with values of 'photo', 'graphics', 'text' and 'text-and-grahics'.  Can't we just reference that from the ipp everywhere spec as being required?

M.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Tykodi
Sent: Monday, September 19, 2011 8:35 AM
To: 'Michael Sweet'
Cc: [email-masked]
Subject: RE: [IPP] Addition to PWG Raster Spec

Hi Mike,

If we follow the idea to put the new value in JPS3 because it is a better fit and we also reach a point where we believe that PWG Raster is stable but JPS3 still needs some work to be completed, I believe that our "customers" could make an informed decision as to whether they believed it would be in their best interest to begin developing software that was compliant with the draft PWG Raster specification knowing that changes were still possible but not probable while we waited for JPS3 to be finished.

Best Regards,

/Paul

Tel/Fax: 603-343-1820
Mobile:  603-866-0712
E-mail:  [email-masked]<mailto:[email-masked]>
WWW:  http://www.tykodi.com<http://www.tykodi.com/>
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Sweet
Sent: Monday, September 19, 2011 10:45 AM
To: Ira McDonald
Cc: [email-masked]
Subject: Re: [IPP] Addition to PWG Raster Spec

Ira,

Hi Mike,

Cheers,
- Ira

mailto:[email-masked]<mailto:[email-masked]>

On Mon, Sep 19, 2011 at 12:31 AM, Michael Sweet <[email-masked]<mailto:[email-masked]>> wrote:
Glen,

Ira,

Thoughts?

New Attribute

If you mean --

If you mean--
Where will the information come from in a SM or IPP "job ticket"; then, I agree there is no source.  But if an application choices to create a PWG Raster file and knows the PrintContentType value; then the application can fill in the field.  The default value of zero ('0') can represent the value of "unknown" or "not specified".  So the enum could be

typedef enum {
            NotSpecifed = 0,
            TextOnly,
            TextAndGraphics,
            GraphicsOnly,
            Photo
} ContentTypeEnum

--
This message has been scanned for viruses and
dangerous content by MailScanner<http://www.mailscanner.info/>, and is
believed to be clean. _______________________________________________

ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp

--
This message has been scanned for viruses and
dangerous content by MailScanner<http://www.mailscanner.info/>, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp

--
This message has been scanned for viruses and
dangerous content by MailScanner<http://www.mailscanner.info/>, and is
believed to be clean.

--
This message has been scanned for viruses and
dangerous content by MailScanner<http://www.mailscanner.info/>, and is
believed to be clean.

---

From: Michael Sweet <[email-masked]>
Date: Mon, 19 Sep 2011 14:16:46 -0700

Marc,

Thanks for noticing we have already got the attribute defined - I'll normatively reference it from the PWG Raster spec and then we can decide whether to require it for IPP Everywhere at the F2F...

On Sep 19, 2011, at 1:32 PM, Yousey, Marc wrote:

> PWG 5100.7 already defines the attribute ‘print-content-optimize’ with values of ‘photo’, ‘graphics’, ‘text’ and ‘text-and-grahics’.  Can’t we just reference that from the ipp everywhere spec as being required?
>  
> M.
>  
>  
> If we follow the idea to put the new value in JPS3 because it is a better fit and we also reach a point where we believe that PWG Raster is stable but JPS3 still needs some work to be completed, I believe that our “customers” could make an informed decision as to whether they believed it would be in their best interest to begin developing software that was compliant with the draft PWG Raster specification knowing that changes were still possible but not probable while we waited for JPS3 to be finished.
>  
> Best Regards,
>  
> /Paul
> --
> Paul Tykodi
> Principal Consultant
> WWW:  http://www.tykodi.com