Subject: [IPP] Question on PWG Raster

From: "Petrie, Glen" <[email-masked]>
Date: Mon, 12 Sep 2011 08:43:46 -0700

Michael,

I finally got back to updating my routines for PWG Raster and had a
question.

1.	For ColorSpaceEnum

	a.	Can you confirm that the value 1 == Device RGB was
removed for the new version. Can you remind me why?

Glen

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Petrie, Glen" <[email-masked]>
Date: Mon, 12 Sep 2011 09:06:36 -0700

Second question:

For "CutMedia", the specification state to use the "WhenEnum".  All of
the WhenEnum are "after" events.  I remember a discussion of "cutting a
page before".  So, are there any other WhenEnum values that should be
added.

Glen

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Petrie, Glen
Sent: Monday, September 12, 2011 8:44 AM
To: Michael Sweet; [email-masked]
Subject: [IPP] Question on PWG Raster

Michael,

1.	For ColorSpaceEnum

 

Glen

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner <http://www.mailscanner.info/> , and is

believed to be clean.

---

From: "Petrie, Glen" <[email-masked]>
Date: Mon, 12 Sep 2011 10:02:28 -0700

One more question.

There are two "box sizes"; the Bounding Box and the Image Box.  There is
section for the Image Box but not the Bounding Box.  Can you explain the
difference between the two boxes.

Glen

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Petrie, Glen
Sent: Monday, September 12, 2011 9:07 AM
To: Michael Sweet; [email-masked]
Subject: RE: [IPP] Question on PWG Raster

Second question:

Glen

Michael,

1.	For ColorSpaceEnum

 

Glen

believed to be clean. 

believed to be clean.

---

From: "Petrie, Glen" <[email-masked]>
Date: Mon, 12 Sep 2011 10:13:22 -0700

Another,

I believe the sGrayPrimary is used to specify the base color for
monochrome printing where the base color is black.  The specification
states that the sGrayPrimary replaces the white value.   I believe the
sGrayPrimary replaces the Black value; that is monochrome printing goes
from a color-to-white versus a color-to-black.

What is your understanding?  Or have I misunderstood the meaning and use
of this value?

glen

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Petrie, Glen
Sent: Monday, September 12, 2011 10:02 AM
To: Michael Sweet; [email-masked]
Subject: RE:RE: [IPP] Question on PWG Raster

One more question.

Glen

Second question:

Glen

Michael,

1.	For ColorSpaceEnum

 

Glen

believed to be clean. 

believed to be clean. 

believed to be clean.

---

From: "Petrie, Glen" <[email-masked]>
Date: Mon, 12 Sep 2011 10:23:38 -0700

What are the possible values of "[color]RenderingIntent"?

glen

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Petrie, Glen
Sent: Monday, September 12, 2011 10:13 AM
To: Michael Sweet; [email-masked]
Subject: RE:RE: RE: [IPP] Question on PWG Raster

Another,

glen

One more question.

Glen

Second question:

Glen

Michael,

1.	For ColorSpaceEnum

 

Glen

believed to be clean. 

believed to be clean. 

believed to be clean. 

believed to be clean.

---

From: Michael Sweet <[email-masked]>
Date: Mon, 12 Sep 2011 12:42:13 -0700

On Sep 12, 2011, at 8:43 AM, Petrie, Glen wrote:
> Michael,
>  
> I finally got back to updating my routines for PWG Raster and had a question.
>  
> For ColorSpaceEnum
> Can you confirm that the value 1 == Device RGB was removed for the new version. Can you remind me why?

We don't currently have device RGB in the list of PwgRasterDocumentTypeSupported keywords.

I'm happy to add this, but looking at the previous versions of the PWG Raster spec I don't see it listed... I could see this in the context of scanning and even limited use for printing (a lot of folks use cheap measuring devices and profiling software to produce RGB ICC profiles on the Mac, for example), although I hope it won't get as much use as standard RGB color spaces...

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Michael Sweet <[email-masked]>
Date: Mon, 12 Sep 2011 12:46:07 -0700

Glen,

As far as I know, neither Adobe nor the PWG have defined "before" values for cutting media, and every vendor-specific PDL I have used similarly either says "cut after X" or "cut now", depending on the device.

The current finishing enums include a single "trim" value (the timing is undefined), and JPS3 adds some additional values to cover what is defined in PWG Raster. I don't think we need any more values defined...

On Sep 12, 2011, at 9:06 AM, Petrie, Glen wrote:

> Second question:
>  
> For “CutMedia”, the specification state to use the “WhenEnum”.  All of the WhenEnum are “after” events.  I remember a discussion of “cutting a page before”.  So, are there any other WhenEnum values that should be added.
>  
> Glen
>  
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Petrie, Glen

---

From: Michael Sweet <[email-masked]>
Date: Mon, 12 Sep 2011 12:49:03 -0700

ImagingBoundingBox is the old integer points bounding box. ImageBox is the bounding box in pixels.

Effectively they describe the same thing, but the ImagingBoundingBox values only support gross approximation of the useful content in the page image...

I'll add in the content for ImagingBoundingBox for the next update of the spec.

On Sep 12, 2011, at 10:02 AM, Petrie, Glen wrote:

> One more question.
>  
> There are two “box sizes”; the Bounding Box and the Image Box.  There is section for the Image Box but not the Bounding Box.  Can you explain the difference between the two boxes.
>  
> Glen
>  
>

---

From: "Petrie, Glen" <[email-masked]>
Date: Mon, 12 Sep 2011 12:50:27 -0700

In the March 26 version in Table 1, it list the color space value.

I would like to know if other print vendors want to put back in "device
RGB".

Glen

From: Michael Sweet [mailto:[email-masked]] 
Sent: Monday, September 12, 2011 12:42 PM
To: Petrie, Glen
Cc: [email-masked]
Subject: Re: Question on PWG Raster

	Michael,

	I finally got back to updating my routines for PWG Raster and
had a question.

	1.	For ColorSpaceEnum

		a.	Can you confirm that the value 1 == Device RGB
was removed for the new version. Can you remind me why?

We don't currently have device RGB in the list of
PwgRasterDocumentTypeSupported keywords.

I'm happy to add this, but looking at the previous versions of the PWG
Raster spec I don't see it listed... I could see this in the context of
scanning and even limited use for printing (a lot of folks use cheap
measuring devices and profiling software to produce RGB ICC profiles on
the Mac, for example), although I hope it won't get as much use as
standard RGB color spaces...

---

From: Michael Sweet <[email-masked]>
Date: Mon, 12 Sep 2011 12:52:47 -0700

On Sep 12, 2011, at 10:13 AM, Petrie, Glen wrote:
> Another,
>  
> I believe the sGrayPrimary is used to specify the base color for monochrome printing where the base color is black.  The specification states that the sGrayPrimary replaces the white value.   I believe the sGrayPrimary replaces the Black value; that is monochrome printing goes from a color-to-white versus a color-to-black.
>  
> What is your understanding?  Or have I misunderstood the meaning and use of this value?

Hmm, I'll change the name and semantics to match your understanding (color-to-white), e.g. BlackPrimary and that its use is specific to the Black color space (since that is probably the only useful scenario - print black as this shade of blue...)

---

From: Michael Sweet <[email-masked]>
Date: Mon, 12 Sep 2011 12:54:11 -0700

Same as the SM element: Absolute, Relative, RelativeBpc, Perceptual, Saturation, and Auto.

On Sep 12, 2011, at 10:23 AM, Petrie, Glen wrote:
> What are the possible values of “[color]RenderingIntent”?
>  
> glen
>

---

From: Michael Sweet <[email-masked]>
Date: Mon, 12 Sep 2011 12:56:39 -0700

OK, I see it there, but there was no way to indicate support for this color space in the supporting attribute... :)

On Sep 12, 2011, at 12:50 PM, Petrie, Glen wrote:

> I would like to know if other print vendors want to put back in “device RGB”.
>  
> Glen
>  
>