Subject: [IPP] Questions about the 'finisher-max-capacity' and 'finisher-capacity' keys for the "printer-finisher" attribute (Finishings 2.1)

From: Steven Young via ipp <[email-masked]>
Date: Thu, 7 Jan 2021 19:40:23 +0000

Smith,

Happy New Year!

I sent the draft to CINC for their review.  The following is their understanding and would like your confirmation:

In Figure 2 - PAPI Example of "printer-finisher"
printer-finisher[1] = "index=8;
                      type=stitcher;
                      unit=sheets;
                      maxcapacity=500;
                      capacity=100;"

Our understanding is as follows:
type(IPP) = finDeviceType(RFC3806)
unit(IPP) = finDeviceCapacityUnit(RFC3806)
maxcapacity(IPP) = finDeviceMaxCapacity(RFC3806)
capacity(IPP) = finDeviceCurrentCapacity(RFC3806)

So, finDeviceMaxCapacity is the maximum capacity of finDeviceType finishing can handle with the unit of finDeviceCapacityUnit. Right?

In the case of type=stacker and unit=sheets,  finDeviceMaxCapacity indicates the maximum number of sheets that can be loaded,  and finDeviceCurrentCapacity indicates the remaining number of sheets.

If our understanding is correct, the example in Figure 2 type=stitcher allows stapling 500 sheets of paper at a time.
（Similarly, in Figure 2, when type=puncher, 100 holes can be made at a time.）

We would like to know our understanding of finDeviceMaxCapacity and finDeviceCurrentCapacity is correct.

Can you please confirm that.

I don't know the answers. The definitions for finDeviceMaxCapacity and finDeviceCurrentCapacity in RFC 3806 aren't clear at all on what a maximum capacity or current capacity means in the context of a finisher. It also seems a bit too wide open to let the printer choose the unit type.Some might

Your example also raises an interesting question about stackers. The Finishing MIB defines 'stacker' as a finisher type. But IPP "finishings-col" doesn't have a representation for stackers - it considers a stacker to be an "output-tray".

Mike, what do you think we ought to do about the FinDeviceTypeTC types in the Finishing MIB that don't have IPP equivalents in finishings-col?

FinDeviceTypeTC ::= TEXTUAL-CONVENTION
    STATUS       current
    DESCRIPTION
      "The defined finishing device subunit process
       enumerations."
    SYNTAX       INTEGER {
         other(1),
         unknown(2),
         stitcher(3),
         folder(4),
         binder(5),
         trimmer(6),
         dieCutter(7),
         puncher(8),
         perforater(9),
         slitter(10),
         separationCutter(11),
         imprinter(12),
         wrapper(13),
         bander(14),
         makeEnvelope(15),
         stacker(16),
         sheetRotator(17),
         inserter(18)
        }

Regards,

Steven

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Thu, 7 Jan 2021 21:41:44 +0000

Hi Steven,

> On Jan 7, 2021, at 12:40 PM, Steven Young via ipp <[email-masked]> wrote:
> 
> Smith,
> 
> Happy New Year!
> 

(Below is the response I gave you in our private conversation.)

I don't know the answers. The definitions for finDeviceMaxCapacity and finDeviceCurrentCapacity in RFC 3806 aren't clear at all on what a maximum capacity or current capacity means in the context of a finisher. Ira, can you provide any clarifications on these?

It also seems a bit too wide open to let the printer choose the unit type.

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 7 Jan 2021 17:33:58 -0500

Hi Steven and Smith,

I sure hope Mike chimes in here...

So a couple of observations:

(1) In the example, with "sheets" as the unit, the finishing device
"stitcher" with
a max capacity of "500" can stitch up to 500 sheets together (at once).  The
remaining capacity in this example is meaningless (because this is not an
output
tray, but an intermediate finishing device).

(2) We (the PWG) can't constrain the printer manufacturers at all in their
choice
of capacity unit for a given finishing device - that boat sailed 20 years
ago.

(3) In the case of a finishing device "stitcher", the corresponding
finishing supply
would have to use a meaningful unit, e.g., "tenThousandthsOfInches(3)" for
the
length of the wire spool in the "stitcher".  Note that "sheets" would be a
weird and
ambiguous *supply* unit for a "stitcher".

The re-use of "PrtMarkerSuppliesSupplyUnitTC" for "finSupplyEntry" was sadly
brain-dead.  Because it's a *non-extensible" enumeration in Printer MIB v2
(RFC
3805), not moved to IANA Printer MIB (as it should have been).  By
contrast, the
"FinDeviceTypeTC" is *extensible* and is defined in IANA Finisher MIB.

Mike - over to you.

Cheers,
- Ira

PS - Actually revising either RFC 3805 (Printer MIB) or RFC 3806 (Finisher
MIB)
in the modern IETF standards context is beyond impossible - it would be a
five-year,
political project for Mike and Ira - not going to happen.

*Ira McDonald (Musician / Software Architect)*

*Chair - SAE Trust Anchors and Authentication TF*
*Co-Chair - TCG Trusted Mobility Solutions WG*

*Co-Chair - TCG Metadata Access Protocol SG*

*Chair - Linux Foundation Open Printing WGSecretary - IEEE-ISTO Printer
Working GroupCo-Chair - IEEE-ISTO PWG Internet Printing Protocol WGIETF
Designated Expert - IPP & Printer MIBBlue Roof Music / High North
Inchttp://sites.google.com/site/blueroofmusic
<http://sites.google.com/site/blueroofmusic>http://sites.google.com/site/highnorthinc
<http://sites.google.com/site/highnorthinc>mailto: [email-masked]
<[email-masked]>(permanent) PO Box 221  Grand Marais, MI 49839
906-494-2434*

On Thu, Jan 7, 2021 at 4:41 PM Kennedy, Smith (Wireless & IPP Standards) <
[email-masked]> wrote:

> I sent the draft to CINC for their review.  The following is their
> understanding and would like your confirmation:
>
> So, finDeviceMaxCapacity is the maximum capacity of finDeviceType
> finishing can handle with the unit of finDeviceCapacityUnit. Right?
>
> In the case of type=stacker and unit=sheets,  finDeviceMaxCapacity
> indicates the maximum number of sheets that can be loaded,  and
> finDeviceCurrentCapacity indicates the remaining number of sheets.
>
> If our understanding is correct, the example in Figure 2 type=stitcher
> allows stapling 500 sheets of paper at a time.
> I don't know the answers. The definitions for finDeviceMaxCapacity and
> finDeviceCurrentCapacity in RFC 3806 aren't clear at all on what a maximum
> capacity or current capacity means in the context of a finisher. Ira, can
> you provide any clarifications on these?
>
> Your example also raises an interesting question about stackers. The
> Finishing MIB defines 'stacker' as a finisher type. But IPP
> "finishings-col" doesn't have a representation for stackers - it considers
> a stacker to be an "output-tray".
>
> Mike, what do you think we ought to do about the FinDeviceTypeTC types in
> the Finishing MIB that don't have IPP equivalents in finishings-col?
>