Subject: [IPP] Requesting an exception for IPP Everywhere Self-Certification v1.1 for some as-yet-unannounced models

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Mon, 8 Feb 2021 20:34:45 +0000

Greetings,

HP Inc. is requesting an IPP Everywhere certification exception to be made for some of our upcoming models, to allow these devices to be certified. As per PWG 5100.20-2020 Section 8.1, HP Inc. has filed Issue #68 (https://github.com/istopwg/ippeveselfcert/issues/68 <https://github.com/istopwg/ippeveselfcert/issues/68>) to report the underlying issue, which does cause an unavoidable race condition. Although the models in question have not been released yet and I cannot provide the model names, they won't be released until after July 1, 2021 transition date so we need to figure out how to deal with this before it is too late.

The issues encountered involve the IPP Everywhere Self-Certification v1.1 suite's test I-20 / I-20.1. These printers treat the PWG Raster document format used in the v1.1 tests as a streaming document format. With streaming document formats, the Printer will flow control the TCP connection over which the Document Creation request is being made if any issues such as 'media-needed' prevent processing.

Because ipptool tests are run serially rather than in parallel, the I-20 test's Print-Job operation blocks until media is provided in the input tray. For Test I-20.1 to pass, the media has to remain removed for the duration of I-20 to allow test I-20.1 to examine the Printer's "printer-state-reasons" Printer Description attribute using a Get-Printer-Attributes operation. This produces a deadlock in the current test suite. If the document format used to perform the test was JPEG, the test would pass because the Printer does not treat JPEG JFIF as a streaming document format.

I'm not sure exactly what procedure we want to do here - I suppose it is similar to the "email based registration process". (I'm pretty sure this is the first time we in the PWG have had to handle an IPP Everywhere exception request...)

Please let me know if more information is needed before we discuss this in the IPP WG.

Cheers,
Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Mon, 8 Feb 2021 16:25:56 -0500

Smith,

Let's talk about this tomorrow, but this is exactly the sort of thing that exceptions were made for.

One thing I can probably change in the next update of the 1.1 tools is to use JPEG when JPEG is available, and convert the "media-needed" test to a "media-empty" test when JPEG isn't supported.  Getting parallel testing going will be a *lot* of work, unfortunately... :/

> On Feb 8, 2021, at 3:34 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]> wrote:
> 
> Signed PGP part
> Greetings,
> 
> HP Inc. is requesting an IPP Everywhere certification exception to be made for some of our upcoming models, to allow these devices to be certified. As per PWG 5100.20-2020 Section 8.1, HP Inc. has filed Issue #68 (https://github.com/istopwg/ippeveselfcert/issues/68) to report the underlying issue, which does cause an unavoidable race condition. Although the models in question have not been released yet and I cannot provide the model names, they won't be released until after July 1, 2021 transition date so we need to figure out how to deal with this before it is too late.
> 

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 23 Feb 2021 22:43:47 +0000

Hi Mike,

Should I file some additional issues in ippeveselfcert for the incremental shift to JPEG for v1.1 I-20 / I-20.1, and a different one in ippsample to request that ipptool be extended to support a "STATUS" directive etc. that will monitor the status in the background or in a separate thread for some duration, so that the parallelism can be supported but in a constrained and simple manner?

Smith

From: Michael Sweet <[email-masked]>
Sent: Monday, February 8, 2021 2:26 PM
To: Kennedy, Smith (Wireless & IPP Standards) <[email-masked]>
Cc: PWG IPP Workgroup <[email-masked]>
Subject: Re: [IPP] Requesting an exception for IPP Everywhere Self-Certification v1.1 for some as-yet-unannounced models

Smith,

> On Feb 8, 2021, at 3:34 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]<mailto:[email-masked]>> wrote:
>
> Signed PGP part
> Greetings,
>
> HP Inc. is requesting an IPP Everywhere certification exception to be made for some of our upcoming models, to allow these devices to be certified. As per PWG 5100.20-2020 Section 8.1, HP Inc. has filed Issue #68 (https://github.com/istopwg/ippeveselfcert/issues/68<https://github.com/istopwg/ippeveselfcert/issues/68>) to report the underlying issue, which does cause an unavoidable race condition. Although the models in question have not been released yet and I cannot provide the model names, they won't be released until after July 1, 2021 transition date so we need to figure out how to deal with this before it is too late.
>

________________________
Michael Sweet

---

From: Michael Sweet via ipp <[email-masked]>
Date: Tue, 23 Feb 2021 21:13:11 -0500

Smith,

Might as well.

Also, FWIW the "STATUS" directive is already taken (to specify acceptable status-code values in a response) but we can some up with a different name for the background test.

> On Feb 23, 2021, at 5:43 PM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]> wrote:
> 
> Hi Mike,
> 
> Should I file some additional issues in ippeveselfcert for the incremental shift to JPEG for v1.1 I-20 / I-20.1, and a different one in ippsample to request that ipptool be extended to support a “STATUS” directive etc. that will monitor the status in the background or in a separate thread for some duration, so that the parallelism can be supported but in a constrained and simple manner?
> 
> Smith
> 
> 
> 
> 

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Wed, 24 Feb 2021 22:14:54 +0000

Sent: Tuesday, February 23, 2021 7:13 PM

Smith,

Might as well.
[S.Kennedy] OK will do!

[S.Kennedy] Doh! I didn’t have the man page when I sent that reply. Maybe something like this:
MONITOR-PRINTER-STATE predicate
MONITOR-JOB-STATE jobid predicate
And the semantic would be that when this directive is in a test, a background thread will begin polling the Printer with Get-Printer-Attributes / Get-Job-Attributes operations requesting “printer-state-reasons” or “job-state-reasons” respectively, with the predicate specifying the keywords and other conditions for what to do and when during the test.

> On Feb 23, 2021, at 5:43 PM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi Mike,
>
> From: Michael Sweet <[email-masked]<mailto:[email-masked]>>
> To: Kennedy, Smith (Wireless & IPP Standards) <[email-masked]<mailto:[email-masked]>>
> Cc: PWG IPP Workgroup <[email-masked]<mailto:[email-masked]>>

________________________
Michael Sweet

---

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 24 Feb 2021 17:57:01 -0500

Smith,

That's a good place to start, we can iterate on the name/syntax in the bug.

> On Feb 24, 2021, at 5:14 PM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]> wrote:
> 
>  

________________________
Michael Sweet