Subject: [IPP] RFC: "printer-service-col (collection)" Printer Description

From: Michael Sweet via ipp <[email-masked]>
Date: Tue, 23 Feb 2021 11:01:55 -0500

All,

As part of our discussions during the last F2F, we determined that IPP should expose the Printer MIB's prtGeneralServicePerson element. The MIB definition is just an octet string, but in keeping with IPP System Service's "printer-contact-col" (prtGeneralCurrentOperator) I think we should convert it to a collection that can convey the name, email address, telephone number, and VCARD information.

"printer-service-col (collection)"

This Printer Description attribute contains the contact information for the individual or organization responsible for performing maintenance on the Printer.  Member attributes are the same as the "printer-contact-col" Printer Description attribute [PWG5100.22].

Thoughts?

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Tue, 23 Feb 2021 15:34:01 -0500

Hi Mike,

Agree with the collection and member attributes.  Much better than the flat
octet string in Printer MIB.

Cheers,
- Ira

*Ira McDonald (Musician / Software Architect)*

*Chair - SAE Trust Anchors and Authentication TF*
*Co-Chair - TCG Trusted Mobility Solutions WG*

*Co-Chair - TCG Metadata Access Protocol SG*

*Chair - Linux Foundation Open Printing WGSecretary - IEEE-ISTO Printer
Working GroupCo-Chair - IEEE-ISTO PWG Internet Printing Protocol WGIETF
Designated Expert - IPP & Printer MIBBlue Roof Music / High North
Inchttp://sites.google.com/site/blueroofmusic
<http://sites.google.com/site/blueroofmusic>http://sites.google.com/site/highnorthinc
<http://sites.google.com/site/highnorthinc>mailto: [email-masked]
<[email-masked]>(permanent) PO Box 221  Grand Marais, MI 49839
906-494-2434*

On Tue, Feb 23, 2021 at 11:02 AM Michael Sweet via ipp <[email-masked]> wrote:

> All,
>
> As part of our discussions during the last F2F, we determined that IPP
> should expose the Printer MIB's prtGeneralServicePerson element. The MIB
> definition is just an octet string, but in keeping with IPP System
> Service's "printer-contact-col" (prtGeneralCurrentOperator) I think we
> should convert it to a collection that can convey the name, email address,
> telephone number, and VCARD information.
>
> This Printer Description attribute contains the contact information for
> the individual or organization responsible for performing maintenance on
> the Printer.  Member attributes are the same as the "printer-contact-col"
> Printer Description attribute [PWG5100.22].
>
>
> Thoughts?
>
> ________________________
> Michael Sweet
>
>
>

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Wed, 24 Feb 2021 23:38:38 +0000

+1 Using a collection is a good idea!

In system service, the “printer-contact-col” attribute refers the reader to the “system-contact-col“ attribute. Its “contact-uri“ member attribute doesn’t currently constrain the range of allowable schemes. Do we want to do that or leave it wide open?

Cheers,
Smith
---
Smith Kennedy
[email-masked]

On Feb 23, 2021, at 9:03 AM, Michael Sweet via ipp <[email-masked]> wrote:

 All,

Thoughts?

________________________
Michael Sweet

---

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 24 Feb 2021 19:54:05 -0500

Smith,

We've traditionally left it wide open to allow for other communication methods besides email and telephone...

> On Feb 24, 2021, at 6:38 PM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]> wrote:
> 

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Fri, 26 Feb 2021 00:01:00 +0000

From: Michael Sweet <[email-masked]>
Sent: Wednesday, February 24, 2021 5:54 PM
To: Kennedy, Smith (Wireless & IPP Standards) <[email-masked]>
Cc: PWG IPP Workgroup <[email-masked]>
Subject: Re: [IPP] RFC: "printer-service-col (collection)" Printer Description

Smith,

[S.Kennedy] OK 😊

> On Feb 24, 2021, at 6:38 PM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]<mailto:[email-masked]>> wrote:
>
> [email-masked]<mailto:[email-masked]>
>
>
>> On Feb 23, 2021, at 9:03 AM, Michael Sweet via ipp <[email-masked]<mailto:[email-masked]>> wrote:
>>
>>  All,
>>
>> [email-masked]<mailto:[email-masked]>
>> https://www.pwg.org/mailman/listinfo/ipp<https://www.pwg.org/mailman/listinfo/ipp>

________________________
Michael Sweet