Subject: [IPP] Adding additional IPP Everywhere v1.0 certified products after the v1.0 / v1.1 transition date

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Mon, 8 Feb 2021 20:35:56 +0000

Greetings,

HP Inc. has some products that are or will be certified by the IPP Everywhere Self-Certification v1.0 / v1.1 transition date. But we have some derivatives of those products that won't be released until after the v1.0 / v1.1 transition date. What should the process or policy be for allowing derivatives to be added after the v1.0 / v1.1 transition date? I don't believe we have this documented in PWG 5100.20-2020.

Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Mon, 8 Feb 2021 16:22:32 -0500

Smith,

If the products are part of the same series and are being released within a few (4?) months of each other then I have no objection to adding new models based on the original 1.0 self-certification - I know we'd talked about supporting this sort of follow-on amendment for the list of models, not sure if that discussion made it into the self-cert manual...

I wouldn't want this to be abused (i.e. products are released a year apart and ship with wildly different firmware), but we do need to be flexible - just getting approvals in different countries can affect the availability of new products, not to mention all of the usual product roll-out stuff, holidays, pandemics (!), etc.

> On Feb 8, 2021, at 3:35 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]> wrote:
> 
> Signed PGP part
> Greetings,
> 

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Mon, 8 Feb 2021 23:40:39 +0000

Hi Mike,

> On Feb 8, 2021, at 2:22 PM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
> 

It doesn't appear to have made it. I'll file an errata to have something added, and then we can submit follow-on comments there with guidance once we develop a plan for how we want to handle it.

> I wouldn't want this to be abused (i.e. products are released a year apart and ship with wildly different firmware), but we do need to be flexible - just getting approvals in different countries ca…

Agreed. I can't speak for other vendors but there are some cases where we release new printers 18 months after initial release that have new model names and improved print engines / mechanisms, but nearly identical firmware. (You are probably familiar with this kind of thing.) It gets a bit fuzzy, but one way or another we probably need to add some statement to 5100.20 (or 5100.14?) to clarify this.