Subject: [IPP] EXTRA: IPP WG Agenda 3:00-4:30pm US Eastern (2 September 2021)

From: Ira McDonald via ipp <[email-masked]>
Date: Wed, 1 Sep 2021 20:49:18 -0400

Hi,

Our next regular IPP WG call will be on Thursday
at 12:00-13:30pm US Pacific / 3:00-4:30pm US Eastern

NOTE: Please USE the *NEW* WebEx meeting below!

-------------------------------------------------------
Meeting information
-------------------------------------------------------
PWG Chair is inviting you to a scheduled WebEx meeting.

Occurs every Thursday effective Thursday, January 14, 2021 from
3:00 PM to 4:30 PM, (UTC-05:00) Eastern Time (US & Canada)
1 hr 30 mins

Join meeting
<https://printerworkinggroup.my.webex.com/printerworkinggroup.my/j.php?MTID=m1ec63e3f9ccef2d69934882f93b83b3c>

*More ways to join:*

*Join from the meeting link*
https://printerworkinggroup.my.webex.com/printerworkinggroup.my/j.php?MTID=m1ec63e3f9ccef2d69934882f93b83b3c

*Join by meeting number*
Meeting number (access code): 126 908 4132
Meeting password: 6Zc7eJPWdQ8 (69273579 from phones and video systems)

*Tap to join from a mobile device (attendees only)*
+1-415-655-0001,,1269084132#69273579#
<%2B1-415-655-0001,,*01*1269084132%2369273579%23*01*> US Toll
Some mobile devices may ask attendees to enter a numeric meeting password.

*Join by phone*
+1-415-655-0001 US Toll
Global call-in numbers
<https://printerworkinggroup.my.webex.com/printerworkinggroup.my/globalcallin.php?MTID=m706cf95ad2262c1bb03cd4b84278830d>

*Join by video system, application or Skype for business*
Dial [email-masked]
You can also dial 173.243.2.68 and enter your meeting number.

Need help? Go to https://help.webex.com

-------------------------------------------------------

Agenda:
(1) PWG IP Policy, Minute Taker, Roll Call, and Agenda Review
- Volunteer as minute taker?
-- Status of all IPP documents in progress is up-to-date below

(2) Approve IPP minutes from previous meetings
- https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20210812.pdf
-- IPP WG call on 08/12/21
- https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20210817.pdf
-- IPP Sessions at PWG August 2021 F2F

<https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20210817.pdf>

(3) Status/Review of various IPP mailing list notes
- https://www.pwg.org/archives/ipp/2021/020992.html
-- [PWG5100.16] Issue #111: printer-requested-job-attributes not registered
with IANA

(4) Status of AMSC and ISO liaisons w/ PWG (Paul)
- http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20210628.htm
- http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20210726.htm
- http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20210823.htm
-- see PWG Steering Committee minutes from 06/28/21, 07/26/21, 08/23/21

(5) Status of PWG and IPP WG Formal Approvals and Last Calls (All)
- none

(6) Status of Deprecating IPP Print-by-Reference (Mike)
- https://www.pwg.org/archives/ipp/2021/020955.html
-- RFC: Deprecate the Print-URI and Send-URI operations and related
attributes and values
-- IPP WG review on 07/15/21 - Mike to post updated draft or a link

(7) Review of IPP Finishings v3.0 (Smith)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings30-20210808-rev.pdf
-- Prototype draft - for Major update
--  PWG review at PWG Virtual F2F in August 2021 - stopped at section 5.3
-- Schedule - Stable draft in Q4 2021

(8) Status of recent IPP Wiki Pages (Mike)
- https://github.com/istopwg/ippsample/wiki/IPP
-Everywhere-Value-Proposition-Discussion-Points
-- IPP Everywhere Value Proposition Discussion Points
-- PWG discussion at PWG Virtual F2F on 18 August 2020
- https://www.pwg.org/archives/ipp/2020/020773.html
-- Wiki page started for errata discussions
-- Added on 20 November 2020

(9) Status of various IPP documents (All)
* IPP Production Printing Ext v2.0 (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippppx20-20210817-rev.pdf
-- Prototype draft - for a Candidate Standard
-- PWG review at PWG Virtual F2F in August 2021 - completed
-- Waiting on prototyping in ippsample
-- Schedule - Stable draft in Q3/Q4 2021

* IPP Enterprise Printing Ext v2.0 (Smith)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20210423-rev.pdf
-
https://ftp.pwg.org/pub/pwg/ipp/slides/ipp-epx-feature-compatibilityinvestigation-20200604.pdf
-- RFC: printer-storage/-description attributes and printer-state-reasons
values
-- Prototype draft - for a Candidate Standard
-- PWG review at PWG Virtual F2F in August 2021 - completed
-- Schedule - Stable draft in Q4 2021

* IPP Driverless Printing Extensions v2.0 (Smith)
- https://ftp.pwg.org/pub/pwg/ipp/wd-ippnodriver20-20210501-rev.pdf
-- Interim draft - for a Candidate Standard
-- PWG review at PWG Virtual F2F in August 2021 - completed
-- Schedule - Prototype draft in Q4 2021

* IPP 2.0, 2.1, and 2.2 Update (Mike/Ira)
- https://github.com/istopwg/ippsample/wiki/Planned-PWG-Errata-Updates
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippbase23-20210424.pdf
-- Prototype draft - for a PWG Standard
-- PWG review at PWG Virtual F2F in August 2021 - completed
-- Schedule - Stable draft in Q1 2022

* IPP Encrypted Jobs and Documents v1.0 (Mike/Smith)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrustnoone10-20210519-rev.pdf
-- Prototype draft - for a Candidate Standard
-- PWG discussion at PWG Virtual F2F in August 2021
-- Waiting for prototyping
-- Schedule - Stable draft in Q1 2022

* Cloud Registration with X.509 Certificates (Cihan/Mike)
-- Registrations or Updates to IPP INFRA and IPP System Service
-- Gathering a list of potential improvements/extensions
-- PWG discussion at PWG/OP Virtual F2F in May 2021
-- Schedule - TBD

* IPP Everywhere v2.0 (Mike)
- https://github.com/istopwg/ippsample/wiki/Planned-PWG-Errata-Updates
-- Major update - for a Candidate Standard
-- Add TLS/1.2 and/or TLS/1.3, Privacy, Job Accounting as Mandatory
-- Add Feature definitions for "vertical solution" use cases
-- Define a complete IPP Everywhere MFD (add Scan, FaxOut, System services)
-- Define tests to certify standard common features
-- PWG discussion at PWG/OP Virtual F2F in May 2021
-- Make IPP Everywhere 2.0 print-only, defer IPP Everywhere MFD until IPP
Scan
is deployed
-- 2.0 = 1.1 + TLS + privacy + job account + system service for servers
-- Defer cloud, finishings, auth methods, job release, job storage, etc. to
2.1
-- Schedule – TBD

(10) Open Printing update (Ira)
-
https://ftp.pwg.org/pub/pwg/liaison/openprinting/minutes/OP-Minutes-20210810.htm
- https://openprinting.github.io/OpenPrinting-News-August-2021
- https://github.com/OpenPrinting/cups-filters/releases/tag/1.28.10
- https://github.com/michaelrsweet/pappl/releases/tag/v1.1b1
-- See OP Monthly news from 08/10/21
-- See CUPS Filters v1.28.10 release notes from 08/17/21
-- See PAPPL v1.1b1 release notes from 08/31/21
- OP Steering Committee
-- OP monthly calls 07/13/21, 08/10/21, and upcoming 09/07/21

(11) Next IPP Meetings

- IPP WG call on Thu 9 September 2021 at 3:00-4:30pm US Eastern
-- regular meeting

- EXTRA IPP WG call on Thu 16 September 2021 at 3:00-4:30pm US Eastern
-- tentative

- IPP WG call on Thu 23 September 2021 at 3:00-4:30pm US Eastern
-- regular meeting

Cheers,

- Ira

*Ira McDonald (Musician / Software Architect)*

*Chair - SAE Trust Anchors and Authentication TF*
*Co-Chair - TCG Trusted Mobility Solutions WG*

*Co-Chair - TCG Metadata Access Protocol SG*

*Chair - Linux Foundation Open Printing WGSecretary - IEEE-ISTO Printer
Working GroupCo-Chair - IEEE-ISTO PWG Internet Printing Protocol WGIETF
Designated Expert - IPP & Printer MIBBlue Roof Music / High North
Inchttp://sites.google.com/site/blueroofmusic
<http://sites.google.com/site/blueroofmusic>http://sites.google.com/site/highnorthinc
<http://sites.google.com/site/highnorthinc>mailto: [email-masked]
<[email-masked]>(permanent) PO Box 221  Grand Marais, MI 49839
906-494-2434*
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: wamwagner--- via ipp <[email-masked]>
Date: Thu, 9 Sep 2021 15:13:39 -0400

Either I have the wrong link or the IPP call, listed in the Sept 2 Minutes, has been cancelled…I guess? Hope all are healthy.
Thanks,
 Bill W.

From: Ira McDonald via ipp
Sent: Wednesday, September 1, 2021 8:49 PM
To: [email-masked]; Ira McDonald
Subject: [IPP] EXTRA: IPP WG Agenda 3:00-4:30pm US Eastern (2 September 2021)

Hi,

 
 
Join meeting

More ways to join:
 
Join from the meeting link
https://printerworkinggroup.my.webex.com/printerworkinggroup.my/j.php?MTID=m1ec63e3f9ccef2d69934882f93b83b3c
 
Join by meeting number
 
Tap to join from a mobile device (attendees only)
+1-415-655-0001,,1269084132#69273579# US Toll
Some mobile devices may ask attendees to enter a numeric meeting password.
 
Join by phone
+1-415-655-0001 US Toll
Global call-in numbers
 
Join by video system, application or Skype for business
Dial [email-masked]
You can also dial 173.243.2.68 and enter your meeting number.

 
Agenda:
-- [PWG5100.16] Issue #111: printer-requested-job-attributes not registered with IANA

-- RFC: Deprecate the Print-URI and Send-URI operations and related attributes and values
- https://github.com/istopwg/ippsample/wiki/IPP-Everywhere-Value-Proposition-Discussion-Points

- https://ftp.pwg.org/pub/pwg/ipp/slides/ipp-epx-feature-compatibilityinvestigation-20200604.pdf
-- RFC: printer-storage/-description attributes and printer-state-reasons values

-- Make IPP Everywhere 2.0 print-only, defer IPP Everywhere MFD until IPP Scan
-- Defer cloud, finishings, auth methods, job release, job storage, etc. to 2.1
-- Schedule – TBD 

- https://ftp.pwg.org/pub/pwg/liaison/openprinting/minutes/OP-Minutes-20210810.htm

(11) Next IPP Meetings 

Ira McDonald (Musician / Software Architect)
Chair - SAE Trust Anchors and Authentication TF
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
(permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Thu, 9 Sep 2021 19:22:25 +0000

Yep, canceled today.

> On Sep 9, 2021, at 1:13 PM, wamwagner--- via ipp <[email-masked]> wrote:
> 
> From: Ira McDonald via ipp <mailto:[email-masked]>
> To: [email-masked] <mailto:[email-masked]>; Ira McDonald <mailto:[email-masked]>
> Join meeting <https://printerworkinggroup.my.webex.com/printerworkinggroup.my/j.php?MTID=m1ec63e3f9ccef2d69934882f93b83b3c>
> 
> More ways to join:
> 
> https://printerworkinggroup.my.webex.com/printerworkinggroup.my/j.php?MTID=m1ec63e3f9ccef2d69934882f93b83b3c <https://printerworkinggroup.my.webex.com/printerworkinggroup.my/j.php?MTID=m1ec63e3f9ccef2d69934882f93b83b3c>
> 
> Join by meeting number
> +1-415-655-0001,,1269084132#69273579# <tel:%2B1-415-655-0001,,*01*1269084132%2369273579%23*01*> US Toll
> Global call-in numbers <https://printerworkinggroup.my.webex.com/printerworkinggroup.my/globalcallin.php?MTID=m706cf95ad2262c1bb03cd4b84278830d>
> 
> Dial [email-masked] <mailto:[email-masked]>
> You can also dial 173.243.2.68 <http://173.243.2.68> and enter your meeting number.
> Need help? Go to https://help.webex.com <https://help.webex.com>
> 
> 
> 
> - https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20210812.pdf <https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20210812.pdf>
> - https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20210817.pdf <https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20210817.pdf>
> - https://www.pwg.org/archives/ipp/2021/020992.html <https://www.pwg.org/archives/ipp/2021/020992.html>
> - http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20210628.htm <http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20210628.htm>
> - http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20210726.htm <http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20210726.htm>
> - http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20210823.htm <http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20210823.htm>
> - https://www.pwg.org/archives/ipp/2021/020955.html <https://www.pwg.org/archives/ipp/2021/020955.html>
> - https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings30-20210808-rev.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings30-20210808-rev.pdf>
> - https://github.com/istopwg/ippsample/wiki/IPP-Everywhere-Value-Proposition-Discussion-Points <https://github.com/istopwg/ippsample/wiki/IPP-Everywhere-Value-Proposition-Discussion-Points>
> - https://www.pwg.org/archives/ipp/2020/020773.html <https://www.pwg.org/archives/ipp/2020/020773.html>
> - https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippppx20-20210817-rev.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippppx20-20210817-rev.pdf>
> - https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20210423-rev.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20210423-rev.pdf>
> - https://ftp.pwg.org/pub/pwg/ipp/slides/ipp-epx-feature-compatibilityinvestigation-20200604.pdf <https://ftp.pwg.org/pub/pwg/ipp/slides/ipp-epx-feature-compatibilityinvestigation-20200604.pdf>
> - https://ftp.pwg.org/pub/pwg/ipp/wd-ippnodriver20-20210501-rev.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd-ippnodriver20-20210501-rev.pdf>
> - https://github.com/istopwg/ippsample/wiki/Planned-PWG-Errata-Updates <https://github.com/istopwg/ippsample/wiki/Planned-PWG-Errata-Updates>
> - https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippbase23-20210424.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippbase23-20210424.pdf>
> - https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrustnoone10-20210519-rev.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrustnoone10-20210519-rev.pdf>
> - https://github.com/istopwg/ippsample/wiki/Planned-PWG-Errata-Updates <https://github.com/istopwg/ippsample/wiki/Planned-PWG-Errata-Updates>
> - https://ftp.pwg.org/pub/pwg/liaison/openprinting/minutes/OP-Minutes-20210810.htm <https://ftp.pwg.org/pub/pwg/liaison/openprinting/minutes/OP-Minutes-20210810.htm>
> - https://openprinting.github.io/OpenPrinting-News-August-2021 <https://openprinting.github.io/OpenPrinting-News-August-2021>
>  <https://github.com/OpenPrinting/cups-filters/releases/tag/1.28.10>- https://github.com/michaelrsweet/pappl/releases/tag/v1.1b1
>  <https://github.com/michaelrsweet/pappl/releases/tag/v1.1b1>-- See OP Monthly news from 08/10/21
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>