Subject: RE: on <draft-ietf-ippm-owdp-00.txt>'s model

From: "Cole, Robert G (Bob), ALSVC" <[email-masked]>
Date: Tue, 12 Dec 2000 10:57:30 -0500

Stanislav,

Thanks.  I agree with what you are saying.  I would just like to see these
options spelled out in an introductory section of the draft.  I would then
also
like to make sure that the source and sink contrl tables in the
kalbfleisch-sspmmib
draft align with the control requirements of the OWDP-test protocol as
spelled out
in your draft.

Thanks,
Bob

> -----Original Message-----
> From:	stanislav shalunov [SMTP:[email-masked]]
> Sent:	Monday, December 11, 2000 8:26 PM
> To:	Cole, Robert G (Bob), ALSVC
> Cc:	[email-masked]; Carl W. Kalbfleisch; Dan Romascanu; Steve
> Waldbusser; Russell Dietz
> Subject:	Re: on <draft-ietf-ippm-owdp-00.txt>'s model
> 
> "Cole, Robert G (Bob), ALSVC" <[email-masked]> writes:
> 
> > Basically, the model chosen is more complete than I had anticipated
> > (not that this is good or bad).
> [...]
> > An alternative (I think) is to define the OWDP-Test protocol
> > and to rely on the work in the RMONMIB WG to handle the
> > OWDP-Control protocol through SNMP and the current draft
> > MIBs being discussed therein.
> 
> Robert,
> 
> draft-ietf-ippm-owdp-00 defines both OWDP-Control and OWDP-Test, but
> it's not anticipated that all hosts that speak OWDP-Test would
> necessarily also speak OWDP-Control.
> 
> Additionally it should be mentioned that our draft doesn't specify
> protocols used on the unlabeled links of the example setup figure (and
> doesn't even discuss whether there should be a protocol on this links).
> The task of Session-Sender and Session-Receiver configuration could be
> accomplished in a number of different ways.
> 
> This could be SNMP.  This could be sending shell commands over an SSH
> session.  This could be anything.
> 
> I suppose we should explicitly mention the possibility of using
> OWDP-Test without OWDP-Control, which will be done in the next draft
> revision.  This is a prose change only.
> 
> -- 
> Stanislav Shalunov <[email-masked]>	Internet Engineer, Internet2
> 
> A large number of installed systems work by fiat.  That is, they work
> by being declared to work.                             -- Anatol Holt

---

From: "Cole, Robert G (Bob), ALSVC" <[email-masked]>
Date: Tue, 12 Dec 2000 10:54:37 -0500

Henk,

see my responses below.
thx, Bob

> From:	Henk Uijterwaal (RIPE-NCC) [SMTP:[email-masked]]
> Sent:	Monday, December 11, 2000 7:20 PM
> Bob,
> > An alternative (I think) is to define the OWDP-Test protocol and to
> > rely on the work in the RMONMIB WG to handle the OWDP-Control protocol
> > through SNMP and the current draft MIBs being discussed therein.  
> > (see figure below).
> > 
> >        +----------------+              +------------------+
> >        | Session-Source |--OWDP-Test-->| Session-Receiver |
> >        +----------------+              +------------------+
> >               ^                                ^
> >               |                                |
> >              SNMP                             SNMP
> >               |                                |
> >               V                                |
> >        +----------------+<---------------------+
> >        |SNMP Server Appl|
> >        +----------------+            
> 
> In this picture, which process is sitting where and what does SNMP-SA
> exactly tell the SS and SR?  
> 
> My preference would be: 
> 
> SA sits at a control point
> SS and SR are measurement nodes
> 
> SA tells SS to send measurement packets starting at t=x with some set
>             of parameters.
> SA tells SR to expect data from SS starting at t=x
> 
> SS tells SA what it has sent
> SR tells SR what it has received.
> 
> SR combines the 2 to report delays
	[Cole, Robert G (Bob), ALSVC]  Exactly !  If you look at the
Kalbfleisch sspmmib
	draft, it contains two contrl table; one for source and one for
sink.  The sink table
	tells the sink what to expect and when.  Also, now that you all have
a draft containing the
	OWDP-test protocol, we can align the source and sink table contrl
info with your test protocol
	requirements.

> This also works to measure losses (count the number of packets at both
> ends) and thus connectivity.
> 
> > At a minimum, I would hope that your draft would be constructed in
> > such a way that it does not exclude the use of the later model where
> > one uses an SNMP application to configure the test source and sinks
> > and the measurements are run using the OWDP-Test protocol without
> > relying on the OWDP-Control protocol.
> > 
> > I would much appreciate hearing your thoughts on this later approach.
> 
> I think that there is a lot of mileage in this idea.  The feedback that I
> get from our customers on our work (http://www.ripe.net/test-traffic), is
> that they are interested in eventually integrating delay and loss
> measurements in their existing monitoring systems, and not in a
> stand-alone device.  If we come up with our own protocol, then I fear that
> the next thing we have to do, is to write a wrapper around the OWDP setup
> protocol in order to integrate it with SNMP.
	[Cole, Robert G (Bob), ALSVC]  I don't think we are suggesting any
sort of wrapper, but
	i guess I do not fully understand your concern.  I think the control
aspects of the setup protocol 
	are to be contained in the sspmmib source and sink contrl tables on
the respective
	measurement nodes.

> Henk
> 
> --------------------------------------------------------------------------
> ----
> Henk Uijterwaal                    Email: [email-masked]
> RIPE Network Coordination Centre     WWW: http://www.ripe.net/home/henk
> Singel 258                         Phone: +31.20.535-4414,  Fax -4445
> 1016 AB Amsterdam                   Home: +31.20.4195305
> The Netherlands                   Mobile: +31.6.55861746  
> --------------------------------------------------------------------------
> ----
> 
> A man can take a train and never reach his destination.
>                                                (Kerouac, well before
> RFC2780).