Subject: [ippm] packet size distribution of Internet traffic

From: Jing Shen <[email-masked]>
Date: Tue, 15 Apr 2003 22:28:33 +0800 (CST)

Hi, I'm reading some paper on router arch., and found someone announced that average packet size is about 1000b. But some other persons said the packet size distributes in a large spetrum and most of them are of 64byte or 1024byte. I want to know is there any paper on this?  thanks in advance.  

Jing Shen

State Key Lab of CAD&CG
ZheJiang University(YuQuan)
HangZhou, ZheJiang Province 310027
P.R.China

---------------------------------
Do You Yahoo!?
"雅虎邀你参与CCTV-2对话节目调查：移动、联通、灵通，要说爱你不容易

---

From: "Vinay Bannai" <[email-masked]>
Date: Tue, 15 Apr 2003 08:03:46 -0700

Actually, I thought most packet size distributions in the internet had three
peaks. One at around 64 bytes (for TCP ACKs), one at around 1500 bytes (max
MTU of ethernets) and finally at around 576 bytes (for TCP implementations
that don't use path MTU).

Vinay
  -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Jing Shen
  Sent: Tuesday, April 15, 2003 7:29 AM
  To: [email-masked]
  Cc: [email-masked]
  Subject: [e2e] packet size distribution of Internet traffic

  Hi,

  I'm reading some paper on router arch., and found someone announced that
average packet size is about 1000b. But some other persons said the packet
size distributes in a large spetrum and most of them are of 64byte or
1024byte.

  I want to know is there any paper on this?

  thanks in advance.

  Jing Shen

  State Key Lab of CAD&CG

----------------------------------------------------------------------------
--
  Do You Yahoo!?
  "雅虎邀你参与CCTV-2对话节目调查：移动、联通、灵通，要说爱你不容易

---

From: "Petri Helenius" <[email-masked]>
Date: Tue, 15 Apr 2003 19:17:54 +0300

The 576 peak seems to be mostly gone nowadays. It also should be noted
that the packet travelling is 40 bytes, not 64. If you say 64 you should also
say 1514 so we would be comparing apples to apples. (packets travelling in 
Ethernet)

Pete

  ----- Original Message ----- 
  From: Vinay Bannai 
  To: Jing Shen ; [email-masked] 
  Cc: [email-masked] 
  Sent: Tuesday, April 15, 2003 6:03 PM
  Subject: [ippm] RE: [e2e] packet size distribution of Internet traffic

  Actually, I thought most packet size distributions in the internet had three peaks. One at around 64 bytes (for TCP ACKs), one at around 1500 bytes (max MTU of ethernets) and finally at around 576 bytes (for TCP implementations that don't use path MTU). 

  Vinay
    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]On Behalf Of Jing Shen
    Sent: Tuesday, April 15, 2003 7:29 AM
    To: [email-masked]
    Cc: [email-masked]
    Subject: [e2e] packet size distribution of Internet traffic

    Hi,

    I'm reading some paper on router arch., and found someone announced that average packet size is about 1000b. But some other persons said the packet size distributes in a large spetrum and most of them are of 64byte or 1024byte.

    thanks in advance.

    Jing Shen

    State Key Lab of CAD&CG

---

From: Jambi Ganbar <[email-masked]>
Date: Tue, 15 Apr 2003 12:14:22 -0400 (EDT)

An Average for packet size for "Internet" traffic is largely meaningless.
A distribution is a more accurate way of looking at traffic.  Caida.org has
several papers and web pages discussing the topic and from what I have seen in a
few networks they still hold true.

Best
Jambi

vBNS Engineering
(703) 886 1714

On Tue, 15 Apr 2003, Vinay Bannai wrote:

>   "�Ż��������CCTV-2�Ի���Ŀ���飺�ƶ�����ͨ����ͨ��Ҫ˵���㲻����
>
>

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: David Moore <[email-masked]>
Date: Tue, 15 Apr 2003 10:54:40 -0700

> few networks they still hold true.

http://www.caida.org/outreach/papers/2002/Frag/frag.pdf is the most
recent caida paper I can think of with this information.  figure
13 has a fairly representative CDF of packet size distribution from
a wide variety of network types in March 2001.  But it still seemed
to be reasonably correct last time we looked.  The trend has mostly
been to reduction of the bump around 576 (default MTU) and increase
at the high end (from path MTU discovery).

As Jambi says, using average size not a good approach when 50% are
small (<60 bytes) and 25% are large (>1000bytes).

-- david

> >   "ÑÅ»¢ÑûÄã²ÎÓëCCTV-2¶Ô»°½ÚÄ¿µ÷²é£ºÒÆ¶¯¡¢ÁªÍ¨¡¢ÁéÍ¨£¬ÒªËµ°®Äã²»ÈÝÒ×
> >
> >
>